seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2014/10/31, 10:37:59


Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Watch your apt messages today  (Read 4076 times)

0 Members and 1 Guest are viewing this topic.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.172
    • http://landofthebuckeye.net/
Watch your apt messages today
« on: 2013/05/13, 15:45:17 »
Here, it is a good day to wait before allowing d-u:

Code: [Select]
Calculating upgrade... Done
The following packages will be REMOVED:
  alien build-essential bzip2:i386 cdebootstrap debhelper debootstrap defoma devscripts dpkg-dev equivs file:i386
  flashplugin-nonfree freeglut3:i386 googleearth-package gvfs gvfs-backends gvfs-daemons hplip hplip-gui
  java-package kde-plasma-desktop kde-standard kde-workspace kde-workspace-bin kdebase-workspace
  kdebase-workspace-bin kscreensaver kscreensaver-xsavers lesstif2:i386 libacl1:i386 libart-2.0-2:i386
  libasound2:i386 libasyncns0:i386 libattr1:i386 libavahi-client3:i386 libavahi-common3:i386 libbonoboui2-0
  libbsd0:i386 libbz2-1.0:i386 libc6:i386 libc6-i686:i386 libcap2:i386 libcomerr2:i386 libcups2:i386 libcurl3:i386
  libdb5.1:i386 libdbus-1-3:i386 libdirectfb-1.2-9:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386
  libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libexif12:i386 libexpat1:i386 libffi5:i386 libflac8:i386
  libfltk1.1:i386 libfontconfig1:i386 libfontenc1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386
  libgd2-xpm:i386 libgdbm3:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglu1-mesa:i386
  libgnome2-0 libgnomeui-0 libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386 libgpm2:i386
  libgssapi-krb5-2:i386 libice6:i386 libidn11:i386 libieee1284-3:i386 libjack-jackd2-0:i386 libjasper-runtime:i386
  libjasper1:i386 libjbig0:i386 libjpeg62:i386 libjpeg8:i386 libjson0:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 libldap-2.4-2:i386 libltdl7:i386 liblua5.1-0:i386 liblzma5:i386
  liblzo2-2:i386 libmagic1:i386 libmpg123-0:i386 libncurses5:i386 libnspr4:i386 libnspr4-0d:i386 libnss-ldap:i386
  libnss3:i386 libnss3-1d:i386 libodbc1:i386 libogg0:i386 libopenal1:i386 libp11-kit0:i386 libpam0g:i386
  libpciaccess0:i386 libpng12-0:i386 libpopt0:i386 libpulse0:i386 librtmp0:i386 libsamplerate0:i386 libsasl2-2:i386
  libsasl2-modules:i386 libsigc++-2.0-0c2a:i386 libsm6:i386 libsndfile1:i386 libsqlite3-0:i386 libssh2-1:i386
  libssl1.0.0:i386 libstdc++5:i386 libstdc++6:i386 libsvga1:i386 libsysfs2:i386 libtasn1-6:i386 libtdb1:i386
  libtinfo5:i386 libtool libts-0.0-0:i386 libusb-0.1-4:i386 libuuid1:i386 libvorbis0a:i386 libvorbisenc2:i386
  libvorbisfile3:i386 libwrap0:i386 libx11-6:i386 libx11-xcb1:i386 libx86-1:i386 libxau6:i386 libxaw7:i386
  libxcb-glx0:i386 libxcb-render-util0:i386 libxcb-render0:i386 libxcb-shape0:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386
  libxinerama1:i386 libxml2:i386 libxmu6:i386 libxmuu1:i386 libxp6:i386 libxpm4:i386 libxrandr2:i386
  libxrender1:i386 libxslt1.1:i386 libxt6:i386 libxtst6:i386 libxv1:i386 libxxf86dga1:i386 libxxf86vm1:i386 lintian
  liquidsoap liquidsoap-plugin-gstreamer liquidsoap-plugin-lame liquidsoap-plugin-pulseaudio module-assistant
  nvidia-kernel-source odbcinst1debian2:i386 pbuilder printer-driver-postscript-hp quilt rkhunter
  siduction-art-kde-eow siduction-art-kde-ridersonthestorm siduction-art-kde-xmas siduction-art-ksplash-eow
  siduction-art-ksplash-ridersonthestorm siduction-art-ksplash-xmas ttf-mscorefonts-installer wget:i386
  x11-utils:i386 xaw3dg:i386 xutils zlib1g:i386
The following NEW packages will be installed:
  plasma-netbook python3-apt python3-chardet python3-debian python3-magic python3-six
The following packages have been kept back:
  iceweasel
The following packages will be upgraded:
  bsdutils cdrdao console-setup console-setup-linux cpp-4.7 desktop-file-utils dialog g++-4.7 gcc-4.7 gcc-4.7-base
  gcc-4.7-base:i386 gcc-4.8-base gcc-4.8-base:i386 gir1.2-glib-2.0 keyboard-configuration lib32gcc1 lib32stdc++6
  libblkid1 libc-bin libc-dev-bin libc6 libc6-dev libc6-i386 libclone-perl libgbm1 libgcc-4.7-dev libgcc1
  libgfortran3 libgirepository-1.0-1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-dri-experimental libgl1-mesa-glx
  libglapi-mesa libglib2.0-0 libglib2.0-bin libglib2.0-data libglu1-mesa libglu1-mesa-dev libgomp1 libitm1
  libmount1 libopus0 libquadmath0 libraw5 libstdc++6 libstdc++6-4.7-dev libuuid1 locales mesa-common-dev mount
  multiarch-support nscd php5-cli php5-common python-gobject-2 python-xapian util-linux uuid-runtime
59 upgraded, 6 newly installed, 194 to remove and 1 not upgraded.
Need to get 87.6 MB of archives.
After this operation, 249 MB disk space will be freed.
Do you want to continue [Y/n]?
Asus Z87-WS, Core i7-4770, Nvidia GTX-750 Ti, OCZ Revodrive, 2@WD1000DHTZ in BTRFS

Offline Lanzi

  • User
  • Posts: 1.181
    • Preiswerter Urlaub (Zimmer und Ferienwohnungen) im Harz?
Watch your apt messages today
« Reply #1 on: 2013/05/13, 18:26:13 »
Thanks for the warning!!!

We should maybe make a subforum, where ppl could also post, when the just completed a DU and all went well...

Offline ayla

  • User
  • Posts: 1.344
Re: Watch your apt messages today
« Reply #2 on: 2013/05/13, 19:13:38 »
Quote from: "Lanzi"
Thanks for the warning!!!

We should maybe make a subforum, where ppl could also post, when the just completed a DU and all went well...


I think an "all in ordern (again)" post would only make sence as an answer to a post like dibls warning.

greets
ayla
Kernel: 3.17-0.towo.4-siduction-amd64
kept current siduction paint-it-black cinnamon (for the moment :) )
Mobo: ASUS P8Z68-V LE
Intel Core i7-2600K CPU
Intel HD3000/Sandybridge Grafik

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.172
    • http://landofthebuckeye.net/
RE: Re: Watch your apt messages today
« Reply #3 on: 2013/05/13, 23:11:20 »
It got better later in the day -- all the x:i386 packages went, which was OK with me, and only a couple of packages that I needed to reinstall after the d-u was finished.  Running fine now.  Looks like no skype for awhile due to dependencies in the i386 packages.

Yes, I think we can use the existing thread that reports a warning to announce the recovery or the workaround or whatever the resolution becomes.
Asus Z87-WS, Core i7-4770, Nvidia GTX-750 Ti, OCZ Revodrive, 2@WD1000DHTZ in BTRFS

Offline jacmoe

  • User
  • Posts: 26
    • http://www.jacmoe.dk/
RE: Re: Watch your apt messages today
« Reply #4 on: 2013/05/14, 06:44:46 »
That is bad news for people who have Steam installed. :(

I accidentally du'ed today, only to be met with unmet dependencies for some 32 bit libgl mesa libs..
I could probably use force, but I'll wait a couple of days.

Those libs weren't in the to be removed packages, nor were they in the kept back list.
I wouldn't have been able to learn anything useful from browsing the Siduction forum either.
Well, I need the 386 libs for Steam, until they come up with a 64-bit solution.

Offline henning

  • User
  • Posts: 209
RE: Re: Watch your apt messages today
« Reply #5 on: 2013/05/14, 10:12:35 »
Hi,

since you mentioned the "Libgl mesa ..... " I encountered a similiar problem with these, but on closer inspection it only was complaining about not being able to overwrite a *.log file
and stopped the upgrade. I deleted that particular log file and tried again and it worked.
You can never be lost , if you don’t care where you are
=================================
64Bit 2013-2-1 up-to-date auf : Asus P8Z68-Vpro / i7-2600K / 8 GB Ram / OCZ Vertex 4 als Sysstemplatte / 2 x Samsung HD 1 TB & 2 TB

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.172
    • http://landofthebuckeye.net/
RE: Re: Watch your apt messages today
« Reply #6 on: 2013/05/14, 15:05:54 »
Today skype can be installed after you install libasound2:i386 and libc6:i386, and you have to use -force.  Possibly Steam is the same today (I don't use it).

But, skype seems unable to use the onboard sound system -- something is still missing in the i386 packages, I think.
Asus Z87-WS, Core i7-4770, Nvidia GTX-750 Ti, OCZ Revodrive, 2@WD1000DHTZ in BTRFS

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 1.728
RE: Re: Watch your apt messages today
« Reply #7 on: 2013/05/14, 15:25:05 »
I have no problem with steam.
Code: [Select]

root:Defiant> dpkg -l | grep -i alsa | grep i386
ii  libasound2:i386                                            1.0.27-3                           i386         shared library for ALSA applications
ii  libasound2-plugins:i386                                    1.0.27-2                           i386         ALSA library additional plugins
ii  libwine-alsa:i386                                          1.4.1-4                            i386         Windows API implementation - ALSA sound module


Hinweis: Das ist kein Bug ;)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.172
    • http://landofthebuckeye.net/
RE: Re: Watch your apt messages today
« Reply #8 on: 2013/05/14, 15:51:02 »
@towo, I see libasound2-plugins:i386 on your system -- I think skype might need that one.  But when I tried to install that package, and chased its dependencies, I ended up here:

Code: [Select]
root@imerabox:/home/don# apt-get install libmp3lame0:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libavcodec53 : Depends: libmp3lame0 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


but

Code: [Select]
root@imerabox:/home/don# apt-get install libmp3lame0
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libmp3lame0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.


Is this just a temporary situation?
Asus Z87-WS, Core i7-4770, Nvidia GTX-750 Ti, OCZ Revodrive, 2@WD1000DHTZ in BTRFS

Offline michaa7

  • User
  • Posts: 1.899
RE: Re: Watch your apt messages today
« Reply #9 on: 2013/05/14, 16:03:01 »
Maybe it depends where the packages come from, in my case two of them came from dmo:
Quote
# apt-cache policy libmp3lame0 libavcodec53 libasound2-plugins
libmp3lame0:
  Installiert:           1:3.99.5-dmo1
  Installationskandidat: 1:3.99.5-dmo2
  Versionstabelle:
     1:3.99.5-dmo2 0
        900 http://deb-multimedia.org/ sid/main i386 Packages
 *** 1:3.99.5-dmo1 0
...
libavcodec53:
  Installiert:           7:0.10.3-dmo1
  Installationskandidat: 7:0.10.3-dmo1
  Versionstabelle:
 *** 7:0.10.3-dmo1 0
        900 http://deb-multimedia.org/ sid/main i386 Packages
...
libasound2-plugins:
  Installiert:           1.0.27-2
  Installationskandidat: 1.0.27-2
  Versionstabelle:
 *** 1.0.27-2 0
        900 http://http.debian.net/debian/ sid/main i386 Packages
...
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline jacmoe

  • User
  • Posts: 26
    • http://www.jacmoe.dk/
Watch your apt messages today
« Reply #10 on: 2013/05/14, 16:22:09 »
This was the error:
Quote
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libgl1-mesa-dev : Depends: libgl1-mesa-glx (= 8.0.5-4+b1) but 8.0.5-4 is installed
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 8.0.5-4) but 8.0.5-4+b1 is installed
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 8.0.5-4+b1) but 8.0.5-4 is installed
E: Unmet dependencies. Try using -f.

I am doing an -f today. :)

Offline jacmoe

  • User
  • Posts: 26
    • http://www.jacmoe.dk/
Watch your apt messages today
« Reply #11 on: 2013/05/14, 16:44:41 »
So, Steam wants to install libgl1-mesa-dri:i386 ..
Quote
jacmoe@siductionbox:~$ sudo apt-get install libgl1-mesa-dri:i386
[sudo] password for jacmoe:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libgl1-mesa-dri:i386 is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
                   Breaks: libgl1-mesa-glx:i386 (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 8.0.5-4) but 8.0.5-4+b1 is to be installed
                        Breaks: libgl1-mesa-glx (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgles1-mesa : Depends: libglapi-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgles2-mesa : Depends: libglapi-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libglu1-mesa : Breaks: libglu1-mesa:i386 (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libglu1-mesa:i386 : Breaks: libglu1-mesa (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libglu1-mesa-dev : Depends: libglu1-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
jacmoe@siductionbox:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libgl1-mesa-dri libgl1-mesa-glx:i386 libglapi-mesa libglu1-mesa
Suggested packages:
  libglide3
The following packages will be upgraded:
  libgl1-mesa-dri libgl1-mesa-glx:i386 libglapi-mesa libglu1-mesa
4 upgraded, 0 newly installed, 0 to remove and 296 not upgraded.                                                                                                
35 not fully installed or removed.                                                                                                                              
Need to get 21.9 MB of archives.                                                                                                                                
After this operation, 6,144 B of additional disk space will be used.                                                                                            
Do you want to continue [Y/n]? Y
Get:1 http://ftp.dk.debian.org/debian/ unstable/main libgl1-mesa-dri amd64 8.0.5-4+b1 [21.5 MB]
Get:2 http://ftp.dk.debian.org/debian/ unstable/main libgl1-mesa-glx i386 8.0.5-4+b1 [131 kB]                                                                  
Get:3 http://ftp.dk.debian.org/debian/ unstable/main libglapi-mesa amd64 8.0.5-4+b1 [47.0 kB]                                                                  
Get:4 http://ftp.dk.debian.org/debian/ unstable/main libglu1-mesa amd64 8.0.5-4+b1 [191 kB]                                                                    
Fetched 21.9 MB in 16s (1,318 kB/s)                                                                                                                            
(Reading database ... 597042 files and directories currently installed.)
Preparing to replace libgl1-mesa-dri:amd64 8.0.5-4 (using .../libgl1-mesa-dri_8.0.5-4+b1_amd64.deb) ...
Unpacking replacement libgl1-mesa-dri:amd64 ...
dpkg: error processing /var/cache/apt/archives/libgl1-mesa-dri_8.0.5-4+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libgl1-mesa-dri/changelog.Debian.gz', which is different from other instances of package libgl1-mesa-dri:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace libgl1-mesa-glx:i386 8.0.5-4 (using .../libgl1-mesa-glx_8.0.5-4+b1_i386.deb) ...
Unpacking replacement libgl1-mesa-glx:i386 ...
dpkg: error processing /var/cache/apt/archives/libgl1-mesa-glx_8.0.5-4+b1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libgl1-mesa-glx/changelog.Debian.gz', which is different from other instances of package libgl1-mesa-glx:i386
Preparing to replace libglapi-mesa:amd64 8.0.5-4 (using .../libglapi-mesa_8.0.5-4+b1_amd64.deb) ...
Unpacking replacement libglapi-mesa:amd64 ...
dpkg: error processing /var/cache/apt/archives/libglapi-mesa_8.0.5-4+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libglapi-mesa/changelog.Debian.gz', which is different from other instances of package libglapi-mesa:amd64
Preparing to replace libglu1-mesa:amd64 8.0.5-4 (using .../libglu1-mesa_8.0.5-4+b1_amd64.deb) ...
Unpacking replacement libglu1-mesa:amd64 ...
dpkg: error processing /var/cache/apt/archives/libglu1-mesa_8.0.5-4+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libglu1-mesa/changelog.Debian.gz', which is different from other instances of package libglu1-mesa:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libgl1-mesa-dri_8.0.5-4+b1_amd64.deb
 /var/cache/apt/archives/libgl1-mesa-glx_8.0.5-4+b1_i386.deb
 /var/cache/apt/archives/libglapi-mesa_8.0.5-4+b1_amd64.deb
 /var/cache/apt/archives/libglu1-mesa_8.0.5-4+b1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So, I guess I'm screwed?

apt-get -f install doesn't work.

And if I were to remove the offending packages, I would remove my Steam installation.

Online piper

  • Global Moderator
  • User
  • *****
  • Posts: 621
Watch your apt messages today
« Reply #12 on: 2013/05/14, 16:58:20 »
Quote from: "jacmoe"
So, Steam wants to install libgl1-mesa-dri:i386 ..
Quote
jacmoe@siductionbox:~$ sudo apt-get install libgl1-mesa-dri:i386
[sudo] password for jacmoe:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libgl1-mesa-dri:i386 is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
                   Breaks: libgl1-mesa-glx:i386 (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 8.0.5-4) but 8.0.5-4+b1 is to be installed
                        Breaks: libgl1-mesa-glx (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgles1-mesa : Depends: libglapi-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libgles2-mesa : Depends: libglapi-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libglu1-mesa : Breaks: libglu1-mesa:i386 (!= 8.0.5-4) but 8.0.5-4+b1 is to be installed
 libglu1-mesa:i386 : Breaks: libglu1-mesa (!= 8.0.5-4+b1) but 8.0.5-4 is to be installed
 libglu1-mesa-dev : Depends: libglu1-mesa (= 8.0.5-4+b1) but 8.0.5-4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
jacmoe@siductionbox:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libgl1-mesa-dri libgl1-mesa-glx:i386 libglapi-mesa libglu1-mesa
Suggested packages:
  libglide3
The following packages will be upgraded:
  libgl1-mesa-dri libgl1-mesa-glx:i386 libglapi-mesa libglu1-mesa
4 upgraded, 0 newly installed, 0 to remove and 296 not upgraded.                                                                                                
35 not fully installed or removed.                                                                                                                              
Need to get 21.9 MB of archives.                                                                                                                                
After this operation, 6,144 B of additional disk space will be used.                                                                                            
Do you want to continue [Y/n]? Y
Get:1 http://ftp.dk.debian.org/debian/ unstable/main libgl1-mesa-dri amd64 8.0.5-4+b1 [21.5 MB]
Get:2 http://ftp.dk.debian.org/debian/ unstable/main libgl1-mesa-glx i386 8.0.5-4+b1 [131 kB]                                                                  
Get:3 http://ftp.dk.debian.org/debian/ unstable/main libglapi-mesa amd64 8.0.5-4+b1 [47.0 kB]                                                                  
Get:4 http://ftp.dk.debian.org/debian/ unstable/main libglu1-mesa amd64 8.0.5-4+b1 [191 kB]                                                                    
Fetched 21.9 MB in 16s (1,318 kB/s)                                                                                                                            
(Reading database ... 597042 files and directories currently installed.)
Preparing to replace libgl1-mesa-dri:amd64 8.0.5-4 (using .../libgl1-mesa-dri_8.0.5-4+b1_amd64.deb) ...
Unpacking replacement libgl1-mesa-dri:amd64 ...
dpkg: error processing /var/cache/apt/archives/libgl1-mesa-dri_8.0.5-4+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libgl1-mesa-dri/changelog.Debian.gz', which is different from other instances of package libgl1-mesa-dri:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace libgl1-mesa-glx:i386 8.0.5-4 (using .../libgl1-mesa-glx_8.0.5-4+b1_i386.deb) ...
Unpacking replacement libgl1-mesa-glx:i386 ...
dpkg: error processing /var/cache/apt/archives/libgl1-mesa-glx_8.0.5-4+b1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libgl1-mesa-glx/changelog.Debian.gz', which is different from other instances of package libgl1-mesa-glx:i386
Preparing to replace libglapi-mesa:amd64 8.0.5-4 (using .../libglapi-mesa_8.0.5-4+b1_amd64.deb) ...
Unpacking replacement libglapi-mesa:amd64 ...
dpkg: error processing /var/cache/apt/archives/libglapi-mesa_8.0.5-4+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libglapi-mesa/changelog.Debian.gz', which is different from other instances of package libglapi-mesa:amd64
Preparing to replace libglu1-mesa:amd64 8.0.5-4 (using .../libglu1-mesa_8.0.5-4+b1_amd64.deb) ...
Unpacking replacement libglu1-mesa:amd64 ...
dpkg: error processing /var/cache/apt/archives/libglu1-mesa_8.0.5-4+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libglu1-mesa/changelog.Debian.gz', which is different from other instances of package libglu1-mesa:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libgl1-mesa-dri_8.0.5-4+b1_amd64.deb
 /var/cache/apt/archives/libgl1-mesa-glx_8.0.5-4+b1_i386.deb
 /var/cache/apt/archives/libglapi-mesa_8.0.5-4+b1_amd64.deb
 /var/cache/apt/archives/libglu1-mesa_8.0.5-4+b1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So, I guess I'm screwed?

apt-get -f install doesn't work.

And if I were to remove the offending packages, I would remove my Steam installation.


Go to /usr/share/doc/libglapi-mesa

and rename changelog.Debian.gz
 to
changelog.Debian.gz.old

and do that for

libgl1-mesa-dri
libgl1-mesa-glx:i386
libglapi-mesa


and then do
Code: [Select]
apt-get -f install
debian sid  |  apt-get into it

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.172
    • http://landofthebuckeye.net/
Re: RE: Re: Watch your apt messages today
« Reply #13 on: 2013/05/14, 17:50:50 »
Quote from: "michaa7"
Maybe it depends where the packages come from, in my case two of them came from dmo:


PERFECT -- thank you very much michaa!  I had dmo commented out for all the time wheezy was in freeze, and I forgot to uncomment it.

Now the sound packages are updated and skype is working as expected.

Great forum here!   :)
Asus Z87-WS, Core i7-4770, Nvidia GTX-750 Ti, OCZ Revodrive, 2@WD1000DHTZ in BTRFS

Offline Santa

  • User
  • Posts: 154
  • biodegradable member
Re: RE: Re: Watch your apt messages today
« Reply #14 on: 2013/05/14, 20:35:00 »
Quote from: "michaa7"
Maybe it depends where the packages come from, in my case two of them came from dmo:


Yes, it depends. It doesn't suprise me at all, this is because of an unsolved debian problem with binNMUs[1][2], so a package built "normally" will work. It's not the first time this problem happens. This problem can be solved easily on siduction just rebuilding the package, so please, each time you upgrade a package you have installed for both amd64 and i386 and you got something like this:
Code: [Select]

Preparing to replace libgl1-mesa-dri:amd64 8.0.5-4 (using .../libgl1-mesa-dri_8.0.5-4+b1_amd64.deb) ...
Unpacking replacement libgl1-mesa-dri:amd64 ...
dpkg: error processing /var/cache/apt/archives/libgl1-mesa-dri_8.0.5-4+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libgl1-mesa-dri/changelog.Debian.gz', which is different from other instances of package libgl1-mesa-dri:amd64

please tell us, so we can fix it. About llibgl1-mesa-dri, I have just uploaded a fixed mesa to fixes.

[1] a binNMU, in case you don't already know, is a mechanism used by debian to rebuild packages against a newer environment.
[2] There's a discussion going out about how to solve this issue: http://lists.debian.org/5190AEDF.8050500@debian.org
Sometimes standing for what you believe means standing alone.