Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: live-packages in installation  (Read 5089 times)

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
live-packages in installation
« on: 2013/12/29, 01:58:09 »
as it was a rc1 there was some bugs in the release - one major  is that the live-packages and the installer are not removed after installation in the installed system. This is fixed for the final. To remove unneeded live-Packages from a installed system one should run this snippet:

Code: [Select]
apt-get purge  \
           fll-live-initscripts \
           fll-live-utils \
           fll-live-xorgconfig \
           siduction-live-settings-cinnamon* \
           siduction-live-settings-common* \
           siduction-live-settings-gnome* \
           siduction-live-settings-kde* \
           siduction-live-settings-lxde* \
           siduction-live-settings-nox* \
           siduction-live-settings-rqt* \
           siduction-live-settings-xfce* \
           cli-installer \
           fll-installer \
           nbd-client \
           setpassword \
           sidu-installer \
           sshstart

its the same we do after install in the fixed fll-installer.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline sunrat

  • User
  • Posts: 405
Re: live-packages in installation
« Reply #1 on: 2014/01/11, 14:20:50 »
I just got this during d-u -
Code: [Select]
<snip>..........
Selecting previously unselected package linux-image-3.12-7.towo-siduction-amd64.
Preparing to unpack .../linux-image-3.12-7.towo-siduction-amd64_3.12-9_amd64.deb ...
Unpacking linux-image-3.12-7.towo-siduction-amd64 (3.12-9) ...
Preparing to unpack .../python-gi_3.10.2-2_amd64.deb ...
Unpacking python-gi (3.10.2-2) over (3.10.2-1) ...
Preparing to unpack .../distro-defaults_2014.01.10_all.deb ...
Unpacking distro-defaults (2014.01.10) over (2013.12.11) ...
Selecting previously unselected package fll-live-utils.
Preparing to unpack .../fll-live-utils_2014.01.10_amd64.deb ...
Unpacking fll-live-utils (2014.01.10) ...
Selecting previously unselected package fll-live-initscripts.
Preparing to unpack .../fll-live-initscripts_2014.01.10_all.deb ...
############################################################
Installing this package is dangerous and not supported!
Aborting installation.
############################################################
dpkg: error processing archive /var/cache/apt/archives/fll-live-initscripts_2014.01.10_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Preparing to unpack .../udev-config-siduction_2014.01.08_all.deb ...
Unpacking udev-config-siduction (2014.01.08) over (0.12.2) ...
Selecting previously unselected package fll-installer.
Preparing to unpack .../fll-installer_2014.01.10_all.deb ...
Unpacking fll-installer (2014.01.10) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
Processing triggers for man-db (2.6.5-3) ...
Processing triggers for menu (2.1.46) ...
Processing triggers for siduction-dynamic-dms (0.3) ...
Errors were encountered while processing:
 /var/cache/apt/archives/fll-live-initscripts_2014.01.10_all.deb
Log ended: 2014-01-11  23:09:54
I found this thread and purged packages as in the above post. Result -
 
Code: [Select]
The following packages will be REMOVED:
  fll-installer* fll-live-utils* siduction-live-settings-common-december*
  siduction-live-settings-kde-december*
0 upgraded, 0 newly installed, 4 to remove and 30 not upgraded.
35 not fully installed or removed.
After this operation, 410 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 136929 files and directories currently installed.)
Removing siduction-live-settings-kde-december (2013.12.30.2) ...
Purging configuration files for siduction-live-settings-kde-december (2013.12.30.2) ...
Removing siduction-live-settings-common-december (2013.12.30.2) ...
Purging configuration files for siduction-live-settings-common-december (2013.12.30.2) ...
Removing fll-installer (2014.01.10) ...
Removing fll-live-utils (2014.01.10) ...
Processing triggers for man-db (2.6.5-3) ...

Subsequent d-u still wants to install fll-installer fll-live-initscripts fll-live-utils

This is an installation of December final from siduction-13.2.0-december-kde-amd64-201312310241.iso

I just checked the log from the d-u I did immediately after installation and also noticed it had not completed.
it contained these errors:
Code: [Select]
Preparing to unpack .../siduction-live-settings-common-december_2014.01.07_all.deb ...
############################################################
Installing this package is dangerous and not supported!
Aborting installation.
############################################################
dpkg: error processing archive /var/cache/apt/archives/siduction-live-settings-common-december_2014.01.07_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Code: [Select]
Selecting previously unselected package fll-live-xorgconfig.
Preparing to unpack .../fll-live-xorgconfig_2013.12.11_all.deb ...
############################################################
Installing this package is dangerous and not supported!
Aborting installation.
############################################################
dpkg: error processing archive /var/cache/apt/archives/fll-live-xorgconfig_2013.12.11_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Code: [Select]
Preparing to unpack .../siduction-live-settings-kde-december_2014.01.07_all.deb ...
############################################################
Installing this package is dangerous and not supported!
Aborting installation.
############################################################
dpkg: error processing archive /var/cache/apt/archives/siduction-live-settings-kde-december_2014.01.07_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1

I also found this in apt history.log from the first failed d-u:
Code: [Select]
Start-Date: 2014-01-08  02:14:40
Commandline: apt-get dist-upgrade
Install: fll-live-xorgconfig:amd64 (2013.12.11, automatic)
<snip>............
Something went wrong.

Links to full /var/log/apt/history.log and term.log if you need.
https://app.box.com/s/p6iseh9e4b0jg03rhyoj
https://app.box.com/s/ldbal7tjo175ena1ba5c
« Last Edit: 2014/01/11, 16:19:48 by sunrat »

Offline sunrat

  • User
  • Posts: 405
Re: live-packages in installation
« Reply #2 on: 2014/01/12, 01:09:54 »
After more investigation, it appears sidu-installer was not purged by the post-install scripts, and I accidentally missed it when I manually purged. I had updated it manually in the live session before installing.
After purging it today, d-u seemed to complete successfully.
Am I the only one to have had this issue?
« Last Edit: 2014/01/12, 01:24:00 by sunrat »

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: live-packages in installation
« Reply #3 on: 2014/01/12, 03:33:37 »
no - depends on when you installed siduction - see the stickies in the d-u section. The leftovers were our fault, but the current packages should work
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline sunrat

  • User
  • Posts: 405
Re: live-packages in installation
« Reply #4 on: 2014/01/12, 04:05:44 »
Thanks melmarker.
Are you planning to release updated isos?

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.615
Re: live-packages in installation
« Reply #5 on: 2014/01/12, 08:55:07 »
Yes, we do.


greetz
devil

Offline Fuss-im-Ohr

  • Newbie
  • Posts: 4
Re: live-packages in installation
« Reply #6 on: 2014/01/16, 19:32:29 »

Hallo zusammen,


ich hänge da auch etwas in der Schleife nach einer Live-Installation
das System ist ein LXDE-64. Bei der Installation durfte ich das System noch im Live-Modus updaten damit die Installation losgetreten wurde. Update/upgrade funktioniert leider noch nicht. Gibt es schon ein workaround?


Gruss Jürgen




Code: [Select]
root@klumpfuss:/home/fuss-im-ohr# uname -a
Linux klumpfuss 3.12-6.towo-siduction-amd64 #1 SMP PREEMPT Fri Dec 20 17:37:54 UTC 2013 x86_64 GNU/Linux




Code: [Select]
root@klumpfuss:/home/fuss-im-ohr# apt-get update
OK   http://packages.siduction.org unstable InRelease
OK   http://packages.siduction.org unstable InRelease
OK   http://packages.siduction.org unstable InRelease
OK   http://packages.siduction.org unstable InRelease
OK   http://packages.siduction.org unstable InRelease
OK   http://packages.siduction.org unstable InRelease
OK   http://packages.siduction.org unstable/main amd64 Packages                                           
OK   http://http.debian.net unstable InRelease                                                           
OK   http://packages.siduction.org unstable/main amd64 Packages                   
OK   http://packages.siduction.org unstable/main amd64 Packages
OK   http://packages.siduction.org unstable/main amd64 Packages
OK   http://http.debian.net unstable/main amd64 Packages/DiffIndex         
OK   http://packages.siduction.org unstable/main amd64 Packages           
OK   http://packages.siduction.org unstable/main amd64 Packages
OK   http://http.debian.net unstable/contrib amd64 Packages/DiffIndex
OK   http://http.debian.net unstable/non-free amd64 Packages/DiffIndex
OK   http://http.debian.net unstable/contrib Translation-en/DiffIndex
OK   http://http.debian.net unstable/main Translation-de_DE
OK   http://http.debian.net unstable/main Translation-de/DiffIndex
OK   http://http.debian.net unstable/main Translation-en/DiffIndex
OK   http://http.debian.net unstable/non-free Translation-en/DiffIndex
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Paketlisten werden gelesen... Fertig


Code: [Select]
root@klumpfuss:/home/fuss-im-ohr# apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 fll-installer : Hängt ab von: fll-live-initscripts (>= 2013.12.11) ist aber nicht installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.


Code: [Select]
root@klumpfuss:/home/fuss-im-ohr# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  fll-live-initscripts
Die folgenden NEUEN Pakete werden installiert:
  fll-live-initscripts
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 107 nicht aktualisiert.
8 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 57,2 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 171 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
(Lese Datenbank ... 102968 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../fll-live-initscripts_2014.01.10_all.deb ...
############################################################
Installing this package is dangerous and not supported!
Aborting installation.
############################################################
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/fll-live-initscripts_2014.01.10_all.deb (--unpack):
 Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/fll-live-initscripts_2014.01.10_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@klumpfuss:/home/fuss-im-ohr#


Offline Fuss-im-Ohr

  • Newbie
  • Posts: 4
Re: live-packages in installation
« Reply #7 on: 2014/01/16, 21:26:10 »

DAU an Board, hier noch ein paar versuche:


Quote
root@klumpfuss:/home/fuss-im-ohr# apt-get install siduction-live-settings-$foo-december
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket siduction-live-settings--december kann nicht gefunden werden.
root@klumpfuss:/home/fuss-im-ohr#


Quote

root@klumpfuss:/home/fuss-im-ohr# apt-get install siduction-live-settings-$foo-december
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket siduction-live-settings--december kann nicht gefunden werden.
root@klumpfuss:/home/fuss-im-ohr# apt-get upgrade; apt-get install sidu-installer
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 fll-installer : Hängt ab von: fll-live-initscripts (>= 2013.12.11) ist aber nicht installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 fll-installer : Hängt ab von: fll-live-initscripts (>= 2013.12.11) soll aber nicht installiert werden
 sidu-installer : Hängt ab von (vorher): fll-installer (>= 2014.01.10) aber 2014.01.09 soll installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
root@klumpfuss:/home/fuss-im-ohr#

Offline Fuss-im-Ohr

  • Newbie
  • Posts: 4
Re: live-packages in installation
« Reply #8 on: 2014/01/16, 21:29:16 »
Quote
[size=78%]         [/size]
root@klumpfuss:/home/fuss-im-ohr# apt-get install siduction-live-settings-lxde-december
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 fll-installer : Hängt ab von: fll-live-initscripts (>= 2013.12.11) soll aber nicht installiert werden
 siduction-live-settings-lxde-december : Hängt ab von: fll-live-xorgconfig (>= 2014.01.10) soll aber nicht installiert werden
                                         Hängt ab von: sidu-installer (>= 2014.01.10) aber 2014.01.05.3 soll installiert werden
                                         Hängt ab von: siduction-live-settings-common-december (= 2014.01.13) aber 2013.12.30.2 soll installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
root@klumpfuss:/home/fuss-im-ohr#

Offline Fuss-im-Ohr

  • Newbie
  • Posts: 4
Re: live-packages in installation
« Reply #9 on: 2014/01/16, 21:57:09 »

gelöst!


siduction-paste dpkg --purge --force-all fll-installer


hat letzendlich geholfen den Knoten zu lösen, danke an alle im IRC, speziell Agaida   ;)


Gruss Jürgen

Offline wora

  • User
  • Posts: 39
Re: live-packages in installation
« Reply #10 on: 2014/01/23, 11:15:56 »
Hallo,
Ich habe immer noch dieselben Probleme und bei einem dist-upgrade soll fll-live-initscripts wieder installiert werden :


Code: [Select]

root@worabox:/home/rw024419# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden NEUEN Pakete werden installiert:
  fll-installer fll-live-initscripts
Die folgenden Pakete sind zurückgehalten worden:
  phonon-backend-vlc
Die folgenden Pakete werden aktualisiert (Upgrade):
  libsmbclient libwbclient0 samba-common samba-libs sidu-installer smbclient
6 aktualisiert, 2 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
Es müssen noch 5.146 kB von 5.335 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 324 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] J
Holen: 1 http://packages.siduction.org/base/ unstable/main fll-live-initscripts all 2014.01.10 [57,2 kB]
Holen: 2 http://cdn.debian.net/debian/ sid/main libwbclient0 i386 2:4.1.4+dfsg-2 [112 kB]
Holen: 3 http://cdn.debian.net/debian/ sid/main smbclient i386 2:4.1.4+dfsg-2 [330 kB]
Holen: 4 http://cdn.debian.net/debian/ sid/main samba-common all 2:4.1.4+dfsg-2 [245 kB]
Holen: 5 http://cdn.debian.net/debian/ sid/main libsmbclient i386 2:4.1.4+dfsg-2 [138 kB]
Holen: 6 http://cdn.debian.net/debian/ sid/main samba-libs i386 2:4.1.4+dfsg-2 [4.264 kB]
Es wurden 5.146 kB in 3 s geholt (1.510 kB/s).
Vorkonfiguration der Pakete ...
(Lese Datenbank ... 265149 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libwbclient0_2%3a4.1.4+dfsg-2_i386.deb ...
Entpacken von libwbclient0:i386 (2:4.1.4+dfsg-2) über (2:4.1.4+dfsg-1) ...
Vorbereitung zum Entpacken von .../smbclient_2%3a4.1.4+dfsg-2_i386.deb ...
Entpacken von smbclient (2:4.1.4+dfsg-2) über (2:4.1.4+dfsg-1) ...
Vorbereitung zum Entpacken von .../samba-common_2%3a4.1.4+dfsg-2_all.deb ...
Entpacken von samba-common (2:4.1.4+dfsg-2) über (2:4.1.4+dfsg-1) ...
dpkg: Warnung: Altes Verzeichnis »/etc/dhcp3/dhclient-enter-hooks.d« kann nicht gelöscht werden: Das Verzeichnis ist nicht leer
dpkg: Warnung: Altes Verzeichnis »/etc/dhcp3« kann nicht gelöscht werden: Das Verzeichnis ist nicht leer
Vorbereitung zum Entpacken von .../libsmbclient_2%3a4.1.4+dfsg-2_i386.deb ...
Entpacken von libsmbclient:i386 (2:4.1.4+dfsg-2) über (2:4.1.4+dfsg-1) ...
Vorbereitung zum Entpacken von .../samba-libs_2%3a4.1.4+dfsg-2_i386.deb ...
Entpacken von samba-libs:i386 (2:4.1.4+dfsg-2) über (2:4.1.4+dfsg-1) ...
Vormals nicht ausgewähltes Paket fll-live-initscripts wird gewählt.
Vorbereitung zum Entpacken von .../fll-live-initscripts_2014.01.10_all.deb ...
############################################################                                                                                                                                                                                                                   
Installing this package is dangerous and not supported!                                                                                                                                                                                                                       
Aborting installation.                                                                                                                                                                                                                                                         
############################################################                                                                                                                                                                                                                   
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/fll-live-initscripts_2014.01.10_all.deb (--unpack):                                                                                                                                                           
 Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück                                                                                                                                                                                                       
Vormals nicht ausgewähltes Paket fll-installer wird gewählt.                                                                                                                                                                                                                   
Vorbereitung zum Entpacken von .../fll-installer_2014.01.22_all.deb ...                                                                                                                                                                                                       
Entpacken von fll-installer (2014.01.22) ...                                                                                                                                                                                                                                   
Trigger für man-db (2.6.5-3) werden verarbeitet ...                                                                                                                                                                                                                           
Fehler traten auf beim Bearbeiten von:                                                                                                                                                                                                                                         
 /var/cache/apt/archives/fll-live-initscripts_2014.01.10_all.deb                                                                                                                                                                                                               
E: Sub-process /usr/bin/dpkg returned an error code (1)                                                                                                                                                                                                                       
root@worabox:/home/rw024419#                           
[size=78%]

Dann kann ich wieder über die bekannte Prozedur den Ausgangszustand herstellen :


[/size]
Code: [Select]




root@worabox:/home/rw024419# apt-mark hold fll-live-initscripts
fll-live-initscripts auf Halten gesetzt.                                                                                                                                                                                                                                       
root@worabox:/home/rw024419# rm /var/cache/apt/archives/fll-live-initscripts*
root@worabox:/home/rw024419# apt-get -f install
Paketlisten werden gelesen... Fertig                                                                                                                                                                                                                                           
Abhängigkeitsbaum wird aufgebaut.                                                                                                                                                                                                                                             
Statusinformationen werden eingelesen.... Fertig                                                                                                                                                                                                                               
Abhängigkeiten werden korrigiert ... Fertig                                                                                                                                                                                                                                   
Die folgenden Pakete werden ENTFERNT:                                                                                                                                                                                                                                         
  fll-installer                                                                                                                                                                                                                                                               
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 2 nicht aktualisiert.                                                                                                                                                                                                   
6 nicht vollständig installiert oder entfernt.                                                                                                                                                                                                                                 
Nach dieser Operation werden 133 kB Plattenplatz freigegeben.                                                                                                                                                                                                                 
Möchten Sie fortfahren? [J/n] J                                                                                                                                                                                                                                               
(Lese Datenbank ... 265177 Dateien und Verzeichnisse sind derzeit installiert.)                                                                                                                                                                                               
Entfernen von fll-installer (2014.01.22) ...                                                                                                                                                                                                                                   
libwbclient0:i386 (2:4.1.4+dfsg-2) wird eingerichtet ...                                                                                                                                                                                                                       
samba-libs:i386 (2:4.1.4+dfsg-2) wird eingerichtet ...                                                                                                                                                                                                                         
libsmbclient:i386 (2:4.1.4+dfsg-2) wird eingerichtet ...                                                                                                                                                                                                                       
samba-common (2:4.1.4+dfsg-2) wird eingerichtet ...                                                                                                                                                                                                                           
smbclient (2:4.1.4+dfsg-2) wird eingerichtet ...                                                                                                                                                                                                                               
Trigger für libc-bin (2.17-97) werden verarbeitet ...                                                                                                                                                                                                                         
root@worabox:/home/rw024419#               

[/font]
Beim nächsten dist-upgrade beginnt das Spiel von neuem ? Kann man das nicht ein für allemal lösen ?

Über jeden Tip ist dankbar und bedankt sich im voraus
Wora[/code]

Offline sunrat

  • User
  • Posts: 405
Re: live-packages in installation
« Reply #11 on: 2014/01/23, 13:28:21 »
 melmarker wrote in the first post.  melmarker schrieb in den ersten Beitrag.
Do this after installation: Tun Sie dies nach der Installation:
Code: [Select]
apt-get purge fll-live-initscripts fll-live-utils fll-live-xorgconfig siduction-live-settings-cinnamon* siduction-live-settings-common* siduction-live-settings-gnome* siduction-live-settings-kde* siduction-live-settings-lxde* siduction-live-settings-nox* siduction-live-settings-rqt* siduction-live-settings-xfce* cli-installer fll-installer nbd-client setpassword sidu-installer sshstart
This is reported fixed in the new sidu-installer. You can upgrade the package sidu-installer in the live session until new install images are released.
From the live session only, not after install:
Code: [Select]
apt-get update; apt-get install sidu-installer
Dies soll in der neuen sidu-installer fixiert. Sie können das Paket sidu-installer in der Live-Session-Upgrade installieren, bis neue Bilder veröffentlicht werden.
Von der Live-Session nur, nicht nach der Installation:
Code: [Select]
apt-get update; apt-get install sidu-installerhttp://forum.siduction.org/index.php?topic=4186.0

Wir entschuldigen uns für die Google Translate. Ich spreche nicht gut Deutsch. :)
« Last Edit: 2014/01/24, 01:49:16 by sunrat »

Offline der_bud

  • User
  • Posts: 1.002
  • member
Re: live-packages in installation
« Reply #12 on: 2014/01/23, 13:58:47 »
DE
sunrat hat erklärt wie man im Livesystem vor der Installation dem Problem beikommt, im bereits installierten system haben fll-* und live-* Pakete nichts zu suchen. Anstatt auf hold zu setzen, sollten die gepurged werden. Welche Pakete das sind, zeigt

Code: [Select]
#dpkg -l | grep live-
#dpkg -l | grep fll-

in einem sauberen System sind beide Ausgaben leer. Falls durch irgendein Paket immer wieder was davon reingezogen werden soll, und man weiß nicht warum, kann man aptitude mit why danach fragen

Code: [Select]
#aptitude why fll-installer
i paketfoo$ schlägt vor fll-installer

paketfoo$ sollte dann entfernt werden.

---
EN
sunrat summed up the solution for a live system before install, in an already installed system fll-* and live-* packages have nothing to do and should be purged. Which packages are still there shows

Code: [Select]
#dpkg -l | grep live-
#dpkg -l | grep fll-

that should be empty in a proper system. If any package always tries to pull in fll*-stuff and you don't know why, ask aptitude

Code: [Select]
#aptitude why fll-installer
i packagefoo$ proposes fll-installer

packagefoo$ should then be deleted.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline wora

  • User
  • Posts: 39
Re: live-packages in installation
« Reply #13 on: 2014/01/23, 18:15:17 »
Thanks der_bud and sunrat!!!
But still the same.  >:(  I'm not doing a new install. My system is a very old aptosid to siduction migrated system. The aptitude code didn't bring any paketfoo$ ?


I purged the 3 files:
Code: [Select]

apt-get remove --purge fll-installer
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  fll-installer*
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 2 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 133 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] J
(Lese Datenbank ... 265415 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von fll-installer (2014.01.22) ...
fll-live-utils (2014.01.10) wird eingerichtet ...
root@worabox:/home/rw024419# apt-get remove --purge fll-live-utils
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  fll-live-utils*
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 2 nicht aktualisiert.
Nach dieser Operation werden 86,0 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] J
(Lese Datenbank ... 265378 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von fll-live-utils (2014.01.10) ...
Trigger für man-db (2.6.5-3) werden verarbeitet ...
root@worabox:/home/rw024419# apt-get remove --purge fll-live-initscripts
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Package 'fll-live-initscripts' is not installed, so not removed
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.
[size=78%]


Then I removed the *.debs in the /var/cache:


[/size]
Code: [Select]

root@worabox:/home/rw024419# cd /var/cache/apt/archives
root@worabox:/var/cache/apt/archives# ls -la fll-*
-rw-r--r-- 1 root root 36322 Jan  9 23:16 fll-installer_2014.01.10_all.deb
-rw-r--r-- 1 root root 36452 Jan 22 19:58 fll-installer_2014.01.22_all.deb
-rw-r--r-- 1 root root 57220 Jan  9 23:28 fll-live-initscripts_2014.01.10_all.deb
-rw-r--r-- 1 root root 59916 Jan 12 19:20 fll-live-utils_2014.01.10_i386.deb
root@worabox:/var/cache/apt/archives# rm fll-*
root@worabox:/var/cache/apt/archives# ls -la fll-*
ls: Zugriff auf fll-* nicht möglich: Datei oder Verzeichnis nicht gefunden
[size=78%]


Then as usual apt-get update, apt-get dist-upgrade:


[/size]
Code: [Select]

root@worabox:/var/cache/apt/archives# apt-get update
OK   http://packages.siduction.org unstable InRelease
OK   http://www.deb-multimedia.org wheezy InRelease                               
Ign http://dl.google.com stable InRelease                                         
OK   http://packages.siduction.org unstable InRelease                                                     
OK   http://packages.siduction.org unstable InRelease                                                     
OK   http://dl.google.com stable Release.gpg                                                               
OK   http://packages.siduction.org unstable InRelease                                                                               
OK   http://dl.google.com stable Release                                                                                           
OK   http://www.deb-multimedia.org wheezy/main Sources                                                                             
OK   http://packages.siduction.org unstable InRelease                                                       
OK   http://packages.siduction.org unstable InRelease                                                       
OK   http://www.deb-multimedia.org wheezy/non-free Sources/DiffIndex                                                               
OK   http://dl.google.com stable/main i386 Packages                                                                                 
OK   http://packages.siduction.org unstable/main i386 Packages                                             
OK   http://www.deb-multimedia.org wheezy/main i386 Packages                                               
OK   http://packages.siduction.org unstable/contrib i386 Packages                                         
OK   http://www.deb-multimedia.org wheezy/non-free i386 Packages                                           
OK   http://packages.siduction.org unstable/non-free i386 Packages                 
OK   http://www.deb-multimedia.org wheezy/non-free Sources                                                 
OK   http://packages.siduction.org unstable/main i386 Packages                                             
OK   http://packages.siduction.org unstable/contrib i386 Packages                                         
Ign http://dl.google.com stable/main Translation-de_DE                                                     
Ign http://dl.google.com stable/main Translation-de                                                       
OK   http://packages.siduction.org unstable/non-free i386 Packages                                         
Ign http://dl.google.com stable/main Translation-en                                                       
OK   http://packages.siduction.org unstable/main i386 Packages                                             
OK   http://packages.siduction.org unstable/contrib i386 Packages                 
OK   http://packages.siduction.org unstable/non-free i386 Packages                 
Ign http://www.deb-multimedia.org wheezy/main Translation-de_DE                   
OK   http://packages.siduction.org unstable/main i386 Packages                     
Ign http://www.deb-multimedia.org wheezy/main Translation-de
Ign http://www.deb-multimedia.org wheezy/main Translation-en                       
Ign http://www.deb-multimedia.org wheezy/non-free Translation-de_DE               
OK   http://packages.siduction.org unstable/contrib i386 Packages                 
OK   http://packages.siduction.org unstable/non-free i386 Packages                 
Ign http://www.deb-multimedia.org wheezy/non-free Translation-de                   
Ign http://www.deb-multimedia.org wheezy/non-free Translation-en                   
OK   http://packages.siduction.org unstable/main i386 Packages                     
OK   http://packages.siduction.org unstable/contrib i386 Packages
OK   http://packages.siduction.org unstable/non-free i386 Packages
OK   http://packages.siduction.org unstable/main i386 Packages
OK   http://cdn.debian.net sid InRelease                   
OK   http://cdn.debian.net sid/main i386 Packages/DiffIndex
OK   http://cdn.debian.net sid/contrib i386 Packages/DiffIndex
OK   http://cdn.debian.net sid/non-free i386 Packages/DiffIndex
OK   http://cdn.debian.net sid/contrib Translation-en/DiffIndex               
OK   http://cdn.debian.net sid/main Translation-de_DE                         
OK   http://cdn.debian.net sid/main Translation-de/DiffIndex                   
OK   http://cdn.debian.net sid/main Translation-en/DiffIndex                   
OK   http://cdn.debian.net sid/non-free Translation-en/DiffIndex
Ign http://packages.siduction.org unstable/contrib Translation-de_DE
Ign http://packages.siduction.org unstable/contrib Translation-de
Ign http://packages.siduction.org unstable/contrib Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/non-free Translation-de_DE
Ign http://packages.siduction.org unstable/non-free Translation-de
Ign http://packages.siduction.org unstable/non-free Translation-en
Ign http://packages.siduction.org unstable/contrib Translation-de_DE
Ign http://packages.siduction.org unstable/contrib Translation-de
Ign http://packages.siduction.org unstable/contrib Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/non-free Translation-de_DE
Ign http://packages.siduction.org unstable/non-free Translation-de
Ign http://packages.siduction.org unstable/non-free Translation-en
Ign http://packages.siduction.org unstable/contrib Translation-de_DE
Ign http://packages.siduction.org unstable/contrib Translation-de
Ign http://packages.siduction.org unstable/contrib Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/non-free Translation-de_DE
Ign http://packages.siduction.org unstable/non-free Translation-de
Ign http://packages.siduction.org unstable/non-free Translation-en
Ign http://packages.siduction.org unstable/contrib Translation-de_DE
Ign http://packages.siduction.org unstable/contrib Translation-de
Ign http://packages.siduction.org unstable/contrib Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/non-free Translation-de_DE
Ign http://packages.siduction.org unstable/non-free Translation-de
Ign http://packages.siduction.org unstable/non-free Translation-en
Ign http://packages.siduction.org unstable/contrib Translation-de_DE
Ign http://packages.siduction.org unstable/contrib Translation-de
Ign http://packages.siduction.org unstable/contrib Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Ign http://packages.siduction.org unstable/non-free Translation-de_DE
Ign http://packages.siduction.org unstable/non-free Translation-de
Ign http://packages.siduction.org unstable/non-free Translation-en
Ign http://packages.siduction.org unstable/main Translation-de_DE
Ign http://packages.siduction.org unstable/main Translation-de
Ign http://packages.siduction.org unstable/main Translation-en
Paketlisten werden gelesen... Fertig
root@worabox:/var/cache/apt/archives# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden NEUEN Pakete werden installiert:
  fll-installer fll-live-initscripts fll-live-utils
Die folgenden Pakete sind zurückgehalten worden:
  phonon-backend-vlc
Die folgenden Pakete werden aktualisiert (Upgrade):
  sidu-installer
1 aktualisiert, 3 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
Es müssen noch 154 kB von 306 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 390 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
So I'm there where I started. Any other idea ?Thanks again!Wora

Offline ayla

  • User
  • Posts: 1.710
Re: live-packages in installation
« Reply #14 on: 2014/01/23, 18:23:43 »
Quote
apt-cache rdepends fll-installer
fll-installer
Reverse Depends:
  siduction-live-settings-common-paintitblack
  siduction-live-settings-common-december
  sidu-installer
  cli-installer
so:
Code: [Select]
apt-get purge sidu-installer
greets
ayla
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205