Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [workaround found for]missing suxterm  (Read 4172 times)

Offline ayla

  • User
  • Posts: 1.710
[workaround found for]missing suxterm
« on: 2014/02/08, 11:35:32 »
Hi,

I've installed the 13.2.1 KDE AMD64 Iso right now.

I'm missing the suxterm command. Apt-file search suxterm delivers nothing, apt-cache policy sux says: there is no installation candidate.

Can I get suxterm back somehow?

Of course, if not, there is allways the workaround with "xhost +" and "su -".

greets
ayla
« Last Edit: 2014/02/08, 20:00:55 by ayla »
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.615
Re: missing suxterm
« Reply #1 on: 2014/02/08, 11:49:18 »
As suxterm was part of sux, that is gone for good. I installed on a new notebook yesterday and miss it already :(


greetz
devil

Offline ayla

  • User
  • Posts: 1.710
Re: missing suxterm
« Reply #2 on: 2014/02/08, 12:01:41 »
I suspected something like that... :(

Thanks for clarifying.

So to thoose who like working as root with graphical tools:

Give as user:
Code: [Select]
xhost +
su -
After root-stuff is finished:
Code: [Select]
xhost - greets
ayla
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.152
    • Land of the Buckeye
Re: missing suxterm
« Reply #3 on: 2014/02/08, 13:40:49 »
On a KDE desktop, you can simply begin typing "kdesu konsole" and it will start the launcher.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline ReinerS

  • User
  • Posts: 994
Re: missing suxterm
« Reply #4 on: 2014/02/08, 14:07:46 »
Another available way is gksu

Under xfce gksu xfce4-terminal  or gksu xterm work really well too.

regards

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ayla

  • User
  • Posts: 1.710
Re: missing suxterm
« Reply #5 on: 2014/02/08, 14:45:12 »
On a KDE desktop, you can simply begin typing "kdesu konsole" and it will start the launcher.

Think it's time for me to get used to kdesu, works well...
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline der_bud

  • User
  • Posts: 1.001
  • member
Re: missing suxterm
« Reply #6 on: 2014/02/08, 16:05:05 »
Another more or less odd workaround I found in some magazin would be to use

Code: [Select]
ssh -X root@localhost
They gave the advice to make a sux-alias from that. Otherwise, alias sux='/usr/lib/kde4/libexec/kdesu' should work as well.
« Last Edit: 2014/02/08, 16:15:10 by der_bud »
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline ayla

  • User
  • Posts: 1.710
Re: missing suxterm
« Reply #7 on: 2014/02/08, 19:58:59 »
Otherwise, alias sux='/usr/lib/kde4/libexec/kdesu' should work as well.

Thanks, this is as close on gone suxterm as could be.
My .bashrc now holds a line:

Quote
alias sux='/usr/lib/kde4/libexec/kdesu konsole'

short, familiar call, works well does not work :( , have to dig in deeper...

What is working is:

Code: [Select]
alias sux='/usr/lib/kde4/libexec/kdesu xterm'
Not my preferred terminal, but it does the job for now.

greets
ayla
« Last Edit: 2014/02/08, 21:24:32 by ayla »
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: [workaround found for]missing suxterm
« Reply #8 on: 2014/02/09, 02:35:11 »
maybe this is a better way to emulate sux, but i'm nor sure. In any case this one is platform agnostic

Code: [Select]
alias sux='su -p -l -c x-terminal-emulator'


Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline ayla

  • User
  • Posts: 1.710
Re: [workaround found for]missing suxterm
« Reply #9 on: 2014/02/09, 10:27:37 »
yep, this works with the bash insteed of xterm, thanks.

But, one must not give the -p option, because:

Quote
Error: "/var/tmp/kdecache-cal" is owned by uid 1000 instead of uid 0.

If the line looks like this ev'rything is fine:
Code: [Select]
alias sux='su -l -c x-terminal-emulator'
greets
ayla
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: [workaround found for]missing suxterm
« Reply #10 on: 2014/02/09, 14:22:29 »
Thanks ayla - that one does not preserve the environment, which is maybe better, i'm not sure about the consequences.  I should read again about this.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jjjrrr3

  • User
  • Posts: 40
Re: [workaround found for]missing suxterm
« Reply #11 on: 2014/02/24, 05:32:48 »
This info should go into the manual, which still instructs users to use sux.
« Last Edit: 2014/02/24, 06:35:02 by jjjrrr3 »

Offline hendrikL

  • Global Moderator
  • User
  • *****
  • Gravatar
  • Posts: 523
Re: [workaround found for]missing suxterm
« Reply #12 on: 2014/02/24, 09:24:16 »
An other solution is to add the xhost command to the ".bashrc" like this:

Code: [Select]
## xhost for root ##
xhost + "local:root@localhost"
xhost -

or enable it system wide, and i do not know if this is a security hole,
you can edit "/etc/X11/xsession.d/35x11-common_xhost-local" like this:

Code: [Select]
# This file is sourced by Xsession(5), not executed.

# If xhost (from x11-xserver-utils) is installed, use it to give access
# to the X server to any process from the same user on the local host.
# Unlike other uses of xhost, this is safe since the kernel can check
# the actual owner of the calling process.

if type xhost >/dev/null 2>&1; then
  xhost +si:localuser:$(id -un) || :
fi

if type xhost >/dev/null 2>&1; then
  xhost +si:localuser:root || :
fi

Then you are able to run, after doing a "su", a graphical program like an editor or a filemanager and so on.

But be aware of the security of your system!

Offline clubex

  • User
  • Posts: 265
Re: [workaround found for]missing suxterm
« Reply #13 on: 2014/02/24, 11:42:12 »
As a kde user if I want to work as root in a graphical mode I use the 'run' command and enter dolphin (it'll remember it for future use). From the drop down menu select SU mode or the option to change user and login as root. From this 'rooted' file manager I can do most of the simple tasks that require root access eg. load a config file into kate for editing.