Siduction Forum

BUGS => Bug Archive (DE/EN) => 2012.1 => Topic started by: dibl on 2012/05/17, 00:19:05

Title: Dell Latitude E6500, wireless and ceni
Post by: dibl on 2012/05/17, 00:19:05
I don't have time to chase it further at this moment, but I have a Dell Latitude E6500 with a broken ethernet chip, so it can only use wireless for networking.  The Broadcom chip was correctly detected by the installer (nice job on the installer!) and the b43 firmware was installed. lsmod shows the driver module loaded.  This laptop previously ran siduction with no issue, but I borked it the other day with the KDE 4.8.3 upgrade, and I wanted to try Desperado anyway.

I ran ceni to configure wlan0, first choosing "Roaming", and it finished with no error.  But no wlan0 either.  I tried again with "Scan to connect now" and it's not finding my router or the other nets in the area.

I have to leave now and may not get to fix it until morning. My plan is to manually configure /etc/networking/interfaces, and wpa_supplicant, download the wicd .deb package, and install wicd and try again that way.  Just wanted to let folks know there might be an issue here.
Title: RE: Dell Latitude E6500, wireless and ceni
Post by: dibl on 2012/05/18, 15:23:57
Fixed.  I don't think it's a bug in 2012.1, I think the problem is the odd configuration of this laptop which has no ethernet capability, and a Broadcom 4312 wifi chip that needs nonfree firmware.  Although the installer detected the chip and attempted to install the b43 driver, I think what happened in the background was a failure to grab the firmware from the download site due to lack of ethernet connectivity.  Moreover, the "Firmware on a USB Stick" coverage in the manual doesn't quite get the BCM 4312 working.

For future reference (my own, if no one else's), here's the needed process:

1. Install the OS.  For speed and simplicity, I pulled the SSD, connected it to another 64-bit computer that has ethernet, installed siduction from a USB stick, booted it and ran d-u, added contrib and non-free to the /etc/apt/sources.list.d/debian.list sources, and installed b43-fwcutter and a few of my favorite packages.

You can't run the lpphy installer package at this step, unless it happens that the host computer that you are using has the BCM 4312 wifi chip.  In my case, it was a desktop with no wifi and so the lpphy installer would abort with a "no broadcom chip found" error.

2. Go to this website:

and scroll down to the "b43 - No Internet" section, skip Step 1 and get the two packages shown in Step 2 and save them in ~/home/user.

3. With the SSD back in the Dell E6500, follow the Step 3 procedure, and reboot.

EDIT 9 AUG 2013:  With the newer broadcom firmware package, the Ubuntu instruction is slightly obsolete.  Where it says (for 12.04):

Code: [Select]
sudo b43-fwcutter -w /lib/firmware broadcom-wl-

what you actually need to do, after un-tarring broadcom-wl-5.100.138.tar.bz2, is this (as root):

Code: [Select]
b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl-apsta.o

and that is all.

Voila -- wifi is enabled!

Code: [Select]
don@delle6500:~$ inxi -v3
System:    Host: delle6500 Kernel: 3.3-6.towo.2-siduction-amd64 x86_64 (64 bit, gcc: 4.7.0)
           Desktop: KDE 4.8.3 (Qt 4.8.1) Distro: siduction 12.1-RC1 Desperado - kde - (201205152133)
Machine:   System: Dell product: Latitude E6500
           Mobo: Dell model: 0PP476 Bios: Dell version: A14 date: 07/31/2009
CPU:       Dual core Intel Core2 Duo CPU P8600 (-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 9576.28
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics:  Card: NVIDIA G98M [Quadro NVS 160M] bus-ID: 01:00.0
           X.Org: 1.12.1 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1920x1200@60.0hz
           GLX Renderer: Gallium 0.4 on NV98 GLX Version: 2.1 Mesa 8.0.2 Direct Rendering: Yes
Network:   Card-1: Broadcom BCM4312 802.11b/g LP-PHY driver: b43-pci-bridge bus-ID: 0c:00.0
           IF: wlan0 state: up mac: 00:23:4e:ab:86:7a
           Card-2: Intel 82567LM Gigabit Network Connection driver: e1000e ver: 1.5.1-k port: efe0 bus-ID: 00:19.0
           IF: eth1 state: down mac: 00:21:70:d4:d3:04
Drives:    HDD Total Size: 120.0GB (36.7% used) 1: model: OCZ_VERTEX
Info:      Processes: 157 Uptime: 32 min Memory: 799.9/1997.2MB Runlevel: 5 Gcc sys: 4.7.0 Client: Shell inxi: 1.7.36

EDIT:  This thread can safely be moved to "Installation".