Welcome, Guest. Please login or register.
Did you miss your activation email?

Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Upgrade Warnings (DE / EN) / GNOME 43 is rolling out
« Last post by schtobia on 2022/08/10, 07:47:11 »
Just a small warning that GNOME 43 is landing on sid. gnome itself is still on 42, but various packages have made the jump:

Code: [Select]
gnome-chess/unstable 1:42.1-1 amd64 [aktualisierbar von: 1:42.0-1]
gnome-clocks/unstable 43~beta-1 amd64 [aktualisierbar von: 42.0-1]
gnome-console/unstable 43~beta-1 amd64 [aktualisierbar von: 42~beta-2]
gnome-contacts/unstable 43~beta-1 amd64 [aktualisierbar von: 42.0-2]
gnome-disk-utility/unstable 43~beta-1 amd64 [aktualisierbar von: 42.0-1]
gnome-font-viewer/unstable 43~beta-1 amd64 [aktualisierbar von: 42.0-1]
gnome-logs/unstable 43~beta-1 amd64 [aktualisierbar von: 42.0-1]
gnome-settings-daemon-common/unstable 43~beta-1 all [aktualisierbar von: 42.2-1]
gnome-settings-daemon/unstable 43~beta-1 amd64 [aktualisierbar von: 42.2-1]
gnome-shell-extension-gpaste/unstable 42.1-5 all [aktualisierbar von: 42.1-4]
gnome-sound-recorder/unstable 43~beta-1 all [aktualisierbar von: 42.0-1]
gnome-weather/unstable 43~beta-1 all [aktualisierbar von: 42.0-1]

For those (like myself. ;-)) that like to wait a little longer, a little pin might help:

Code: [Select]
Package: gnome-*
Pin: version 42*
Pin-Priority: 600
22
Software Support (EN) / Re: no tty login
« Last post by jyp on 2022/08/09, 00:09:17 »
@HendrikL
Thank you. Will live with it for a while. ;)
23
Installations-Support (DE) / Re: Verschlüsselung 2022
« Last post by scholle1 on 2022/08/08, 14:44:11 »
Dazu gibt es auch im Handbuch einen Eintrag.

https://manual.siduction.org/index_de.html

Bei dieser Variante wird das gesamte System verschlüsselt und in eine freie Partition oder auf eine komplette Disk geschrieben.
Ausreichende Größe vorausgesetzt.
Meines Wissens bleiben der Bootmanager Grub und eine separate Swap Partition außen vor.

Die HTML Version:
-> Installation -> Installation auf HDD -> System verschlüsseln

Im aktuellen PDF (27.07.2022):
Ab Seite 59 und Verschlüsselung speziell ab Seite 65.


EDIT:
Unverschlüsselte Swap ergänzt.
24
Software - Support / Re: du entfernt plasma-desktop ...
« Last post by jure on 2022/08/07, 21:57:26 »
es ist doch noch nicht ausgestanden, nachdem ein du wie geschrieben problemlos verlief, gibt es unerfüllte Abhängigkeiten für  polkit-kde-agent-1

wie bekomme ich den "Knoten" gelöst ...?

Code: [Select]
apt policy libpolkit-agent-1-0 libpolkit-gobject-1-0 polkit-kde-agent-1 polkitd
polkitd:
  Installiert:           (keine) >> lässt sich nicht installieren, siehe unten**
  Installationskandidat: 0.105-33
  Versionstabelle:
     0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages

polkit-kde-agent-1
polkit-kde-agent-1:
  Installiert:           4:5.25.3-1
  Installationskandidat: 4:5.25.4-1
  Versionstabelle:
     4:5.25.4-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
 *** 4:5.25.3-1 100
        100 /var/lib/dpkg/status

libpolkit-agent-1-0:
  Installiert:           0.105-33
  Installationskandidat: 0.105-33
  Versionstabelle:
 *** 0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libpolkit-gobject-1-0:
  Installiert:           0.105-33
  Installationskandidat: 0.105-33
  Versionstabelle:
 *** 0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Code: [Select]
apt dist-upgrade
....
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 polkit-kde-agent-1 : Hängt ab von: polkitd
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

[root@siductionbox juergen]$ apt --fix-broken install
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Abhängigkeiten werden korrigiert … Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libarmadillo10 libgdal29 libkf5alarmcalendar-data libodbc1 libodbccr2 libopencv-calib3d4.5 libopencv-contrib4.5 libopencv-core4.5 libopencv-dnn4.5
  libopencv-features2d4.5 libopencv-flann4.5 libopencv-highgui4.5 libopencv-imgcodecs4.5 libopencv-imgproc4.5 libopencv-ml4.5 libopencv-objdetect4.5
  libopencv-video4.5 liborcus-0.16-0 liborcus-parser-0.16-0 libplacebo120 libplacebo157 libpoppler102 libproj22 libqhull8.0 libtesseract4 libwireshark14
  libwiretap11 libwsutil12 libx264-160 nvidia-settings
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  polkitd
Die folgenden NEUEN Pakete werden installiert:
  polkitd
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 551 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 88,9 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 308 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
(Lese Datenbank ... 435248 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../polkitd_0.105-33_amd64.deb ...
Entpacken von polkitd (0.105-33) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/polkitd_0.105-33_amd64.deb (--unpack):
 Versuch, »/etc/pam.d/polkit-1« zu überschreiben, welches auch in Paket policykit-1 0.112-5.3.1~really-0.105-8 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/polkitd_0.105-33_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


**
Code: [Select]
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/polkitd_0.105-33_amd64.deb (--unpack):
 Versuch, »/etc/pam.d/polkit-1« zu überschreiben, welches auch in Paket policykit-1 0.112-5.3.1~really-0.105-8 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/polkitd_0.105-33_amd64.deb
26
Software Support (EN) / Re: no tty login
« Last post by jyp on 2022/08/07, 20:46:30 »
I should add that, after a reboot, before login in as a user, I have login prompt on all tty (2-6).
After login in as a user, Ctrl+Alt+F1 (or F2-F6) print the same last lines from the booting process.
I have no idea how to correct that.
jyp
27
Software Support (EN) / no tty login
« Last post by jyp on 2022/08/07, 19:15:05 »
Hi everybody
I have 3 machines running siduction ( :D) fully upgraded as today.
On one of them, I cannot get tty logins; blank black screen (cursor looking inactive top left corner).
Code: [Select]
System:
Host: kappa Kernel: 5.18.16-1-siduction-amd64 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.25.4 Distro: siduction 21.2.0 Farewell - kde -
    (202109171658)
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-E GAMING v: Rev X.0x
    serial: 210686050900556 UEFI: American Megatrends v: 3604 date: 04/14/2021
CPU:
  Info: 6-core model: AMD Ryzen 5 5600G with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 3 MiB
  Speed (MHz): avg: 1400 min/max: 1400/4464 cores: 1: 1400 2: 1400 3: 1400
    4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1400 10: 1400 11: 1400 12: 1400
Graphics:
  Device-1: AMD Cezanne driver: amdgpu v: kernel
  Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa gpu: amdgpu resolution: 1: 1200x1920~60Hz
    2: 2560x1440~60Hz
  OpenGL: renderer: RENOIR (renoir LLVM 14.0.6 DRM 3.46
    5.18.16-1-siduction-amd64) v: 4.6 Mesa 22.2.0-rc1
Code: [Select]
jyp# systemctl list-units --type=service --state=running
  UNIT                      LOAD   ACTIVE SUB     DESCRIPTION
  ...
  getty@tty2.service        loaded active running Getty on tty2
  getty@tty3.service        loaded active running Getty on tty3
  getty@tty4.service        loaded active running Getty on tty4
  getty@tty5.service        loaded active running Getty on tty5
  getty@tty6.service        loaded active running Getty on tty6
  ...

Cannot access tty1 either. Tried the following with no result.
Code: [Select]
jyp# systemctl enable getty@tty1.service

Google it without success. Any clue?
Thank you.
28
Installations-Support (DE) / Re: Verschlüsselung 2022
« Last post by ReinerS on 2022/08/07, 18:27:22 »
Hmm, habe letztes Jahr meinen Laptop neu aufgesetzt.
Ging dabei nach Bluelupos Beschreibung Teil 2 vor:
Auf der internen SSD (480GB):
1 EFI Partition (die auch mal via Grub ein Windows von ner externen SSD startet)
1 Boot Partition unverschlüsselt.
1LUKS dmcrypt container der den Rest der SSD umfasst.
darin /, root, swap u. /home als LVs.
Auf der internen HDD
1 LUKS dmcrypt Container als "Archiv" über die gesamte Platte
mit 1 LV
Der erste LUKS Container wird beim Start via Grub durch Eingabe des Schlüssels entsperrt.
Der zweite LUKS Container wird beim Hochfahren automatisch durch Hinterlegung des Schlüssels
in einer Datei unter /etc/crypt und Referenzierung dieser Datei in /etc/crypttab entsperrt.
Kann man auch manuell machen
Als Dateisysteme habe ich für EFI Fat16, und für /boot ext4 genommen.
Bei den LVs habe ich für swap natürlich swap genommen, für den Rest ext4.

Bei dem Setup musste ich etwas mit dem EFI-Gedöns fummeln weill mein HP-BIOS da etwas zickig war.

Grüße

Reiner
29
Installations-Support (DE) / Verschlüsselung 2022
« Last post by michaaa62 on 2022/08/07, 12:46:42 »
Hallo,
meine Erfahrungen mit luks-cryptsetup sind aus den 'Vor-systemd-Tagen' und 'Vor-EFI-Tagen' und entsprechend eingerostet.
Kann mir jemand einen Link nennen, um ein zeitgemässes How-to zu erhalten, und für siduction anzupassen, oder gar einfach nur abzuarbeiten? Was hat sich für luks-cryptsetup, ext4-Filesystem EFI-Partition und SSD-Festplatte durch systemd verändert?
Für Tips und Anregungen wäre ich dankbar.
Viele Grüße
Michael
Pages: 1 2 [3] 4 5 ... 10