Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  Can not backup to NAS anymore rsync: [generator] chown <FILENAME> failed: Invali  (Read 1732 times)

Offline mash

  • User
  • Posts: 47
Error Message:
Code: [Select]
Can not backup to NAS anymore rsync: [generator] chown <FILENAME> failed: Invalid argument (22)Situation:
Synology NAS 216
Client: siduction

Hi, a couple of days ago (on June 6th - so three days ago) I added a new root folder to share some files with my partner
I just copied the Folder in question from my laptop as normal user.
I also did an update when I was working on the DSM (NAS) from Browser

Usually I use rsync to backup and sync my working files.

Today I noticed that the rsync command doesn't work anymore but instead it gives me errors on each file which has obviously to do with groups/users/rights:

rsync: [generator] chown <FILENAME> failed: Invalid argument (22)

The NAS-device is mounted with the following options in /etc/fstab

zonzamas://volume1/lzf /media/lzf  nfs noauto,users  0 0 vers=3
[I also tried vers=2 and vers=4]

I am using the following command(s)
rsync -agEvztP --delete-after /media/work/shared/ /media/lzf/shared

All other standardized backups, that I use for years result in the same error.
I don't blame the latest update - maybe I have misclicked somewhere, but I would appreciate any help.
I tried google and found some topics in stackoverflow but the solutions I have found did not work for me.

Any help apreciated
Code: [Select]
ls -la on the mounted device gives e.g.
Code: [Select]
total 5812
drwxrwxrwx 23 hy     nogroup    4096 jun  9 17:30 .
drwxrwxrwx 14 nobody nogroup    4096 dic 12 19:39 ..
drwxr-xr-x  3 nobody nogroup    4096 nov 10  2021 design
drwxr-xr-x  2 nobody nogroup  4096 ene 22 16:54 email
« Last Edit: 2022/06/10, 13:10:05 by mash »
when it was hard to write it should be hard to read