Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Browsers are broken  (Read 3850 times)

Offline sites

  • User
  • Posts: 6
[EN] Browsers are broken
« on: 2023/11/19, 16:10:25 »
Ran updates this morning. Chrome and Brave will not load pages properly. Firefox does, but some pages crash. Typing from a different pc now.

Offline edlin

  • User
  • Posts: 501
Re: Browsers are broken
« Reply #1 on: 2023/11/19, 17:53:34 »
Sorry, but hardly anyone here will be able to do anything with your description of the problem.
1. neither Chrome nor Brave are part of the official Debian/Siduction repos. Which versions do you have installed?
2. is your system up to date (apt update && apt dist-upgrade)?
3. KDE/Plasma, Wayland or X11, ...?
4. what do you mean by a page not loading properly?
5. example pages and the concrete problems (screenshots) would be helpful.
6. have you tested Chromium instead of Chrome?
7. which pages crash under Firefox?
8. ...

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.916
Re: Browsers are broken
« Reply #2 on: 2023/11/19, 17:56:42 »
For Chromium, i can confirm the Issue, Chromium does not render any site since todays upgrade.
For Google-Chrome and Firefox i can't see any problem here.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline edlin

  • User
  • Posts: 501
Re: Browsers are broken
« Reply #3 on: 2023/11/19, 18:06:18 »
I have just installed Chromium as a test and cannot see any problems.
 
Code: [Select]
apt policy chromium
chromium:
  Installed: 119.0.6045.159-1
  Installationskandidat: 119.0.6045.159-1
  Version table:
 *** 119.0.6045.159-1 500
        500 https://deb.debian.org/debian testing/main amd64 packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 packages
        500 http://debian.intergenia.de/debian trixie/main amd64 packages
        100 /var/lib/dpkg/status
     119.0.6045.123-1 500
        500 http://ftp.hosteurope.de/mirror/ftp.debian.org/debian trixie/main amd64 Packages

KDE/Plasma, X11

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.916
Re: Browsers are broken
« Reply #4 on: 2023/11/19, 18:08:23 »
I'm on Plasma Wayland.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.916
Re: Browsers are broken
« Reply #5 on: 2023/11/19, 18:11:30 »
After removing ~/.cache/chromium and ~/.config/chromium, Chromium is working again.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline edlin

  • User
  • Posts: 501
Re: Browsers are broken
« Reply #6 on: 2023/11/19, 18:21:20 »
A virgin Wayland session works fine with Chromium.
Code: [Select]
edlin@Devil:~$ inxi -G
Graphics:
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-2: Aveo USB2.0 UVC PC Camera driver: uvcvideo type: USB
  Display: wayland server: X.Org v: 23.2.2 with: Xwayland v: 23.2.2
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu
    resolution: 1920x1200~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,radeonsi,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 vendor: amd mesa v: 23.2.1-1 renderer: AMD Radeon
    Graphics (renoir LLVM 16.0.6 DRM 3.54 6.5.11-1-siduction-amd64)

Perhaps it is the legacy files (cache, config) that are causing problems. The problem should then disappear with a new user created as a test.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline samoht

  • User
  • Posts: 478
Re: Browsers are broken
« Reply #7 on: 2023/11/28, 23:49:27 »
Recently Google Chrome and Vivaldi, as the browsers based on the Chromium machine, have been updated. And only these versions are working again on my siduction.

[Interestingly, the standalone desktop version of the Bitwarden client as an Electron-based programme still does not work.

UPDATE:
Bitwarden works again after deleting the current
Code: [Select]
~/.config/Bitwarden]
« Last Edit: 2023/11/29, 09:51:32 by samoht »

Offline Camelot

  • User
  • Posts: 76
Re: Browsers are broken
« Reply #8 on: 2023/12/16, 14:09:42 »
I now had the same problem, the solution is to delete only the GPUCache folder.
Tested with the following browsers: Chromium, Vivaldi, Opera

Before deleting, you can test by starting the browser without GPU:
Code: [Select]
chromium --disable-gpu --disable-accelerated-video-encode
If this works, simply delete the GPU cache folder:
Code: [Select]
~/.config/chromium/Default/GPUCache
The complete browser profile therefore does not have to be deleted.