Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Neue Network-Manager Version bedroht (isc-)dhcp/-client  (Read 6697 times)

Offline samtfalterblau

  • User
  • Posts: 33
[DE] Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #15 on: 2023/11/22, 22:19:14 »
Ich habe gestern beim DU die Pakete "isc-dhcp-client" & "python3-deprecation" deinstalliert und erst dann diesen Austausch hier gelesen. Wenn ich sie wieder installieren möchte, sollen viele andere wichtige Programme deinstalliert werden:
Code: [Select]
apt install isc-dhcp-client python3-deprecation
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  dnsmasq-base easy-rsa libeac3 libndp0 libnm0 libopenconnect5 libpkcs11-helper1 libpskc0 libstoken1 libteamdctl0 libtomcrypt1 libtommath1 libtss2-tcti-libtpms0 libtss2-tcti-spi-helper0
  libtss2-tctildr0 libxmlsec1-openssl openconnect opensc opensc-pkcs11 openvpn pptp-linux python3-asn1crypto python3-mechanize python3-netifaces vpnc vpnc-scripts
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  isc-dhcp-common
Vorgeschlagene Pakete:
  resolvconf isc-dhcp-client-ddns
Die folgenden Pakete werden ENTFERNT:
  network-manager network-manager-openconnect network-manager-openvpn network-manager-pptp network-manager-vpnc plasma-nm
Die folgenden NEUEN Pakete werden installiert:
  isc-dhcp-client isc-dhcp-common python3-deprecation
Ich warte damit lieber, bis das nicht mehr passiert. Richtig?

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 929
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #16 on: 2023/11/22, 23:40:32 »
[...]
Ich warte damit lieber, bis das nicht mehr passiert. Richtig?

Besser ist es!

Offline samtfalterblau

  • User
  • Posts: 33
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #17 on: 2023/11/24, 21:42:22 »
Ich habe mal noch eine grundsätzliche Verständnisfrage: Warum wird im Siduction-Handbuch (https://manual.siduction.org/index_de.html) geschrieben
Quote
Eine Aktualisierung des ganzen Systems wird mit diesem Befehl durchgeführt: apt full-upgrade.
UND
Quote
Ein einfaches apt upgrade von Debian Sid ist normalerweise nicht empfohlen.
und im Debian-Wiki (https://wiki.debian.org/DebianUnstable#What_are_some_best_practices_for_testing.2Fsid_users.3F) das genaue Gegenteil empfohlen?
Quote
Use apt upgrade instead of apt full-upgrade to avoid unwanted removal of any packages that you depend on.

Offline lila

  • User
  • Posts: 17
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #18 on: 2023/11/24, 22:00:29 »
man kann nicht stable und unstable  1:1  vergleichen   ;)

es kommt viel darauf an, mit welchen Abhängigkeiten die Pakete verknüpft sind

Offline Camelot

  • User
  • Posts: 81
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #19 on: 2023/11/24, 22:07:07 »
Es spricht nichts gegen die Verwendung von apt full-upgrade wenn man darauf achtet was dabei entfernt werden soll.
Bei apt upgrade werden Pakete nur installiert, aber nicht entfernt. Wenn längere Zeit Pakete auf diese Weise zurückgehalten werden, hilft ein apt full-upgrade um zu sehen warum.

https://manual.siduction.org/sys-admin-apt_de.html#apt-und-apt-get

Ich persönlich verwende immer apt upgrade.

Offline samtfalterblau

  • User
  • Posts: 33
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #20 on: 2023/11/24, 22:23:19 »
man kann nicht stable und unstable  1:1  vergleichen   ;)
Das hier ist ja extra ein Wiki für Debian UNstable: https://wiki.debian.org/DebianUnstable#What_are_some_best_practices_for_testing.2Fsid_users.3F 🤔

Offline lila

  • User
  • Posts: 17
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #21 on: 2023/11/24, 22:38:12 »
ok - überlesen  :(

Offline edlin

  • User
  • Posts: 539
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #22 on: 2023/11/25, 13:41:07 »
Nicht ganz so schnell!
Ja, es ist das Wiki speziell für sid/unstable.
Nein, es wird nirgends als Standardmethode für Upgrades ein apt upgrade empfohlen.

Bitte die ganze Seite lesen und den Hinweis zu apt upgrade entsprechend einordnen! Wäre apt upgrade die ultimative Methode für Aktualisierungen, dann hätte man sich Hinweise, wie z. B. „make sure that you do not remove a plethora of packages you need“, komplett sparen können, denn mit einem einfachen apt upgrade würde man ja nie in diese Situation gelangen.
Und es wird auch geraten, sich u.a. mit dem Paketsystem auszukennen: „This means that you should know your way around Linux, Debian, and the Debian packaging system.“

Wer nur apt upgrade verwendet, kann durchaus Pakete zurückhalten, die besser aktualisiert werden sollten. Angenommen, das Paket foo verlangt als Abhängigkeit das Paket foo-bar. Irgendwann kommt der Entwickler von foo auf die Idee, das Paket foo-bar gleich in foo mit zu integrieren. Als Folge soll dann beim nächsten full-upgrade das (nicht mehr benötigte) Paket foo-bar entfernt werden. Verwendet man nur apt upgrade, würde foo nie mehr aktualisiert werden. Bei sid/unstable herrscht nun mal ein ständiges Kommen und Gehen. Daher steht ja auch im Wiki: „Always be careful when you perform updates and check if the actions proposed by the package managing tools are in line with your wishes and expectations.“

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline samtfalterblau

  • User
  • Posts: 33
Re: Neue Network-Manager Version bedroht (isc-)dhcp/-client
« Reply #23 on: 2023/11/25, 19:43:15 »
Danke für die Aufklärung, edlin!