Siduction Forum

Siduction Forum => Experimental / Experimentelles => Experimental (EN) => Topic started by: dibl on 2015/08/02, 15:47:55

Title: Skype & Plasma 5
Post by: dibl on 2015/08/02, 15:47:55
Has anyone got skype working on a 64-bit KDE system after installing kf5/plasma 5?  If so, here would be a great place to post the recipe.  Thanks!  :)
Title: Re: Skype & Plasma 5
Post by: dibl on 2015/08/03, 11:17:34
Replying to my own issue:


Message #237 near the end of this thread (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=712938) is good news for users of qt4 packages like skype that need to use the systemtray. The problem should be resolved in the near future.
Title: Re: Skype & Plasma 5
Post by: domicius on 2015/08/10, 21:46:37
Is Skype working but not showing in system tray or not working at all?

Skype works for me, but without showing up in system tray. And I have sni-qt 0.2.6 installed here, since I use the kdenext repo.
Title: Re: Skype & Plasma 5
Post by: dibl on 2015/08/10, 22:03:51
Since part of the functionality depends on the indicators in the system tray, I would say "not working".  It might or might not be the case that a skype process was running -- I don't remember checking on that.  I deleted skype from this system after I realized that it was pretty doomed for Plasma 5 functionality until the sni issue was resolved.  I can easily run skype on a Windows (or other Linux) VM, so it's not a big deal to do it that way in lieu of on the host OS.
Title: Re: Skype & Plasma 5
Post by: domicius on 2015/08/11, 16:57:13
Thanks for the clarification and I would agree indicators in system tray are integral to it's proper functioning and that's why I'm a bit bummed out with this whole Plasma 5 system tray mess... :(

Here's where I found the early warning (from more than a year ago) (http://blog.martin-graesslin.com/blog/2014/06/where-are-my-systray-icons/), but I only found out about it after I was affected. :D And to this day, there still seem to be quite a few applications not working with my systray in Plasma 5 (Skype, blueproximity, HPLIP Status Service, VLC...). :(

Oh, and I just realized you're on a 64-bit and in Martin's blog post it says:
Quote
Note for Skype users: Skype does not provide a 64 bit package, because of that one also needs the sni-qt package in the 32 bit variant.
Title: Re: Skype & Plasma 5
Post by: dibl on 2015/08/11, 17:28:05
Yes 64-bit systems have always needed multiarch (or ia32-libs in ancient times) to run skype, teamviewer, google earth, etc.


Radiotray is the package I miss the most since I installed Plasma 5 -- it is so handy sitting there ready to play at all times.  But of course I can chase down my favorite streams and play them with VLC.  It's just not as cool and convenient that way.


I assume that further development of Plasma 5, plus the patch for sni-qt for qt5, will eventually bring back the missing functionality.
Title: Re: Skype & Plasma 5
Post by: der_bud on 2015/08/12, 12:04:04
Haven't tried that myself, but here is a short summary from Arch wiki (https://wiki.archlinux.org/index.php/KDE#No_system_tray_icons_in_Plasma_5), based on the same blog post domicius posted:
Quote
No system tray icons in Plasma 5
Plasma 5 uses a new specification to display items in the 'system tray' area called Status Notifier. To allow applications using the old xembed specification to display items the packages (GTK2) libappindicator-gtk2, (GTK3) libappindicator-gtk3, (Qt4) sni-qt, or (For 32-bit Qt applications like Skype) lib32-sni-qt may be required.
Title: Re: Skype & Plasma 5
Post by: dibl on 2015/08/12, 15:04:57
Right. However, here is the current state of affairs in Debian sid for those packages:


Code: [Select]
root@Hibiscus:/# apt-cache policy libappindicator-gtk2 
N: Unable to locate package libappindicator-gtk2
root@Hibiscus:/# apt-cache policy libappindicator-gtk3
N: Unable to locate package libappindicator-gtk3
root@Hibiscus:/# apt-cache policy sni-qt
sni-qt:
  Installed: 0.2.6-0r0
  Candidate: 0.2.6-0r0
  Version table:
 *** 0.2.6-0r0 0
        500 http://packages.siduction.org/kdenext/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
root@Hibiscus:/# apt-cache policy lib32-sni-qt
N: Unable to locate package lib32-sni-qt
root@Hibiscus:/#

So, we wait.
 
Title: Re: Skype & Plasma 5
Post by: domicius on 2015/08/14, 02:58:45
Well, even though these packages just go by different names in Debian (I have them installed: libappindicator1 and libappindicator3-1), I'm not exactly sure what's the situation here: as you can see from the source package (https://tracker.debian.org/pkg/libappindicator), these haven't been updated in more than awhile and the upstream version seems "ages away", at least judging by the version number.

Good news is that #712938 (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=712938) is closed and sni-qt is in experimental now, I guess we now only wait for the most recent "fun times" situation (http://forum.siduction.org/index.php?topic=5719.0) to come to it's closure. :) I'm still not sure if this will solve everything, since my understanding is that GTK2 and GTK3 apps still need libappindicator and I just came here disappointed as I discovered yet another app I just started using that doesn't work correctly with my desktop: Workrave (http://www.workrave.org/). :(
Title: Re: Skype & Plasma 5
Post by: hendrikL on 2015/08/14, 10:18:04
hi,
I use trayer as workaround

Code: [Select]
  LANG=C apt-cache policy trayer
trayer:
  Installed: 1.1.5-1
  Candidate: 1.1.5-1
  Version table:
 *** 1.1.5-1 0
        500 http://httpredir.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

It is working fine for me.
Easy to set up like

Code: [Select]
trayer --edge top --align right  --width 8 --transparent true --padding 5  --height 29  --margin 5

greetz hendrik
Title: Re: Skype & Plasma 5
Post by: domicius on 2015/08/15, 00:10:26
Hey Hendrik, thanks for the workaround. Someone already mentioned wmsystemtray but that wasn't working for me. This will have to do until the real support comes back. :)