Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Terminal seg fault  (Read 2911 times)

Offline eriefisher

  • User
  • Posts: 268
[EN] Terminal seg fault
« on: 2023/09/19, 14:59:21 »
I just did a dist-upgrade and there were several packages to update. For one was the grub packages so I was a little nervous. However, everything updated fine and survived a reboot.

On to the issue since. I use Tilda for my terminal most of the time but since the upgrade it seg faults. I know this because I used the xfce4 terminal to start it to look for errors. Tilda started up fine the shortly after that it seg faulted then the xfce4 terminal crashed. I assume it also segfaulted. I retried it all again, same result.

Anyone else having issues?

Offline unklarer

  • User
  • Posts: 822
Re: Terminal seg fault
« Reply #1 on: 2023/09/19, 16:22:10 »
I do not use Tilda.
But it was updated today libvte-2.91-0. Maybe it is related to that. If you want to look:

Code: [Select]
apt show libvte-2.91-0
Package: libvte-2.91-0
Version: 0.74.0-1
Priority: optional
Section: libs
Source: vte2.91
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Installed-Size: 1.219 kB
Depends: libvte-2.91-common (= 0.74.0-1), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.34), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.10.0), libfribidi0 (>= 1.0.0), libgcc-s1 (>= 3.0), libglib2.0-0 (>= 2.77.3), libgnutls30 (>= 3.7.2), libgtk-3-0 (>= 3.24.22), libicu72 (>= 72.1~rc-1~), libpango-1.0-0 (>= 1.44.3), libpangocairo-1.0-0 (>= 1.22.0), libpcre2-8-0 (>= 10.22), libstdc++6 (>= 13), libsystemd0 (>= 220), zlib1g (>= 1:1.2.0)
Homepage: https://wiki.gnome.org/Apps/Terminal/VTE
Tag: role::shared-lib
Download-Size: 811 kB
APT-Manual-Installed: no
APT-Sources: https://deb.debian.org/debian unstable/main amd64 Packages
Description: Terminalemulator-Widget für GTK+ 3.0 - Laufzeitdateien
 Die VTE-Bibliothek bietet das Terminalemulator-Widget »VteTerminal« für
 Anwendungen, die den Werkzeugsatz GTK+ verwenden. Auch stellt sie das
 VtePTY-Objekt zur Verfügung, dass Funktionen zum Starten eines neuen
 Prozesses in einem neuen Pseudoterminal und zum Verändern von
 Pseudoterminals enthält.
 .
 Dieses Paket enthält die Laufzeitbibliothek, die von Programmen benötigt
 wird, die das VTE-Widget mit GTK+ 3.0 nutzen.

===============

apt show tilda
Package: tilda
Version: 1.5.4-1
Priority: optional
Section: x11
Maintainer: Sebastian Geiger <lanoxx@gmx.net>
Installed-Size: 423 kB
Depends: libc6 (>= 2.4), libconfuse2 (>= 3.2.1~), libgdk-pixbuf-2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.55.2), libgtk-3-0 (>= 3.21.5), libpango-1.0-0 (>= 1.14.0), libvte-2.91-0 (>= 0.49.92), libx11-6
Homepage: https://github.com/lanoxx/tilda
Tag: implemented-in::c, interface::graphical, interface::x11, role::program,
 uitoolkit::gtk, x11::application, x11::terminal
Download-Size: 109 kB
APT-Sources: https://deb.debian.org/debian unstable/main amd64 Packages
Description: GTK+ based drop down terminal for Linux and Unix
 Tilda is a terminal emulator similar to normal terminals like
 gnome-terminal (GNOME) or Konsole (KDE), with the difference
 that it drops down from the edge of a screen when a certain configurable
 hotkey is pressed. This is similar to the build-in consoles in
 games such as Quake or Half-live. Tilda is highly configureable
 through a graphical wizard.

Offline eriefisher

  • User
  • Posts: 268
Re: Terminal seg fault
« Reply #2 on: 2023/09/19, 18:42:44 »
Looks to be the same.
Code: [Select]
dan@hp15:~$ apt show libvte-2.91-0
Package: libvte-2.91-0
Version: 0.74.0-1
Priority: optional
Section: libs
Source: vte2.91
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Installed-Size: 1,219 kB
Depends: libvte-2.91-common (= 0.74.0-1), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.34), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.10.0), libfribidi0 (>= 1.0.0), libgcc-s1 (>= 3.0), libglib2.0-0 (>= 2.77.3), libgnutls30 (>= 3.7.2), libgtk-3-0 (>= 3.24.22), libicu72 (>= 72.1~rc-1~), libpango-1.0-0 (>= 1.44.3), libpangocairo-1.0-0 (>= 1.22.0), libpcre2-8-0 (>= 10.22), libstdc++6 (>= 13), libsystemd0 (>= 220), zlib1g (>= 1:1.2.0)
Homepage: https://wiki.gnome.org/Apps/Terminal/VTE
Tag: role::shared-lib
Download-Size: 811 kB
APT-Manual-Installed: no
APT-Sources: https://deb.debian.org/debian unstable/main amd64 Packages
Description: Terminal emulator widget for GTK+ 3.0 - runtime files
 The VTE library provides a terminal emulator widget VteTerminal for
 applications using the GTK+ toolkit. It also provides the VtePTY object
 containing functions for starting a new process on a new
 pseudo-terminal and for manipulating pseudo-terminals.
 .
 This package contains the runtime library, needed by programs using the
 VTE widget with GTK+ 3.0.
and tilda
Code: [Select]
dan@hp15:~$ apt show tilda
Package: tilda
Version: 1.5.4-1
Priority: optional
Section: x11
Maintainer: Sebastian Geiger <lanoxx@gmx.net>
Installed-Size: 423 kB
Depends: libc6 (>= 2.4), libconfuse2 (>= 3.2.1~), libgdk-pixbuf-2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.55.2), libgtk-3-0 (>= 3.21.5), libpango-1.0-0 (>= 1.14.0), libvte-2.91-0 (>= 0.49.92), libx11-6
Homepage: https://github.com/lanoxx/tilda
Tag: implemented-in::c, interface::graphical, interface::x11, role::program,
 uitoolkit::gtk, x11::application, x11::terminal
Download-Size: 109 kB
APT-Manual-Installed: yes
APT-Sources: https://deb.debian.org/debian unstable/main amd64 Packages
Description: GTK+ based drop down terminal for Linux and Unix
 Tilda is a terminal emulator similar to normal terminals like
 gnome-terminal (GNOME) or Konsole (KDE), with the difference
 that it drops down from the edge of a screen when a certain configurable
 hotkey is pressed. This is similar to the build-in consoles in
 games such as Quake or Half-live. Tilda is highly configureable
 through a graphical wizard.

Offline eriefisher

  • User
  • Posts: 268
Re: Terminal seg fault
« Reply #3 on: 2023/09/19, 19:02:28 »
A snip from dmesg
Code: [Select]
[  205.820569] tilda[2872]: segfault at 55aa73d49000 ip 00007ff7e6294b30 sp 00007ffff6bf85c8 error 4 in libglib-2.0.so.0.7800.0[7ff7e6221000+99000] likely on CPU 1 (core 1, socket 0)
[  205.820628] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[  275.005391] tilda[5986]: segfault at 5575e0c86000 ip 00007fa87ac66b30 sp 00007ffdf0532b28 error 4 in libglib-2.0.so.0.7800.0[7fa87abf3000+99000] likely on CPU 0 (core 0, socket 0)
[  275.005449] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[  329.329243] xfce4-terminal[6698]: segfault at 5639ed260000 ip 00007f0f5a94ab30 sp 00007ffe72c740c8 error 4 in libglib-2.0.so.0.7800.0[7f0f5a8d7000+99000] likely on CPU 0 (core 0, socket 0)
[  329.329287] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[  440.900417] tilda[8730]: segfault at 557b6ce6c000 ip 00007fa1ca795b30 sp 00007ffd5574ec98 error 4 in libglib-2.0.so.0.7800.0[7fa1ca722000+99000] likely on CPU 0 (core 0, socket 0)
[  440.900467] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[  511.826633] xfce4-terminal[8538]: segfault at 56527a1b1000 ip 00007f7148548b30 sp 00007ffc187a47c8 error 4 in libglib-2.0.so.0.7800.0[7f71484d5000+99000] likely on CPU 0 (core 0, socket 0)
[  511.826682] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[ 1516.952815] tilda[9982]: segfault at 558d2ca81000 ip 00007fa1089feb30 sp 00007ffcc0d939b8 error 4 in libglib-2.0.so.0.7800.0[7fa10898b000+99000] likely on CPU 0 (core 0, socket 0)
[ 1516.952863] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[ 1614.708885] xfce4-terminal[9339]: segfault at 556a31784000 ip 00007f9165238b30 sp 00007ffefebcbdd8 error 4 in libglib-2.0.so.0.7800.0[7f91651c5000+99000] likely on CPU 1 (core 1, socket 0)
[ 1614.708931] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[ 8568.848737] rcu: INFO: rcu_preempt detected expedited stalls on CPUs/tasks: { P15389 } 21 jiffies s: 1505 root: 0x0/T
[ 8568.848766] rcu: blocking rcu_node structures (internal RCU debug):

Offline ro_sid

  • User
  • Posts: 227
Re: Terminal seg fault
« Reply #4 on: 2023/09/20, 00:40:29 »
A snip from dmesg
Code: [Select]
[  205.820569] tilda[2872]: segfault at 55aa73d49000 ip 00007ff7e6294b30 sp 00007ffff6bf85c8 error 4 in libglib-2.0.so.0.7800.0[7ff7e6221000+99000] likely on CPU 1 (core 1, socket 0) 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[...]
[ 1614.708885] xfce4-terminal[9339]: segfault at 556a31784000 ip 00007f9165238b30 sp 00007ffefebcbdd8 error 4 in libglib-2.0.so.0.7800.0[7f91651c5000+99000] likely on CPU 1 (core 1, socket 0)
[ 1614.708931] Code: 00 00 00 48 39 fe 72 0b eb 40 48 89 f8 48 89 f7 48 89 c6 48 f7 da 48 39 f7 72 ef 31 c0 4c 8d 05 76 0f 06 00 48 39 fe 73 38 90 <0f> b6 0e 48 83 c0 01 49 0f be 0c 08 48 01 ce 48 39 fe 72 ec 48 0f
[ 8568.848737] rcu: INFO: rcu_preempt detected expedited stalls on CPUs/tasks: { P15389 } 21 jiffies s: 1505 root: 0x0/T
[ 8568.848766] rcu: blocking rcu_node structures (internal RCU debug):
libglib2.0 has also been updated (several times?) in the last few days! Iirc today for the last time.
But it might be difficult to roll back, since it has a lot of dependencies.
Myself, I did not have a problem with the current version, though - at least yet.

Offline eriefisher

  • User
  • Posts: 268
Re: Terminal seg fault
« Reply #5 on: 2023/09/20, 01:00:41 »
I just now completed another d-u and a reboot. The issue seems to be fixed. Neither terminal is crashing. So far anyway.