Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved] No Wake-On-Lan with Network-Manager  (Read 4752 times)

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
[EN] [solved] No Wake-On-Lan with Network-Manager
« on: 2015/09/20, 23:46:01 »
Hello,

my system with eth0 controlled by network-manager, wake-on-lan doesn't work anymore. How can I configure network-manager that eth0 is listening for wol-packets even the computer is powered off?

With the sysv-scripts I was able to configure this in /etc/default/halt with NETDOWN=no.
« Last Edit: 2015/09/22, 22:37:14 by orinoco »

Offline der_bud

  • User
  • Posts: 1.077
  • member
Re: No Wake-On-Lan with Network-Manager
« Reply #1 on: 2015/09/21, 10:55:18 »
Found this in ArchWiki#Wake-on-LAN, gives on my system:
 - First
Code: [Select]
nmcli con show

NAME                         UUID                                  TYP             GERÄT
Kabelgebundene Verbindung 1  so999888-melo-ngnu-mber-777here  802-3-ethernet  eth0 

 - Then
Code: [Select]
nmcli con show "Kabelgebundene Verbindung 1" | grep wake

802-3-ethernet.wake-on-lan:             default
802-3-ethernet.wake-on-lan-password:    --

 - Change
Code: [Select]
nmcli c modify "Kabelgebundene Verbindung 1" 802-3-ethernet.wake-on-lan magic
They describe other possibilies also in that wiki, i.e via systemd-networks or systemd-services. Don't know what works for you on siduction, as I do not use WOL.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline orinoco

  • User
  • Posts: 248
  • Bullshit artist
Re: No Wake-On-Lan with Network-Manager
« Reply #2 on: 2015/09/22, 22:36:39 »


Code: [Select]
nmcli c modify "Kabelgebundene Verbindung 1" 802-3-ethernet.wake-on-lan magic
That was the trick. This setting survives a reboot, too. Thanks a lot.