Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] plasma-desktop to be removed  (Read 2338 times)

Offline finotti

  • User
  • Posts: 277
[EN] [SOLVED] plasma-desktop to be removed
« on: 2018/03/08, 04:14:58 »
After a while without DUing, I've tried to do it today on my laptop.  I saw that:

Code: [Select]
The following packages will be REMOVED:
  kde-config-touchpad kde-plasma-desktop kde-standard linux-headers-4.14.0-3-amd64 plasma-desktop
  powerdevil

I thought maybe it was a transition, but I don't see that behavior in two machines running aptosid.  I've also checked the "Upgrade Warnings" forum and it seems that there is no transition now.

Running 'apt-get -o Debug::pkgProblemResolver=yes dist-upgrade' I also see some weird things:

Code: [Select]
Starting pkgProblemResolver with broken count: 13
Starting 2 pkgProblemResolver with broken count: 13
Investigating (0) kactivitymanagerd:amd64 < 5.10.5-2 -> 5.12.1-1 @ii umU Ib >
Broken kactivitymanagerd:amd64 Breaks on plasma-desktop:amd64 < 4:5.10.5-2 @ii mK NPb Ib > (< 4:5.12)
  Considering plasma-desktop:amd64 -5 as a solution to kactivitymanagerd:amd64 28
  Added plasma-desktop:amd64 to the remove list
  Fixing kactivitymanagerd:amd64 via remove of plasma-desktop:amd64

If I understand correctly, it is removing plasma-desktop because kactivitymanagerd needs a newer version of it.  But it is available:

Code: [Select]
# apt policy plasma-desktop
plasma-desktop:
  Installed: 4:5.10.5-2
  Candidate: 4:5.12.2-1
  Version table:
     4:5.12.2-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 4:5.10.5-2 100
        100 /var/lib/dpkg/status

So, I don't see why apt isn't just installing the newer version.

Here is the complete output: https://pastebin.com/pP53191M


Some info on the system:

Code: [Select]
# inxi -v3
System:    Host: e7440 Kernel: 4.15.1-towo.1-siduction-amd64 x86_64 bits: 64 gcc: 7.3.0
           Desktop: KDE Plasma 5.10.5 (Qt 5.9.2)
           Distro: siduction 15.1.0 Paint It Black - kde - (201601162135)
Machine:   Device: laptop System: Dell product: Latitude E7440 v: 00 serial: BZSMP12
           Mobo: Dell model: 07F3F4 v: A00 serial: /BZSMP12/CN129634C10144/
           BIOS: Dell v: A17 date: 12/01/2015
Battery    BAT0: charge: 47.7 Wh 168.6% condition: 28.3/47.7 Wh (59%)
           model: SMP DELL 909H538 status: Full
CPU:       Dual core Intel Core i7-4600U (-MT-MCP-) arch: Haswell rev.1 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10775
           clock speeds: max: 3300 MHz 1: 2868 MHz 2: 2718 MHz 3: 2713 MHz 4: 2707 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) driver: intel Resolution: 1920x1080@60.02hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile
           version: 4.5 Mesa 17.3.3 Direct Render: Yes
Network:   Card-1: Intel Ethernet Connection I218-LM
           driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: down mac: 34:e6:d7:19:d5:4d
           Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: 48:51:b7:67:5b:a1
Drives:    HDD Total Size: 256.1GB (74.7% used)
           ID-1: model: SAMSUNG_SSD_PM85
Info:      Processes: 229 Uptime: 1:28 Memory: 2434.6/7887.0MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0 Client: Shell (bash 4.4.121) inxi: 2.3.56

Any suggestions?  Should I try to DU, let the listed packages be remove and try to install them back again?


« Last Edit: 2018/03/09, 03:38:33 by finotti »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
Re: plasma-desktop to be removed
« Reply #1 on: 2018/03/08, 07:30:00 »
For one thing, you should update morte often!
Now you could try to
Code: [Select]
apt install kde-plasma-desktop -s and see what that wants to do. Also
Code: [Select]
apt upgrade first and then see what dist-upgade wants to do is a viable road.

Offline finotti

  • User
  • Posts: 277
Re: plasma-desktop to be removed
« Reply #2 on: 2018/03/09, 03:38:02 »
Thanks, devil!  For some reason, today, trying DU no package to be removed.  I don't know what fixed, but I am not complaining.

(And indeed I should DU more often, but this laptop stays with my wife, which makes it harder...)

Thanks for the help!!!