Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)  (Read 1297 times)

Offline dpanter

  • User
  • Posts: 31
DU currently removes pipewire-media-session as it's not yet updated to 0.3.39-1, meaning you no longer have any visible sound devices. Fun side effect, konsole hangs when trying to send a bell. :)

Downgrade all the pipewire packages to 0.3.38-2 to fix it for now.
Code: [Select]
sudo apt install {pipewire-media-session,libpipewire-0.3-0,libpipewire-0.3-common,libpipewire-0.3-modules,pipewire-audio-client-libraries,pipewire-bin,pipewire-pulse,pipewire-tests,pipewire,libspa-0.2-modules,libpipewire-0.3-0:i386,libpipewire-0.3-modules:i386,libspa-0.2-modules:i386,pipewire:i386}=0.3.38-2
« Last Edit: 2021/10/23, 14:30:11 by dpanter »
<< insert signature here >>

Offline Pip

  • User
  • Posts: 112
Re: DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #1 on: 2021/10/22, 21:32:57 »
Thanks for trying to fix it. For me, it just says that version 0.3.38-2 of all the packages can't be found.

Offline dpanter

  • User
  • Posts: 31
Re: DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #2 on: 2021/10/22, 21:54:03 »
Ah sorry, 0.3.38-2 is available in Testing.
<< insert signature here >>

Offline dpanter

  • User
  • Posts: 31
Re: DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #3 on: 2021/10/23, 14:29:06 »
After reading the changelog, it seems pipewire-media-session is out and wireplumber is the new hotness. Ran a new DU, installed wireplumber, rebooted, configured sound device settings and sound is now working again. Using external DAC via optical cable and it's running 192 KHz just fine.

Snipped the relevant changelog entries:
Code: [Select]
pipewire (0.3.39-1) unstable; urgency=medium
  * Don't build the pipewire-media-session binary package anymore,
      media-session has moved to a separate module to accelerate its
      deprecation in favour of WirePlumber.
  * Change priority order between pipewire-media-session and wireplumber,
      WirePlumber is now the recommended session manager.

Code: [Select]
$ pactl info | grep "Server Name"
Server Name: PulseAudio (on PipeWire 0.3.39)
<< insert signature here >>

Offline Pip

  • User
  • Posts: 112
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #4 on: 2021/10/23, 22:37:35 »
Nice. Thanks.

Offline samoht

  • User
  • Posts: 416
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #5 on: 2021/10/24, 09:18:34 »
Thanks, @dpanter, for sharing.

For German localized installs:

Auf deutsch:

Code: [Select]
$ pactl info | grep "Name des Servers"
Name des Servers: pulseaudio


Offline hendrikL

  • Global Moderator
  • User
  • *****
  • Gravatar
  • Posts: 547
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #6 on: 2021/10/24, 11:09:30 »
Code: [Select]
pactl info | grep '^Name des Servers'
Name des Servers: PulseAudio (on PipeWire 0.3.39)

Code: [Select]
LANG=C  pactl info | grep '^Server Name'
Server Name: PulseAudio (on PipeWire 0.3.39)

As the changelog explained, pipewire-media-session is replaced by wireplumber!
That is not a bug, and do not break pipewire on a full-upgraded sid/unstable.
To install wireplumber you have to purge  pipewire-media-session and install wireplumber.

What I did/ had to do to install wireplumber (I had to remove  /etc/systemd/user/pipewire-session-manager.service before it worked),

Code: [Select]
apt purge  pipewire-media-session
rm /etc/systemd/user/pipewire-session-manager.service
apt install wireplumber

Code: [Select]
LANG=C apt policy pipewire-media-session
pipewire-media-session:
  Installed: (none)
  Candidate: 0.3.38-2
  Version table:
     0.3.38-2 500
        500 http://deb.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status


Code: [Select]
LANG=C apt policy wireplumber
wireplumber:
  Installed: 0.4.4-1
  Candidate: 0.4.4-1
  Version table:
 *** 0.4.4-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.3-1 500
        500 http://deb.debian.org/debian testing/main amd64 Packages

Online devil

  • Administrator
  • User
  • *****
  • Posts: 4.638
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #7 on: 2021/10/27, 20:53:25 »
There will be a package  pipewire-media-session again, it is waiting in NEW. What happened is, pipewire-media-session was made a standalone package and will eventually be succeeded by wireplumber, which is the new session-manager for pipewire.

Offline finotti

  • User
  • Posts: 200
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #8 on: 2021/10/27, 21:24:50 »
@devil: Sorry for the ignorance, but what does NEW stand for?

Offline hendrikL

  • Global Moderator
  • User
  • *****
  • Gravatar
  • Posts: 547
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #9 on: 2021/10/28, 10:43:32 »
I think, devil can explain it much better than me.

But for the start

https://ftp-master.debian.org/#new

Mostly you can find it out with "rmadison" (part of 'devscripts') like:

Code: [Select]
:~$ rmadison pipewire-media-session
pipewire-media-session | 0.3.38-2      | testing    | amd64, arm64, armel, armhf, i386, mips64el, mipsel, ppc64el, s390x
pipewire-media-session | 0.4.0-1       | new        | source, amd64

Packages in NEW (entirely new or with significant changes) are on the way, but have to be checked and accepted by the ftp-masters of debian.

If the maintainer has no luck, it could be in the NEW-query for a long, long time!
« Last Edit: 2021/10/28, 12:24:24 by hendrikL »

Offline finotti

  • User
  • Posts: 200
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #10 on: 2021/10/28, 13:22:56 »
Thanks hendrikL!  It's hard to search for a term like "new".  (And I thought it was an acronym.)

Part of the reason I asked was because devil had also mentioned that ksysguard was in NEW, but I cannot find it in the list (and it is still not installable).

Online devil

  • Administrator
  • User
  • *****
  • Posts: 4.638
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #11 on: 2021/10/28, 14:13:54 »
@finotti: The new Systemmonitor (successor of ksysguard) runs fine unter 5.23 in sid. The following packages are installed:
Quote
ft@blue:~$ dpkg -l | grep ksys
rc  ksysguard-data                                4:5.21.5-2                             all          library for monitoring your system - shared library
ii  ksysguardd                                    4:5.21.5-2                             amd64        System Guard Daemon
ii  ksystemlog                                    4:21.08.0-1                            amd64        system log viewer
ii  ksystemstats                                  5.23.0-2                               amd64        plugin based system monitoring daemon
ii  libksysguardformatter1                        4:5.23.0-5                             amd64        library for system monitoring - ksysguardformatter shared library
ii  libksysguardsensorfaces1                      4:5.23.0-5                             amd64        library for system monitoring - ksysguardsensorfaces shared library
ii  libksysguardsensors1                          4:5.23.0-5                             amd64        library for system monitoring - ksysguardsensors shared library
ii  libksysguardsystemstats1                      4:5.23.0-5                             amd64        library for system monitoring - ksysguardsystemstats shared library
ii  qml-module-org-kde-ksysguard                  4:5.23.0-5                             amd64        KSysGuard QtDeclarative QML Support

Offline finotti

  • User
  • Posts: 200
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #12 on: 2021/10/28, 14:42:12 »
Ah!  I thought a new version of ksysguard was suppose to come in.  Thanks @devil!  All is working as expected.

Offline whistler_mb

  • User
  • Posts: 177
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #13 on: 2021/10/28, 16:00:33 »
Could it be that you mean this version?

Code: [Select]
$ apt policy plasma-systemmonitor
plasma-systemmonitor:
  Installed: 5.23.2-1~np1
  Candidate: 5.23.2-1~np1
  Version table:
 *** 5.23.2-1~np1 500
        500 https://downloadcontent.opensuse.org/repositories/home:/npreining:/debian-kde:/plasma523/Debian_Unstable ./ Packages
        100 /var/lib/dpkg/status
     5.23.0-2 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages

Offline dpanter

  • User
  • Posts: 31
Re: [SOLVED] DU breaks pipewire (incomplete 0.3.39-1 atm)
« Reply #14 on: 2021/10/28, 16:41:32 »
ksysguard and the new plasma-systemmonitor are different.
It can be noted that ksysguard provides data for some widgets like Thermal Monitor, Resources Monitor, Netspeed Widget etc. Removing ksysguard means these no longer function. Guessing this may be fixed later.

What happened to my topic? :P
<< insert signature here >>