Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: Balou on 2021/08/23, 20:40:16

Title: Fehler bei Update Libre Office
Post by: Balou on 2021/08/23, 20:40:16
Hi

Hatte eben einen Fehler beim Update.

Code: [Select]
[[1mdpkg:^[[0m Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-n6vJDk/58-libreoffice-gnome_1%3a7.2.0-2_amd64.deb (--unpack):
 Versuch, »/usr/lib/libreoffice/program/liblosessioninstalllo.so« zu überschreiben, welches auch in Paket libreoffice-gtk3 1:7.1.5-2 ist
^[[1mdpkg-deb:^[[0m ^[[1;31mFehler:^[[0m »einfügen«-Unterprozess wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Vorbereitung zum Entpacken von .../59-libreoffice-gtk3_1%3a7.2.0-2_amd64.deb ...
Entpacken von libreoffice-gtk3 (1:7.2.0-2) über (1:7.1.5-2) ...
Vorbereitung zum Entpacken von .../60-libreoffice-writer_1%3a7.2.0-2_amd64.deb ...
Entpacken von libreoffice-writer (1:7.2.0-2) über (1:7.1.5-2) ...
^[[1mdpkg:^[[0m Dekonfiguration von libreoffice-gnome wird in Betracht gezogen, welches durch Installation von »libreoffice-core« beschädigt würde ...
^[[1mdpkg:^[[0m Ja, libreoffice-gnome wird dekonfiguriert (beschädigt durch libreoffice-core

ein apt --fix-broken install behob das Problem

BalouB
Title: Re: Fehler bei Update Libre Office
Post by: yunanideniz on 2021/09/02, 17:03:21
I too have problems with Libre Office, I cannot open it... I tried to launch it from the terminal even in safemode, but it doesn't start and the terminal gives me this answer :yunanideniz@lenovo:~$ su
Password:
root@lenovo:/home/yunanideniz# libreoffice
Warning: failed to launch javaldx - java may not function correctly
/usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib/libreoffice/program/libmergedlo.so: undefined symbol: _ZNK11LanguageTag20getGlibcLocaleStringERKN3 rtl8OUStringE
root@lenovo:/home/yunanideniz#  thanks and waiting for advice


Title: Re: Fehler bei Update Libre Office
Post by: dibl on 2021/09/02, 17:40:51
Quote from: yunanideniz
root@lenovo:/home/yunanideniz# libreoffice

Why are you trying to run this package as root? Here, it runs perfectly from a user terminal or the user gui (plasma-desktop):

Code: [Select]
don@dibl-patience:~$ libreoffice
This is ver. 7.2.0.4.

On my system, both of the ".so" files named in your error output are present in /usr/lib/libreoffice/program.

You may need to
Code: [Select]
apt remove -purge libreoffice and reinstall it, then use it from the user's login session.
Title: Re: Fehler bei Update Libre Office
Post by: yunanideniz on 2021/09/03, 09:06:18


thank you, i uninstalled libre office and reinstalled the new version and now it works perfectly. thank you again and see you next time.