Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Some confusion with php with du today  (Read 457 times)

Offline harley-peter

  • User
  • Posts: 895
Some confusion with php with du today
« on: 2021/11/21, 13:12:32 »
A du today creates some confusion for me with php packages:
Code: [Select]
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
 .... node-jquery php-cli php-google-recaptcha php-mariadb-mysql-kbs php-mbstring php-mysql php-nikic-fast-route php-pear
  php-phpmyadmin-motranslator php-phpmyadmin-shapefile php-phpmyadmin-sql-parser php-phpseclib php-psr-cache php-psr-container php-psr-log php-symfony-cache
  php-symfony-cache-contracts php-symfony-config php-symfony-dependency-injection php-symfony-expression-language php-symfony-filesystem php-symfony-service-contracts
  php-symfony-var-exporter php-symfony-yaml php-tcpdf php-twig php-twig-i18n-extension php-xml php8.1-cli php8.1-mbstring php8.1-mysql php8.1-opcache php8.1-readline
  php8.1-xml
Verwenden Sie »apt autoremove«, um sie zu entfernen.

Die folgenden Pakete werden ENTFERNT:
  libapache2-mod-php7.4 php7.4-cli php7.4-common php7.4-curl php7.4-gd php7.4-intl php7.4-json php7.4-mbstring php7.4-mysql php7.4-opcache php7.4-readline php7.4-xml
  php7.4-zip phpmyadmin

Die folgenden NEUEN Pakete werden installiert:
  libdecor-0-0 libdecor-0-plugin-1-cairo liblbfgsb0 libpython3.10-minimal libpython3.10-stdlib libqhull-r8.0 liburing2 linux-headers-5.15.3-2-siduction-amd64
  linux-image-5.15.3-2-siduction-amd64 php8.1-cli php8.1-common php8.1-curl php8.1-mbstring php8.1-mysql php8.1-opcache php8.1-readline php8.1-xml php8.1-zip
  python3-appdirs python3-attr python3-brotli python3-fonttools python3-fs python3-importlib-metadata python3-lz4 python3-more-itertools python3-mpmath
  python3-packaging python3-pil.imagetk python3-scipy python3-sympy python3-tz python3-ufolib2 python3-zipp python3.10 python3.10-minimal unicode-data

Die folgenden Pakete werden aktualisiert (Upgrade):
....  libapt-pkg6.0 libasan5 libasan6
  libatomic1 libaudit1 libayatana-ido3-0.4-0 libayatana-indicator3-7 libbinutils libboost-filesystem1.74.0 libboost-iostreams1.74.0 libboost-locale1.74.0
  libboost-thread1.74.0 libbrotli1 libcc1-0 libcrack2 libcryptsetup12 libctf-nobfd0 libctf0 libdrm-amdgpu1 libdrm-common libdrm-intel1 libdrm-nouveau2 libdrm-radeon1
  libdrm2 libdw1 libelf-dev libelf1 libevdev2 libfbclient2 libftdi1-2 libgcc-10-dev libgcc-11-dev libgcc-9-dev libgcc-s1 libgfortran5 libgmp10 libgmpxx4ldbl libgomp1
  libgpgme11 libgpgmepp6 libgs9 libgs9-common libgwenhywfar-data libgwenhywfar79 libhttp-message-perl libib-util libitm1 libjpeg-turbo-progs libjpeg62-turbo liblsan0
  libmagic-mgc libmagic1 libmariadb3 libmecab2 libmysofa1 libncurses5 libncurses6 libncursesw5 libncursesw6 libnewt0.52 libnftables1 libnftnl11 libnspr4 libobjc4
  libopenmpt0 libpam-systemd libpcre2-16-0 libpcre2-32-0 libpcre2-8-0 libprotobuf-lite23 libpython3-stdlib libpython3.9 libpython3.9-minimal libpython3.9-stdlib
  libqpdf28 libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5sql5 libqt5sql5-sqlite libqt5test5
  libqt5widgets5 libqt5xml5 libquadmath0 libsasl2-2 libsasl2-modules libsasl2-modules-db libsdl2-2.0-0 libseccomp2 libselinux1 libsemanage2 libsmbclient libsphinxbase3
  libstdc++-11-dev libstdc++6 libsystemd0 libtasn1-6 libtinfo5 libtinfo6 libtsan0 libturbojpeg0 libubsan1 libudev1 libwbclient0 libxfont2 libxml2
  libxmlgraphics-commons-java libxmmsclient6 linux-headers-siduction-amd64 linux-image-siduction-amd64 linux-libc-dev mecab-utils mkvtoolnix mkvtoolnix-gui ncurses-base
  ncurses-bin nftables openssh-client openssh-server openssh-sftp-server oxygen-icon-theme php-cli php-common php-curl php-mbstring php-mysql php-xml php-zip plocate
  python-matplotlib-data python3 python3-apsw python3-apt python3-cairo python3-cffi-backend python3-chm python3-cryptography python3-cups python3-dbus
  python3-dbus.mainloop.pyqt5 python3-distutils python3-dnspython python3-gi python3-gi-cairo python3-keyutils python3-kiwisolver python3-lib2to3 python3-lxml
  python3-markdown python3-markupsafe python3-matplotlib python3-minimal python3-netifaces python3-numpy python3-pil python3-psutil python3-pycryptodome python3-pycurl
  python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebchannel python3-pyqt5.qtwebengine python3-pyqt5.sip python3-regex python3-reportlab-accel python3-tk python3-yaml
  python3-zeroconf python3.9 python3.9-minimal samba-libs smbclient systemd systemd-sysv udev unrar vivaldi-stable whiptail xdg-desktop-portal xdg-desktop-portal-gtk
  xserver-xorg-video-amdgpu xwayland

I think it is better to wait some days.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.637
Re: Some confusion with php with du today
« Reply #1 on: 2021/11/21, 14:04:36 »
No confusion. Compare what gets removed and what gets newly installed.

Offline harley-peter

  • User
  • Posts: 895
Re: Some confusion with php with du today
« Reply #2 on: 2021/11/21, 14:28:00 »
Hi Devil,
ich bin deshalb verwirrt weil die Pakete, die angeblich nicht mehr benötigt werden, teilweise dieselben sind, wie die die neu installiert werden.

Offline vayu

  • User
  • Posts: 228
Re: Some confusion with php with du today
« Reply #3 on: 2021/11/22, 05:12:39 »
I'm confused too.  I see that php8.1 is to be installed over php7.4 and mariadb is going to be upgraded as well. That's all good.  But the autoremove list looks dangerous to me. I see many packages to be removed and autoremoved but not installed or upgraded.  I'm going to wait a bit to see if it's in the middle of a transition.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.637
Re: Some confusion with php with du today
« Reply #4 on: 2021/11/22, 12:12:00 »
I never use autoremove. Too dangerous without checking every package in there.

Offline vayu

  • User
  • Posts: 228
Re: Some confusion with php with du today
« Reply #5 on: 2021/11/23, 04:19:14 »
Quote
I never use autoremove. Too dangerous without checking every package in there.

Some times it takes quite a bit of searching to find out what all the packages it wants to remove are.  When removing something does break my system that usually means I need to manually install that package.
« Last Edit: 2021/11/23, 04:31:02 by vayu »

Offline Mte90

  • User
  • Posts: 165
  • KDE & Debian lover
    • http://www.mte90.net
Re: Some confusion with php with du today
« Reply #6 on: 2021/11/23, 11:38:51 »
I reverted back and kept php7.4 as with php8.1 few things doens't work on my dev machine.
I guess that is php-common on forcing the php7.4 removal with php8.1 install.

Offline harley-peter

  • User
  • Posts: 895
Re: Some confusion with php with du today
« Reply #7 on: 2021/11/23, 12:40:20 »
And here also the packages phpmyadmin and libapache2-mod-php7.4 gets removed. Maybe phpmyadmin does not work yet with php8.1

Offline vayu

  • User
  • Posts: 228
Re: Some confusion with php with du today
« Reply #8 on: 2021/11/23, 13:29:20 »
It took me a long time to get it all working that didn't want to remove phpmyadmin or the later version of php-common. 

Basically what I did is removed everything with a php7.4 and then installed all of the same packages with the same package name but without a version. Like I removed php7.4-mysql and install php-mysql.   

There are 3 versions of each package. For example php7.4-common, php8.1-common and the unversioned package php-common.
Not every package had all three and that was the problem. In the end we want all 7.4 removed and to keep the unversioned one which should want to pull in the 8.1 one.

There were some like php8.1-opcache that had no corresponding unversioned package so I installed the 8.1 version.  The hard part was that I had to keep experimenting with the order of removals and installations that wouldn't remove things like php-common or phpmyadmin. 

In the end it worked and I had a running phpmyadmin and other php/apache programs. I had a list of packages that had to stay removed in order to keep phpmyadmin and the latest php-common. 

These packages I removed and will keep on the lookout for when a newer 8.1 version of them become available: php-apcu php-apcu-bc php-imagick php-uploadprogress php-xdebug. None of them were vital to a php functioning under apache.

Offline harley-peter

  • User
  • Posts: 895
Re: Some confusion with php with du today
« Reply #9 on: 2021/11/23, 15:58:19 »
Very interesting:
a du this afternoon does not want to remove anymore php packages nore install php packages. Only some packages (php-cli php-common php-curl php-mbstring php-mysql php-xml php-zip) will be updated.

Offline vayu

  • User
  • Posts: 228
Re: Some confusion with php with du today
« Reply #10 on: 2021/11/23, 16:23:08 »
Haha after all that work yesterday, today it wants to reinstall 7.4 packages and it wants to upgrade 8.1 packages I had installed with newer versions of 8.1 packages with the name really7.4.

These are all currently installed as 8.1 packages on my system and are flagged for upgrade with names of 8.1+really7.4:
Code: [Select]
php php-bcmath php-bz2 php-cli php-common php-curl php-fpm php-gd php-gmp php-json php-mbstring php-mysql php-readline php-sqlite3 php-xml php-zip
Code: [Select]
php-curl:
  Installed: 2:8.1+85
  Candidate: 2:8.1+85+really7.4+88

php-fpm:
  Installed: 2:8.1+85
  Candidate: 2:8.1+85+really7.4+88
and several others

So it appears that 8.1 is to be used in name only