Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] (gelöst) System bootet sich von selbst  (Read 1875 times)

Offline Sir_Aim

  • User
  • Posts: 50
[DE] (gelöst) System bootet sich von selbst
« on: 2012/04/23, 12:15:56 »
Seit ein paar Wochen bootet sich mein System gelegentlich von selbst, meistens zwischen 0:00 und 4:00 Uhr. Das passiert aber nur ca. 1-2 mal pro Woche.

Nach einem Supend-to-Disk startet er sich immer nach 30s bis 5min wieder...

Hat jemand ne Ahnung warum das so ist und wie ich das deaktivieren bzw. steuern kann?

Code: [Select]
aim@i7:~$ inxi -v3
System:    Host: i7 Kernel: 3.3-0.towo.2-siduction-amd64 x86_64 (64 bit, gcc: 4.6.3)
           Desktop: KDE 4.7.4 (Qt 4.7.4) Distro: aptosid 2011-01 Γῆρας - kde-lite - (201102051540)                                                                          
Machine:   Mobo: ASUSTeK model: P8H67 version: Rev X.0x Bios: American Megatrends version: 1002 date: 04/12/2011                                                            
CPU:       Quad core Intel Core i7-2600K CPU (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28017.1                                  
           Clock Speeds: 1: 3401.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 3401.00 MHz 5: 1600.00 MHz 6: 1600.00 MHz 7: 1600.00 MHz 8: 1600.00 MHz                            
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI Cayman XT [Radeon HD 6970] bus-ID: 01:00.0                                                                            
           X.Org: 1.11.4 driver: fglrx Resolution: 1920x1200@60.0hz, 1920x1200@60.0hz, 1920x1200@60.0hz                                                                    
           GLX Renderer: AMD Radeon HD 6900 Series GLX Version: 4.2.11566 - CPC Direct Rendering: Yes                                                                      
Network:   Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller                                                                                              
           driver: r8169 ver: 2.3LK-NAPI port: b000 bus-ID: 08:00.0                                                                                                        
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: f4:6d:04:d2:6a:85                                                                                          
Drives:    HDD Total Size: 1530.3GB (19.2% used) 1: WDC_WD1002FAEX                                                                                                          
           2: OCZ 3: WDC_WD2500JS 4: WDC_WD1600JD                                                                                                                          
Info:      Processes: 196 Uptime: 12:44 Memory: 1689.9/7973.4MB Runlevel: 5 Gcc sys: 4.6.3 Client: Shell inxi: 1.7.29

hefee

  • Guest
RE: System bootet sich von selbst
« Reply #1 on: 2012/04/23, 12:19:38 »
Schau mal ob WakeOnLan im BIOS aktiviert ist. Das hatte bei mir ähnliches bewirkt.

Offline Sir_Aim

  • User
  • Posts: 50
(gelöst) System bootet sich von selbst
« Reply #2 on: 2012/04/24, 13:34:37 »
Also WOL ist bei dem Rechner schonmal deaktiviert.

Ich habe im aptosid Forum einen passenden Thread gefunden der das gleiche Verhalten beschreibt:
http://www.aptosidusers.de/index.php?name=PNphpBB2&file=viewtopic&t=1323&postdays=0&postorder=asc

Wenn ich das beim überfliegen richtig verstanden hab sollte es reichen den wakealarm beim shutdown auf 0 zu setzen...

Ich hab mir jetzt folgendes init-script gebastelt und als K10remove-wakealarm in /etc/rc0.d gelinkt:

Code: [Select]
#! /bin/sh
### BEGIN INIT INFO
# Provides: remove-wakealarm        
# Required-Start:
# Required-Stop:
# Default-Start:
# Default-Stop:      0 6
# X-Stop-After:      hwclock
# Short-Description: Set rtc wakealarm to 0
### END INIT INFO

case "$1" in
  start)
        # No-op
        ;;
  restart|reload|force-reload)
        echo "Error: argument '$1' not supported" >&2
        exit 3
        ;;
  stop)
        echo 0 > /sys/class/rtc/rtc0/wakealarm
        echo "Wakealarm set to 0"
        ;;
  *)
        echo "Usage: $0 start|stop" >&2
        exit 3
        ;;
esac

:


Keine Ahnung ob das so korrekt ist - aber mal schauen obs hilft ;)

Offline Sir_Aim

  • User
  • Posts: 50
(gelöst) System bootet sich von selbst
« Reply #3 on: 2012/05/09, 15:07:37 »
So, 2 Wochen ohne nächtliches selbst booten...

Das scheint also zu funktionieren ;)

Problem gelöst...

Offline cryptosteve

  • User
  • Posts: 675
(gelöst) System bootet sich von selbst
« Reply #4 on: 2012/05/09, 18:19:50 »
Erstaunlich ... danke für die Rückmeldung.
- born to create drama -
CS Virtual Travel Bug: VF6G5D