Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F1...  (Read 4013 times)

Offline pit

  • User
  • Posts: 222
Ganz sicher habe ich mich mit meinem Vorgehen von einem aptosid bzw. siduction-Standardsystem entfernt. Wenn dabei etwas schief läuft, ist das nur mir zuzuschreiben. Bevor ich jetzt aber komplett neu installiere (hatte aptosid ohne Neuinstallation in siduction umgewandelt), frage ich hier im Bereich für Experimentelles, ob vielleicht jemand spontan weiß, was gegen folgendes Problem hilft:

Ich wollte wie im Forum beschrieben kde 4.7.2 aus qt-kde installieren, habe mich dabei verfranst und bin bei 4.7.4 aus experimental gelandet. Das funktioniert auch wunderbar.

Mein Problem: Wenn ich nach der grafischen Anmeldung versuche, via STRG + ALT + F1 (F2, F3 ...) auf eine der Konsolen zu kommen, erscheint jeweils ein komplett schwarzer Bildschirm, Tastatureingaben werden nicht ausgegeben. Mit Alt + F7 komme ich aber problemlos zurück nach KDE. Der Wechsel klappt noch, wenn der KDE-Login Bildschirm gezeigt wird, die Anmeldung aber noch nicht erfolgt ist.

Google hat mich nicht weitergebracht, vielleicht hat hier jemand einen Tipp, was ich tun kann?

Kleiner Überblick über das, was ich installiert/deinstalliert habe:
http://paste.siduction.org/20120103173339
(aktuelle apt-history)

Mein System:

Code: [Select]
System:    Host dell-notebook Kernel 3.1-6.towo.3-siduction-amd64 x86_64 (64 bit) Distro "aptosid" "2011-01 Γῆρας - kde-full - (201102052200)"                                                                
CPU:       Dual core Intel Core i3-2310M (-HT-MCP-) cache 3072 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) clocked at 800.00 MHz                                                                  
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller X.org 2) Res: 103x29 Gfx Data: N/A for root                                                                        
Network:   Card-1 Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver r8169          
           Card-2 Atheros AR9285 Wireless Network Adapter (PCI-Express) driver ath9k                  
Disks:     HDD Total Size: 500.1GB (27.6% used) 1: ST9500420AS                                        
Info:      Processes 174 Uptime 25 min Memory 1012.9/3874.2MB Client Shell inxi 1.4.95


Einige der Seiten, die ich mich Google gefunden habe, empfahlen Änderungen in der Grub-Config. Ich habe nichts geändert, aber vielleicht findet sich hier etwas?

Code: [Select]
cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
# GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash resume=swap=UUID=895e1340-a673-435d-938b-a5b3c70fc4ad"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Offline Geier0815

  • User
  • Posts: 562
KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F1...
« Reply #1 on: 2012/01/03, 20:02:21 »
Magst Du mal in deiner /etc/inittab gucken ob da was drin ist ala:
Code: [Select]
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline pit

  • User
  • Posts: 222

Offline ralul

  • User
  • Posts: 1.814
KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F1...
« Reply #3 on: 2012/01/03, 20:11:48 »
Mir fallen 3 Dinge ein/auf:
- debug - hin - her ?
- intel Grafik - könnte sich von allein beim nächsten Kernel bessern!
- kde-Pakete aus experimental vollständig? Datei in /etc/apt/preferences.d abgelegt? (siehe Forum)

Kde-4.7.4 aus experimental ist gut und besser. Bleib dabei.
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline pit

  • User
  • Posts: 222
KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F1...
« Reply #4 on: 2012/01/03, 20:23:22 »
@ralul
cat /etc/apt/preferences.d/kde-experimental
=> http://paste.siduction.org/20120103191509

Was meinst du mit debug hin/her? Das was ich via apt installiert u. dann wieder deinstalliert habe? Ich war auf der Suche nach kdesu und war der Meinung, es mit dem Paket kde-runtime-dbg installieren zu können. Das zog einige andere neuen Pakete nach und aktualisierte eine ganze Reihe vorhandener Pakete. Das oben beschriebene Problem ist mir erst danach aufgefallen. Meine Hoffnung, es durch die Deinstallation dieser neuen Pakete zu lösen, hat sich aber nicht erfüllt.

Ergänzung: Diese KDE-Pakete sind installiert:

http://paste.siduction.org/20120103193920

Habe noch zwei ältere Kernel gebootet, gleiches Problem.

3.1-6.slh.1-aptosid-amd64
3.1.6.towo.2-siduction-amd64

Offline Geier0815

  • User
  • Posts: 562
KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F1...
« Reply #5 on: 2012/01/03, 20:24:58 »
Unter suse hat es wohl hin und wieder Probleme mit kdm gegeben die ähnliche Probleme verursacht haben. Teste doch mal ob es mit gdm oder xdm besser geht. Dies ist jetzt natürlich reine glaskugel-leserei... also keine Garantie das es Besserung bringt.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline pit

  • User
  • Posts: 222
RE: KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F
« Reply #6 on: 2012/01/03, 20:35:01 »
Ich habe probeweise mal fluxbox gestartet. Hier klappt alles, ich kann mit STRG + ALT + Fn problemlos auf die Konsolen wechseln.

Online devil

  • Administrator
  • User
  • *****
  • Posts: 4.697
RE: KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F
« Reply #7 on: 2012/01/03, 20:42:23 »
Weisst du denn, ob du, unterliegend, die Pakete von qt-kde installiert hast? Wenn ja, könnte eventuell
Code: [Select]
aptitude -t experimental install ~S~i~Aexperimental-snapshotshelfen.

greetz
devil

Offline pit

  • User
  • Posts: 222
RE: KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F
« Reply #8 on: 2012/01/03, 20:48:37 »
@devil
Code: [Select]
aptitude -t experimental install ~S~i~Aexperimental-snapshots
Die folgenden Pakete werden ENTFERNT:        
  freespacenotifier{u} libkwineffects1abi1{u} libqtlocation1{u} libqtmultimediakit1{u} libsolidcontrol4abi1{u} libsolidcontrolifaces4abi1{u} xulrunner-8.0{u}
0 Pakete aktualisiert, 0 zusätzlich installiert, 7 werden entfernt und 109 nicht aktualisiert.
Muss 0 B an Archiven herunterladen. Nach dem Entpacken werden 30,0 MB frei werden.
Wollen Sie fortsetzen? [Y/n/?]

Das mach ich dann wohl mal.

Edit: Leider keine Besserung.

Edit: In /var/log/messages fand sich folgende Zeile:

Code: [Select]
dell-notebook kernel: [   44.928032] [drm] Changing LVDS panel from (+hsync, -vsync) to (-hsync, +vsync)

Auch wenn es vermutlich gar keinen Zusammenhang gibt, habe ich mal krandrtray gestartet. Dort war (anders als bisher) für LVDS1 die Größe 1366x768 gewählt, korrekt müsste ein Eintrag mit gleicher Größe aber dem Zusatz "(Auto)" sein. Das habe ich korrigiert, die Bildwiederholrate wurde dabei von 59,8 HZ ebenfalls auf "Automatisch" geändert.

Und siehe da: Alles ist gut.

siducerm

  • Guest
RE: KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F
« Reply #9 on: 2012/01/08, 16:17:53 »
Hallo,

wenn man sich genau an folgende Anleitung hält ist alls sofort gut.

http://pkg-kde.alioth.debian.org/kde47.html


@ralul
Quote
- kde-Pakete aus experimental vollständig? Datei in /etc/apt/preferences.d abgelegt? (siehe Forum)


Welcher Thread ist gemeint?


Also KDE 4.7.4 trat ein richtiger *wow Effekt ein, funktioniert echt besser. Und fühlt sich schneller an, oder ist es.

MfG

siducerm

holgerw

  • Guest
KDE 4.7.4 aus experimental: black screen nach STRG/ALT/F1...
« Reply #10 on: 2012/01/08, 18:42:27 »
Hallo,

zu der kde-experimental: Ich habe sie noch um digikam, digikam-data, kipi-plugins und kipi-plugins-common ergänzt, sonst gibt es Schwierigkeiten beim Versuch, das aktuelle digikam zu installieren.

Viele Grüße,
  Holger