Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  xorg-Neuinstallation-kein Login  (Read 11318 times)

Offline unklarer

  • User
  • Posts: 849
xorg-Neuinstallation-kein Login
« on: 2016/02/18, 10:39:18 »
Da die Jungs bei bunsenlabs die neue ISO mit einem PAE-Kernel ausliefern, habe ich mir jetzt (weil ich es brauche) die xorg installiert.
Code: [Select]
unklarer@x40:~$ inxi -Fxz
System:    Host: x40 Kernel: 4.4.0-towo.1-siduction-686 i686 (32 bit gcc: 5.3.1)
           Desktop: Fluxbox 1.3.5 Distro: siduction 15.1.0 Paint It Black - xorg - (201601171617)
Machine:   System: IBM product: 2371H8G v: ThinkPad X40
           Mobo: IBM model: 2371H8G Bios: IBM v: 1UETD3WW (2.08 ) date: 12/21/2006
CPU:       Single core Intel Pentium M (-UP-) cache: 2048 KB
           flags: (sse sse2) bmips: 2792 speed: 1400 MHz (max)
Graphics:  Card: Intel 82852/855GM Integrated Graphics Device bus-ID: 00:02.0
           Display Server: X.Org 1.17.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1024x768@50.01hz
           GLX Renderer: Mesa DRI Intel 852GM/855GM x86/MMX/SSE2
           GLX Version: 1.3 Mesa 11.1.1 Direct Rendering: Yes
Audio:     Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
           driver: snd_intel8x0 ports: 1c00 18c0 bus-ID: 00:1f.5
           Sound: Advanced Linux Sound Architecture v: k4.4.0-towo.1-siduction-686
Network:   Card-1: Intel PRO/Wireless 2200BG [Calexico2] Network Connection bus-ID: 02:02.0
           IF: N/A state: N/A mac: N/A
           Card-2: 3Com 3cCFE575CT CardBus [Cyclone] driver: 3c59x port: 3000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 60.1GB (18.6% used) ID-1: /dev/sda model: MXSSD1MNANO size: 60.1GB
Partition: ID-1: / size: 15G used: 3.0G (22%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 3.22GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: 41.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 109 Uptime: 12 min Memory: 134.8/1503.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.3.1 Client: Shell (bash 4.3.421) inxi: 2.2.32
Nach dem Neustart lande ich an einem schwarzen Schirm ohne alles.
Kann mich jedoch auf tty3 einloggen und mit startx   ;) Fluxbox starten. Hier habe ich nur die Toolbar, keine Maus. Durch

Rechtsklick erscheint das Menü und mit den Pfeiltasten kann ich eine Anwendung, hier z.B. ein Terminal, mit "Enter" auswählen und,  jetzt ist auch die Maus da.
In der Zwischenzeit hatte sich Gestern das Problem mit der Maus nach dem ersten D-U und dem 4.4.1 erledigt.
Heute habe ich schon den 4.4.2 mit einem weiteren D-U 'drauf, das mit dem Login besteht weiter.
Durch suchen im Forum habe ich das jetzt auch so mit dem autologin  in der /etc/sddm.conf gemacht. Was einwandfrei klappt. Durch bearbeiten der ~/.fluxbox/startup habe ich auch mein eigenes Hintergrundbild.

Das Problem wird dann wieder beim Klick auf EXIT im Fluxbox-Menü sichtbar. Es zeigt sich der schwarze Schirm, ohne alles
und ich muß tty3 benutzen, um den Rechner mit systemctl reboot -i zum 'runterfahren zu bewegen.
Bisher habe ich nicht herausfinden können, was da fehlt. Der Status von sddm.service ist i.O.
Weiß jemand von Euch Rat?

Offline paxmark2

  • User
  • Posts: 85
Re: xorg-Neuinstallation-kein Login
« Reply #1 on: 2016/02/19, 01:50:09 »
DE:  Welcher Teil ist BunsenLabs? Welcher Teil ist paintitblack?

[size=78%]Ich bin nur ein Hobby und ich sehe nichts offensichtlich falsch, Verzeihen Sie mir, wenn meine Gedanken zur Seite ging, die Bunsenlabs Begriff verwirrend ist.[/size]

EN:  What part is BunsenLabs?   What part is Paintitblack? 

I am just a hobbyist and I do not see anything obviously wrong, Pardon me if my thoughts went sideways, the Bunsenlabs phrase is confusing. 

Offline unklarer

  • User
  • Posts: 849
Re: xorg-Neuinstallation-kein Login
« Reply #2 on: 2016/02/19, 11:21:15 »
Hello @paxmark2,

thanks for your reply.
It concerns only the paintitblack (xorg). The confusion is here:  https://forums.bunsenlabs.org/viewtopic.php?pid=19058#p19058

With Bunsen labs that has nothing to do.   ;)

Offline paxmark2

  • User
  • Posts: 85
Re: xorg-Neuinstallation-kein Login
« Reply #3 on: 2016/02/19, 17:57:50 »
If, if your Celeron M does NOT support pae  - then you must use a non-pae kernel.  Some do, some do not.

I am not going to look  in detail about the 32 bit kernels in siduction.  i686 version equals pae to me. 

A quick search   when I hear fluxbox and sid I think vsido

http://vsido.org/index.php?topic=339.msg4433#msg4433    No non-pae

I used cruchbang for years, and did install bunsen on a separate drive.  Bunsenlabs was working on a non-pae kernel for RC2 as of 2 two days ago. 

Kernels.  You have a very old machine, I have old machines myself.  The newest kernel will not always be your friend.     

Possibly the best way to attack your problem is to search for people who have had success with your ThinkPad X40 in Debian and Debian derivatives, install and modify to your style. 

Offline unklarer

  • User
  • Posts: 849
Re: xorg-Neuinstallation-kein Login
« Reply #4 on: 2016/02/19, 19:44:24 »

Many thanks for your help.
@hhh said not pae kernel earlier than in a month at Bunsen labs.
But as long as I did not want to wait, so the experiment with siduction.

Previously here antiX-M11 on it.
I need the x40 because I-tuning with unison all my computers.

I do not plan to install additional kernel. At the moment the machine is surprisingly good (surfen, no flash; E-mail). There is only the problem with sddm. I see no login screen. Also do I do this by "automatic login".

If I find no solution, then I try lightdm. The has worked with me everywhere.   ;)


Offline musca

  • User
  • Posts: 725
  • sid, fly high!
Re: xorg-Neuinstallation-kein Login
« Reply #5 on: 2016/02/21, 13:27:57 »

   i686 version equals pae to me.
That's the situation in ubuntu!

siduction has three kernel packages to offer:
 1)  linux-image-siduction-amd64 (integrated in the amd64.iso)

Our primary architecture is the 64 bits capable x86-64 or "amd64".
Don't worry about the "amd" name -- it is for intel and AMD processors sold in the last decade:
intel Core 2, Atom 230/330, Atom N400/N500  or AMD Athlon64, Opteron, Phenom, Sempron).
Beware: most the intel atoms of the bay trail systems can't execute 64-bit Linux, because of their 32-Bit UEFI implementation. siduction-amd64 doesn't support 32-bit UEFI.
The name "AMD64" honors the fact that this architecture was first invented by AMD and later cross-licensed with intel SSE2. Did you even notice that for over a decade the multi billion dollar company intel has tried to push the market to its own 64-bits archtitecture "Itanium"? For this reason when intel licensed the amd64 architecture they used funny names like "Enhanced Memory 64 Technology (EM64T, later renamed to intel 64)" to hide the fact.

2a) linux-image-siduction-686        (integrated in the i386.iso)
2b) linux-image-siduction-686-pae (available from the extra repo)

Thy olde x86 architecture as found in fields, forests and meadows.
Named after the intel i80686 processor it is best for
  • intel: PentiumPro™ (© 1994), Pentium II, III, M, Pentium 4, Core Solo, Core Duo, Atom Z500/N270/N280)
  • AMD Athlon Processors until AthlonXP (still without SSE2, dated 2002).
Two of theese processors were special. The Pentium M was optimized for low power consumption, it was found in high performance notebooks and it doesn't support PAE (officially). The Pentium 4 Extreme Edition and the Pentium D are 64-bit capable, if the mainboard chipset permits the property, too.
On i386 systems equipped with more than 3 GB of RAM you might want to install the -pae kernel for advanced memory mapping.

« Last Edit: 2016/02/21, 13:51:59 by musca »
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)