Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Unable to install / upgrade  (Read 2563 times)

Offline RunLevelZero

  • User
  • Posts: 9
[EN] Unable to install / upgrade
« on: 2023/09/07, 19:36:47 »
Hello everyone. I hope you're all doing well. I am having an issue after trying to install xdotools. It wanted to remove linux-image-6.4.10-2-siduction-amd64. I am on currently booting into kernel 6.4.13-1. I get the below message. I have done a --fix-missing and reconfigured grub-common and reinstalled grub plus a update-grub. I am hoping someone can shed some light on why it's missing a btrfs file when I do not use btrfs? Below is my error.

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/giants/theme.txt
Found linux image: /boot/vmlinuz-6.5.2-1-siduction-amd64
Found initrd image: /boot/initrd.img-6.5.2-1-siduction-amd64
Found linux image: /boot/vmlinuz-6.4.13-1-siduction-amd64
Found initrd image: /boot/initrd.img-6.4.13-1-siduction-amd64
Found linux image: /boot/vmlinuz-6.4.12-1-siduction-amd64
Found initrd image: /boot/initrd.img-6.4.12-1-siduction-amd64
Found linux image: /boot/vmlinuz-6.4.11-1-siduction-amd64
Found initrd image: /boot/initrd.img-6.4.11-1-siduction-amd64
Found memtest86+ 64bit EFI image: /boot/memtest86+x64.efi
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
chmod: cannot access '/etc/grub.d/09_siduction-btrfs': No such file or directory

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.358
    • Land of the Buckeye
Re: Unable to install / upgrade
« Reply #1 on: 2023/09/07, 20:02:56 »
I don't know anything about this package. I did a simulated installation on my ancient Dell LXQt laptop, and it seemed to have no problems:

Code: [Select]
$ sudo apt install -s xdotool
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libxdo3
The following NEW packages will be installed:
  libxdo3 xdotool
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Inst libxdo3 (1:3.20160805.1-5 Debian:unstable [amd64])
Inst xdotool (1:3.20160805.1-5 Debian:unstable [amd64])
Conf libxdo3 (1:3.20160805.1-5 Debian:unstable [amd64])
Conf xdotool (1:3.20160805.1-5 Debian:unstable [amd64])

In my /etc/grub.d/ directory, there is no 09-xxx file of any kind.

Is there some reason you are keeping all those old kernels? In a standard siduction installation, apt asks to remove kernels older than the previous two or three.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline RunLevelZero

  • User
  • Posts: 9
Re: Unable to install / upgrade
« Reply #2 on: 2023/09/07, 20:23:47 »
I did an autoclean and auto remove this morning which I'm wondering if it may have contributed to the issue. I am using xdotool for xbindkeys. It's very bizarre to me really. This install of sid is not that old. I used standing on the shoulders for kde plasma. I have no 09 file either so it's just strange why it's trying to chod the file at all. I usually keep a few kernels around in case I need to boot into one for some odd reason but I went to clean them up today, attempted to install xdotool and it wasn't happy so I did the usual steps for a full upgrade and now I'm stuck.

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.937
Re: Unable to install / upgrade
« Reply #3 on: 2023/09/07, 20:42:55 »
apt install siduction-btrfs
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline RunLevelZero

  • User
  • Posts: 9
Re: Unable to install / upgrade
« Reply #4 on: 2023/09/07, 20:49:35 »
Thanks but apparently it is already installed. Maybe a remove and reinstall? I am sure it will fail to remove so maybe a dpkg purge? Appreciate you guys a lot for trying to help me out.

siduction-btrfs is already the newest version (0.1.1-1).

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.937
Re: Unable to install / upgrade
« Reply #5 on: 2023/09/07, 20:57:57 »
Code: [Select]
apt install --reinstall grub-btrfs
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline RunLevelZero

  • User
  • Posts: 9
Re: Unable to install / upgrade
« Reply #6 on: 2023/09/07, 21:00:29 »
It so stuck on this that I can't even do that.

chmod: cannot access '/etc/grub.d/09_siduction-btrfs': No such file or directory
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: error processing package linux-image-6.4.10-1-siduction-amd64 (--remove):
 installed linux-image-6.4.10-1-siduction-amd64 package post-removal script subprocess returned error exit status 1
dpkg: too many errors, stopping
Errors were encountered while processing:
 linux-image-6.4.10-1-siduction-amd64
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.937
Re: Unable to install / upgrade
« Reply #7 on: 2023/09/07, 21:01:33 »
/etc/grub.d/09_siduction-btrfs

is clearly in package siduction-btrfs
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline RunLevelZero

  • User
  • Posts: 9
Re: Unable to install / upgrade
« Reply #8 on: 2023/09/07, 21:05:16 »
This is what is in my dir....

I only see 09_siduction-btrfs.dpkg-dist

ls /etc/grub.d/
00_header  05_debian_theme  09_siduction-btrfs.dpkg-dist  10_linux  20_linux_xen  20_memtest86+  25_bli  30_os-prober  30_uefi-firmware  35_fwupd  40_custom  41_custom  41_snapshots-btrfs  backup  LS_siduction-btrfs  proxifiedScripts  README

Online towo

  • Administrator
  • User
  • *****
  • Posts: 2.937
Re: Unable to install / upgrade
« Reply #9 on: 2023/09/07, 21:07:03 »
Code: [Select]
mv /etc/grub.d/09_siduction-btrfs.dpkg-dist /etc/grub.d/09_siduction-btrfs
apt -f install
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline RunLevelZero

  • User
  • Posts: 9
Re: Unable to install / upgrade
« Reply #10 on: 2023/09/07, 21:11:26 »
You sir are amazing. Thank you very very much! That seems to have addressed the issue. Was the .dpkg-dist file perhaps due to the failure to complete the install / configuration of the kernel and just renaming it to the file it was looking for allowed it to "see" the file it was looking for. I'm just trying to understand where things went wrong. I am going to reboot now to make sure all is well.... thank you again for such quick responses and assistance and resolution.

Offline RunLevelZero

  • User
  • Posts: 9
Re: Unable to install / upgrade
« Reply #11 on: 2023/09/07, 21:14:40 »
All is well after the reboot. I do want to mention that I used nala to do my full upgrade. Not sure it matters but I thought I would add it.