Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] [Läuft] Aptosid 2011-2 auf HP Elitebook 8560p  (Read 3675 times)

wofritz

  • Guest
[DE] [Läuft] Aptosid 2011-2 auf HP Elitebook 8560p
« on: 2011/07/23, 15:19:04 »
Hallo Leute,

diese Woche habe ich ein HP Elitebook 8560p bekommen und natürlich sofort aptosid darauf installiert. Hier mein Erfahrungsbericht, vielleicht ist das ja mal für jemanden von Interesse.

Genaue Bezeichnung des Notebooks: HP EliteBook 8560p LQ 589AW

Live-System:
Live-DVD erfordert cheatcodes "radeon.modeset=0 xmodule=vesa", sonst Pixelsalat.

Installation:

1. Partitionieren
Es sind alle primären Partitionen bereits belegt.
sda1: System, Funktion unklar, vermutlich Quickweb
sda2: Windows 7
sda3: HP Recovery
sda4: HP Tools

Partitionen sda3 und sda4 wurden im Live-System mittels partimage
gesichert. Dann wurde im Installer folgende Partitionierung durchgeführt:
1. sda3 und sda4 löschen
2. sda2 auf 100 GB verkleinern
4. erweiterte Partition sda3 anlegen
5. in sda3 folgende logischen Partitionen anlegen:
- sda5: Typ 7 (HPFS/NTFS/exFAT), Grösse wie HP Recovery Partition
- sda6: Typ c (W95 FAT32 (LBA), Grösse wie HP Tools Partition
- sda7: Linux swap 6 GB
- sda8: Linux 10 GB (Root-Partition)
- sda9: Linux 10 GB (für Alternativ-OS)
- sda10: Linux Rest für Daten (/local)

Testweise wurde nun Windows7 gestartet. Es macht einen FS-Check, funktioniert
aber noch. Puh. Die HP-Partitionen wurden mit partimage wiederhergestellt. Ob sie
benutzbar sind oder nicht ist mir nicht klar.

2. Installation:
- Nonfree firmware installieren: firmware-linux-nonfree (für radeon),
firmware-iwlwifi (für iwlagn WLAN-Treiber)

Die Installation läuft problemlos durch und ist nach wenigen Minuten beendet. Os-prober findet 2 mal Windows 7 und ein mal Windows Vista auf den Original-Partitionen. Daher habe ich eine 40.custom angelegt mit einen funktionierenden Eintrag für W7 und den os-prober deaktiviert.

3. Hardware-Support

Graphik:
OSS Radeon: Der aktuelle Radeon-Treiber unterstützt die HD 6470M einschliesslich
Desktopeffekten in KDE. Die Desktopeffekte müssen nach der Installation
eingeschaltet werden. Die Displayhelligkeit ist maximal und kann nicht
geändert werden, weder durch die FN-Tasten noch per Powermanagement.

FGLRX: Der fglrx in sid funktioniert OOTB wenn man eine rudimentäre xorg.conf
anlegt. Nachteil: In der rechten unteren Bildschirmecke erscheint ein
transparentes Wasserzeichen "AMD Unsupported hardware". Vorteil: Es funktionieren
das Powermanagement und das Ändern der Displayhelligkeit. Daher bleibe ich
beim fglrx und hoffe, dass die nächste Version den HD 6470M offiziell
unterstützt.

Tastatur:
Es funktionieren alle Tasten bis auf zwei HP-Spezialtasten, die zum Starten
des HP QuickWeb dienen.

Touchpad:
Funktioniert, muss aber noch optimiert werden (horizontales Scrollen, mittlere
Maustaste, Finetuning).

LAN:
Läuft OOTB. Konfiguration mit ceni.

WLAN:
Läuft OOTB, wenn die Firmware installiert wurde. Konfiguration mit ceni.

Webcam:
Läuft OOTB. Wenn man in Kopete die Videoeinstellungen öffnet, sieht man sofort
die eigene liebliche Hackfresse auf dem Schirm.

Bluetooth:
Läuft OOTB. Verbindung mit Handy konnte hergestellt werden.

Sound:
Läuft OOTB.

Nicht getestet mangels passender Hardware:
SATA, USB 3, VGA, Displayport, Modem, SD-Card-Reader, Fingerprint reader

Suspend to disk, suspend to RAM: Funktionieren.

Akkulaufzeit: Noch unbekannt. Lüfterverhalten in Windows 7 und aptosid ist
vergleichbar, also vermutlich etwa gleiche Akkulaufzeit unter beiden OS.

Fazit:
Das Notebook ist gut für aptosid geeignet. Die Installation ist wegen der
recht komplexen Partitionierung aber etwas tricky.

Hier noch infobash -v der aktuellen Konfiguration:
Code: [Select]
Host/Kernel/OS  "eddie" running Linux 3.0-0.slh.3-aptosid-amd64 x86_64 [ aptosid 2011-02 Ἡμέρα - kde-full - (201107131633) ]
CPU Info        4x Intel Core i5-2540M @ clocked at [ 800.000 MHz ]                                                                                                          
Videocard       ATI NI Seymour [AMD Radeon HD 6470M]  X.Org 1.10.2.902  [ 1600x900@60.0hz ]                                                                                  
Processes 150 | Uptime 2:30 | Memory 804.0/3919.0MB | HDD Size 320GB (2%used) | GLX Renderer AMD Radeon HD 6400M Series | GLX Version 4.1.10834 Compatibility Profile Context | Client Shell | Infobash v3.36    


Wolfgang

Ignaz

  • Guest
RE: [Läuft] Aptosid 2011-2 auf HP Elitebook 8560p
« Reply #1 on: 2012/02/14, 19:33:49 »
Danke für den ausführlichen Bericht! Zwei Fragen hätt' ich noch, so aus Neugier:

1. Funktioniert der eingebaute Helligkeitssensor (wenn überhaupt einer drin ist)? Als ich aptosid auf einem 8540p (mit nVidia-GPU) bei uns in der Arbeit getestet habe, konnte ich ihn ohne Weiteres ein- und ausschalten und er hat auch gearbeitet.

2. (bissl exotischer): Kannst Du den Mikrofonanschluss und das interne Mikro getrennt voneinander regeln? Bei meinem Belinea-Notebook hab ich das Problem, dass ich zwar über den Mikrofonanschluss in Stereo aufnehmen kann – z. B. beim Digitalisieren von Schallplatten – aber dann ist das eingebaute Mikro ebenfalls offen und wenn ich es ausschalte, kann ich auch nicht mehr aufnehmen.

Grueße
Ignaz

wofritz

  • Guest
RE: [Läuft] Aptosid 2011-2 auf HP Elitebook 8560p
« Reply #2 on: 2012/02/15, 07:52:35 »
Moin,
zu 1. Der Helligkeitssensor funktioniert. Ich benutzte den fglrx-Treiber, ob er auch mit dem Open-Source-Treiber funktioniert, weiß ich nicht. Die Helligkeitseinstellung per Tasten oder SW funktionierte mit dem OS-Treiber jedenfalls nicht.

zu 2. Hab ich nie getestet, werde es heute Abend mal ausprobieren. Bin aber inzwischen auf Kubuntu umgestiegen  :oops:

wofritz

  • Guest
RE: [Läuft] Aptosid 2011-2 auf HP Elitebook 8560p
« Reply #3 on: 2012/02/18, 11:59:34 »
So, ich hab jetzt mal das Aufnehmen getestet:
Wenn ich das externe Mic einstöpsele, wird das interne abgeschaltet. Ich vermute, das wird hardwäremässig gemacht, denn die Regler für internes und externes Mic bleiben unverändert, und Ändern des Pegels am inaktiven Mic hat keine Auswirkung.

kwoby

  • Guest
[Läuft] Aptosid 2011-2 auf HP Elitebook 8560p
« Reply #4 on: 2012/04/14, 18:12:33 »
Hallo,

Watermark "unsopported Hardware" kannst Du so weg kriegen:


Code: [Select]

#!/bin/sh
DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
 sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
done


Dies habe ich auf folgendem Link gefunden:

https://wiki.archlinux.org/index.php/ATI_Catalyst

Gruss
Kwoby