Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  [Solved] Normal User Cannot Shut Down - December RQT  (Read 3634 times)


  • Guest
My system has acquired an odd bug:  as a normal user of "December" with Razor-QT, I cannot shutdown or reboot using selections from the menu.  A D-bus error is thrown back, saying that the action is denied.

I can, however, issue a sudo poweroff or sudo reboot command.  It appears that my permissions for normal users are mangled, as even newly created users have the same problem.  I've tried removing and reinstalling razor-qt, policykit, and systemd and have the same system behavior happening.

Another possible side effect of this problem is behavior of Qtfm.  I cannot click to open files in LibreOffice, VLC, and other applications.  Editing the mime types / default apps has no effect.

Can someone suggest another action to repair the system?
« Last Edit: 2014/09/19, 06:32:05 by brightflash64 »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
Re: Normal User Cannot Shut Down - December RQT
« Reply #1 on: 2014/09/18, 20:15:25 »
I'm not a Razor-QT user, but substituting "shutdown" for "hibernate", this looks a lot like your problem. 
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Normal User Cannot Shut Down - December RQT
« Reply #2 on: 2014/09/18, 20:38:11 »
drop qtfm and take pcmanfm-qt5 - if new in repo
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)


  • Guest
Re: [Solved] Normal User Cannot Shut Down - December RQT
« Reply #3 on: 2014/09/19, 06:50:22 »
Interestingly, I encountered the same problem in Siduction "Paint it Black" - the very slick upcoming version with LXQT.  All was well until the first dist-upgrade, and then it happened.  Searching a bit more revealed the solution:  editing the grub2 kernel arguments to include init=/bin/systemd.

Along the way, I removed Qtfm and made PCManFM (pcmanfm-qt) my default file manager.

I'm happy with Sid again, running bleeding edge LXQT on a system that shuts down when necessary.  It shuts down fast!  From the last click to all lights out is about 5 seconds. 

Thanks for the suggestions, as they led to a solved problem.