Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Tastaturlayout DE nach Start nicht eingestellt  (Read 10124 times)

c.monty

  • Guest
[DE] Tastaturlayout DE nach Start nicht eingestellt
« on: 2015/07/19, 20:11:31 »
Hallo!

Ich habe die aktuelle Version von siduction installiert.
Allerdings habe ich nach dem Starten immer das Tastaturlayout US eingestellt.

Der Befehl dpkg-reconfigure keyboard-configuration aus dem Wiki endet mit einem Fehler:
Code: [Select]
dpkg-reconfigure keyboard-configuration
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

Ich kann über die Konsole das Tastaturlayout DE manuell einstellen:
Code: [Select]
setxkbmap -model pc105 -layout de -variant basic

In der Konfiguration des Xservers steht:
Code: [Select]
Section "InputDevice"
    # generated from default
    #Identifier     "Keyboard0"
    Identifier     "Logitech MK710"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules"      "xorg"
    Option         "XkbModel"      "pc105"
    Option         "XkbLayout"     "de"
    Option         "XkbVariant"    "nodeadkeys"
    Option         "XkbOptions"    "ctrl:nocaps"
EndSection
Das wird aber hinsichtlich dem Tastaturlayout offensichtlich ignoriert.

Frage:
Wie kann ich das Tastaturlayout fix auf DE einstellen?

THX

Offline ayla

  • User
  • Posts: 1.744
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #1 on: 2015/07/19, 20:51:47 »
Schau mal in diese beiden threads, vielleicht hilft Dir da was weiter. Dies scheint ein öfter mal auftretendes Problem  mit einigen wenigen Logitech Boards zu sein.

http://forum.siduction.org/index.php?topic=3415.msg29246#msg29246

http://forum.siduction.org/index.php?topic=5371.msg43945#msg43945

Offline der_bud

  • User
  • Posts: 1.072
  • member
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #2 on: 2015/07/19, 20:57:37 »
Hallo c.monty, Willkommen im Forum. Gibst Du bitte auch noch an welchen Desktop Du verwendest (KDE, Gnome, Cinnamon, ...), könnte eventuell bei der Lösungssuche helfen ;)
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #3 on: 2015/07/19, 22:24:18 »
@der_bud: verlang doch nicht immer so unmögliche Sachen, das muss auch ganz ohne sinnvolle Infos gehen
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

c.monty

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #4 on: 2015/07/20, 19:52:14 »
Code: [Select]
System:    Host: pc1-gigabyte Kernel: 4.1.2-towo.2-siduction-686 i686 (32 bit)
           Desktop: Cinnamon 2.6.13
           Distro: siduction 14.1.0 Indian Summer - cinnamon - (201411230313)

Die Links helfen mir leider nicht weiter.

Denken ist ja nicht verboten... und demnach wird durch den Befehl
Code: [Select]
setxkbmap -model pc105 -layout de -variant nodeadkeys -option lv3:ralt_switch,terminate:ctrl_alt_bksp
auf das deutsche Tastaturlayout umgestellt.

 In der /etc/default/keyboard steht das drin:
Code: [Select]
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="nodeadkeys"
XKBOPTIONS="lv3:ralt_switch,terminate:ctrl_alt_bksp"

BACKSPACE="guess"

Sollte dies wirklich die Ursache für das falsche Tastaturlayout sein?

Oder wird beim Systemstart ganz zum Schluß eine Einstellung verwendet, die alles zuvor überschreibt, also auch das, was in der Konfiguration des Xservers steht?

Und dann noch diese Feststellung: das Tastaturlayout EN ist bereits beim Anmeldefenster eingestellt, und dort habe ich keine Möglichkeit etwas umzustellen.
« Last Edit: 2015/07/20, 20:16:38 by c.monty »

holgerw

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #5 on: 2015/07/21, 12:43:29 »
Hallo,

mal dazwischen gefragt: Spielt das Desktop Environement bezogen auf die Eingangsfrage eine große Rolle beim Tastaturlayout? Ich bekomme ein wenig den Eindruck, wenn ich hier einige Kommentare lese. Wenn ich siduction starte und gebe ihm deutsch und Berliner Zeitzone mit, dann habe ich deutsches Tastaturlayout sowohl in RL 3 als auch bei X Applikationen, ob ich nun xfce oder kde benutze.

Viele Grüße,
  Holger

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #6 on: 2015/07/21, 13:32:42 »
@holgerw: Wer die Taste F2 kennt und siduction dann auch so installiert, sollte keine Probleme haben - und je nach DE wird die Tastaturbelegung dann auch noch in Applets abgelegt, z.b. in LXDE und LXQt - einfach weil es bisher nicht anders ging. Insofern ist das schon relevant
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline ayla

  • User
  • Posts: 1.744
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #7 on: 2015/07/21, 15:45:06 »
Wer die Taste F2 kennt und siduction dann auch so installiert, sollte keine Probleme haben

Wie Du sagst: sollte

Ist aber bei meinem logitech keyboard jetzt bei 2 von den letzten Releases nicht so gewesen. Trotz F2 US in KDE und Konsole, bei mehreren Installationsversuchen mit dem gleichen ISO: Mal DE, mal US.
Anderes Keyboard: Immer DE

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #8 on: 2015/07/21, 20:53:54 »
nu ja - das hatte dann andere Ursachen, das war dann systemd (wenn der Installationsversuch noch nicht allzulange her ist - und auch das erst nach dem ersten d-u. ich leg meine Hand nicht dafür ins Feuer, aber die Isos sollten funktionieren™ und in sich konsistent sein. 8)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline ayla

  • User
  • Posts: 1.744
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #9 on: 2015/07/21, 21:14:33 »
Leider war es so daß bereits im Livesystem das Tastaturlayout trotz Wahl von DE auf US blieb -mit Ausnahme CLI- und dies, auch wenn die Umstellung im Live dann gelang, dieses nicht ins installierte System übernommen wurde -bzw nicht immer. Ich kanns aber nicht mehr wirklich nachvollziehen.

Das gleiche -oder wenigstens ein sehr ähnliches- Problem hatte ich auch gelegentlich bei Installatiosversuchen von Indian Summer, obwohl jetzt systemd. Da wir aber das Problem bei einem der beiden obigen Threads an der Logitech Tastatur festgemacht hatten und es auch nicht irgendwie nachvollziehbar aufgetreten ist hab ichs halt wieder mit durchprobieren beseitigt oder Neustart bis es funktioniert -für meine Tastatur könnt schließlich ihr nix :) 

Ich denke deshalb auch nicht daß es am Iso liegt, wie gesagt: Anderes keyboard angeschlossen und immer das korrekte Layout.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #10 on: 2015/07/21, 21:24:11 »
örgs - nu gut, ich hab auch ne Logi K360 und in der letzten Zeit nur Probleme mit systemd und udev gehabt bei der nicht so gelungenen systemd 220 - da ich aber nicht wirklich der KDE-Experte bin und eh die Umstellung auf KF5/Plasma5 ansteht, werd ich da auch nicht mehr nachforschen, komisch ist es aber schon.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

c.monty

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #11 on: 2015/07/21, 21:37:13 »
Ich möchte an dieser Stelle anmerken, dass ich dieselbe Hardware zuvor mit LMDE2, das ebenfalls mit systemd auf Basis von Debian 8 läuft, ohne Probleme verwendet habe.

Und noch ein Argument, das gegen die Ursache mit Logitech-Tastatur spricht:
Ich kann ja mittels Befehl
Code: [Select]
setxkbmap -model pc105 -layout de -variant nodeadkeys -option lv3:ralt_switch,terminate:ctrl_alt_bksp
das Tastaturlayout umstellen.
Folglich muss mit der Tastatur alles i.O. sein.


Offline ayla

  • User
  • Posts: 1.744
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #12 on: 2015/07/21, 21:46:00 »
Ich bin kein Experte oder so was, ich hatte diese Vermutung nur weil das Problem bei einer anderen Tastatur nie aufgetreten ist und ich bei meiner damaligen Suche im Web öfter über Logitech Tastaturen gestolpert bin.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #13 on: 2015/07/21, 22:09:28 »
@c.monty: glaub mir, wir reden grad über was anderes, zumindest die letzten 3 Beiträge - und dafür ist es relativ egal, ob genau Deine Tastatur unter LMDE funktioniert hat oder nicht, weil vollkommen anderer Mechanismus. Und dieser sollte bei ayla eingentlich funktionieren. Sorry, wie gesagt, 2 getrennte Probleme.

@ayla: Wir sollten uns nochmal genauer über Deine Tastatur unterhalten und eventuell wäre es nicht schlecht für mich, mir da direkt selbst ein Bild von zu machen, wenn ich weiss, wonach ich suchen muss.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline ayla

  • User
  • Posts: 1.744
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #14 on: 2015/07/21, 22:19:36 »
@melmarker: ok, ich komm mal ins IRC, wird aber wahrscheinlich WE werden, hab Nachtschicht und bin dann auch tagsüber zu nix zu gebrauchen...