Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Herabstufen auf ein Paket aus stable  (Read 4907 times)

grefabu

  • Guest
[DE] Herabstufen auf ein Paket aus stable
« on: 2010/09/20, 12:36:40 »
Moin,

ich möchte gerne das Paket PHP5 nebst zuhörigen auf die version 5.2 aus stable herabstufen.

Wie mache ich das am geschicktesten? Ich hatte einfach vor per apt-get remove php5 die Pakete zu entfernen und dann mit -t stable wieder hinzuzufügen. Allerdings werden dabei natürlich die von PHP abhängigen Pakete mit entfernt. Kann ich das umgehen?

Grüße

Grefabu

hefee

  • Guest
Herabstufen auf ein Paket aus stable
« Reply #1 on: 2010/09/20, 13:00:53 »
naja ein paket einer bestimmten version zu installieren kannst du über:

Code: [Select]

apt-get install php5/stable

oder mit allen abhängigkeiten aus stable
Code: [Select]

apt-get install -t stable php5


Das ganze ist auch im handbuch beschrieben: http://manual.aptosid.com/de/sys-admin-apt-de.htm#apt-downgrade

Aber mit jedem du wird er wieder die sib version installieren. Deswegen solltest du, wenn es dauerhaft gewünscht ist das ganze noch mittels pinning dauerhaft machen.

Aber mal eine andere Frage, wieso willst du das downgraden, probleme mit der aktuellen version? oder musst du speziell etwas für diese version in stable testen?

grefabu

  • Guest
Herabstufen auf ein Paket aus stable
« Reply #2 on: 2010/09/20, 13:07:20 »
Ich habe unter anderem mal ein Rechnungsprogramm gekauft, das den zend Optimizer (oder wie das Ding heißt) voraussetzt, den gibt es nur für 5.2.

Und wegen einem anderen Problem hat mir jemand zur 5.2 geraten.

Grüße

Grefabu

DonKult

  • Guest
Herabstufen auf ein Paket aus stable
« Reply #3 on: 2010/09/20, 21:30:22 »
In solchen Fällen kann virtualbox oder ähnliches Wunder tun.

Schneller und sauber wäre in dem Fall aber auch ein stable chroot mit debootstrap aufzusetzen und in diesem PHP und Co. zu installieren. Ist gar nicht so schwer wie es sich anhört, um ein bisschen manpage lesen wird man allerdings nicht drumherum kommen…

Offline bluelupo

  • User
  • Posts: 2.068
    • BluelupoMe
Herabstufen auf ein Paket aus stable
« Reply #4 on: 2010/09/21, 09:29:35 »
hi grefabu,
ich würde an deiner Stelle PHP nicht downgraden, das ist mit zu vielen möglichen Risiken verbunden. Versuch das ganze in einer virtuellen Maschine, wie schon DonKult vorgeschlagen hat, zu installieren. Dort kann bestenfalls die VM kaputt gehen. VirtualBox oder Qemu/KVM sind zwei möglichen Kandidaten mit denen du das bewerkstelligen kannst.