Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] [Gelöst: Gemixte Sources] Probleme mit "tex-common" nach full upgrade  (Read 2840 times)

Offline Isegrimm666

  • User
  • Posts: 71
Guten Morgen ...

Nach einem eben erfolgten "apt full-upgrade" warf das system eine Fehlermeldung aus:

Code: [Select]
fmtutil failed. Output has been stored in
/tmp/fmtutil.eSgAw6Lc
Please include this file if you report a bug.

dpkg: Fehler beim Bearbeiten des Paketes tex-common (--configure):
 »installiertes post-installation-Skript des Paketes tex-common«-Unterprozess gab den Fehlerwert 1 zurück
busybox (1:1.36.1-5) wird eingerichtet ...
libnumbertext-data (1.0.11-3) wird eingerichtet ...
libsystemd-shared:amd64 (255~rc2-2) wird eingerichtet ...
libnss-myhostname:amd64 (255~rc2-2) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von texinfo:
 texinfo hängt ab von tex-common; aber:
  Paket tex-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes texinfo (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert

Aus der erzeugten Datei fmtutil.eSgAw6Lc (attached) kann ich jetzt auch kein weiteres Vorgehen erkennen. Recherchen im Internet ergaben keine brauchbaren Hinweise. Ein vorgeschlagenes "dpkg --configure -a" brachte keine positive Veränderung.

Hier im Forum fand ich auch noch keinen Ansatz.

Habt ihr Vorschläge zur Lösung?
« Last Edit: 2023/11/25, 10:13:15 by Isegrimm666 »

Offline ro_sid

  • User
  • Posts: 193
Re: Probleme mit "tex-common" nach full upgrade
« Reply #1 on: 2023/11/20, 17:55:23 »
Zunächst: Ich habe texinfo und tex bei mir in Siduction nicht installiert!

Was mir auffällt ist, daß alle (relevanten) Fehlermeldungen lauten wie
Code: [Select]
fmtutil: running `luahbtex -ini   -jobname=luahbtex -progname=luahbtex luatex.ini' ...
PANIC: unprotected error in call to Lua API (zlib library version does not match - header: 1.2.13, library: 1.3)
und enthalten dieselbe PANIC-Zeile.

Danach wäre die Ursache entweder bei LuaTeX oder der zlib-Library zu suchen. Da LuaTeX als ein TeX von vielen zum texlive-binaries-Paket gehört, würde ich mir zuerst die "zlib" vornehmen. Einfach das Paket zlib1g (auf Verdacht) neu-/reinstallieren, vielleicht geht es dann.

Ferner fällt mir bei der Paketsuche in Debian "unstable" auf:
Quote
Package zlib1g

    sid (unstable) (libs): compression library - runtime
    1:1.3.dfsg-2: alpha amd64 arm64 armel armhf hppa i386 ia64 m68k ppc64 ppc64el riscv64 s390x sh4 sparc64 x32
    1:1.2.13.dfsg-3: mips64el
daß es vorher wohl eine Version 1.2.13 (statt 1.3) [siehe arch: mips64el] gegeben hat. Die Fehlermeldung spricht von "header: 1.2.13" in "library: 1.3". Vielleicht liegt da (noch) ein Fehler vor?!

Offline der_bud

  • User
  • Posts: 1.072
  • member
Re: Probleme mit "tex-common" nach full upgrade
« Reply #2 on: 2023/11/20, 18:23:46 »
Ist dieser Bug:  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1056312 , "#1056312 zlib1g makes tex-common fail to install due to fmtutil failing"
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline Isegrimm666

  • User
  • Posts: 71
Re: Probleme mit "tex-common" nach full upgrade
« Reply #3 on: 2023/11/25, 10:12:04 »
Das Problem lag an einer ganz anderen Stelle: eigene Dummheit  :'(

Als ich 'Masters-of-War' installierte, wollte ich unbedingt meinen Lieblingsdesktop 'Cinnamon' behalten, der wurde aber nicht mehr supported. Ich fand eine Installationsquelle in den Archiven, die 'Masters-of-war' mit 'Cinnamon' anbot ... aber dazu 'experimental'-Sources nutzte.

Lief auch alles soweit gut.

Im aktuellen Fall hatte ich diesen Mix vergessen und war durch meine Erkältung eh nicht mehr in der Lage, klare Gedanken zu fassen *g ... was dann zu Dingen führte, die ich besser nicht getan hätte.

Als ich dann das full-upgrade durchführte, kam es erst zum beschriebenen Fehler, Tage später - ich dachte noch, es läge vielleicht an einer defekten tex-common - führte ich ein erneutes full-upgrade durch ... und danach ging gar nichts mehr ... kein Desktop kein Linux.

Und da fiel mir das obige Gemixe wieder ein.

Ergebnis:
Ich habe mein Dual-Boot-System wieder neu aufgesetzt, diesmal mit 'Standing-on-the-shoulder-of-giants' mit KDE-Desktop.

Rein und sources-treu.

Lehre aus der Sache:
Erst denken, dann installieren.

Danke an alle, die mir bei der ursprünglichen Problematik geholfen haben ...