Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Virtualbox (7.0.10) modules won't compile with Kernel 6.4.10-1-siduction-amd64  (Read 3791 times)

Offline Teriarch

  • User
  • Posts: 49
/usr/src/virtualbox-7.0.10/vboxnetflt/linux/VBoxNetFlt-linux.c line 50 reads:

#if RTLNX_VER_MIN(6,5,0)

But the current kernel is still 6.4. So you have to change the line into

#if RTLNX_VER_MIN(6,4,0)

in order to succeed. The kernel developers moved functions from
<linux/inetdevice.h> to <net/gso.h>, which could otherwise not be found.


Offline DeepDayze

  • User
  • Posts: 458
That patch works for me as well and thanks for sharing this!  8)