Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved] apt & usrmerge  (Read 2413 times)

Offline orinoco

  • User
  • Posts: 233
  • Bullshit artist
[EN] [solved] apt & usrmerge
« on: 2023/09/18, 09:53:27 »
Hello all,
with the latest version of apt a topic has become acute here again, which I had long thought settled.

Code: [Select]
$ sudo apt -V upgrade
<List of packages to be upgraded>
E: /bin resolved to a different inode than /usr/binE: Unmerged usr is no longer supported, install usrmerge to continue.
N: See https://www.debian.org/releases/bookworm/amd64/release-notes/ch-information.en.html#a-merged-usr-is-now-required for more details

I remember that I had installed the package usrmerge at that time. I do not remember an error message.

When I install usrmerger again, I get this error message.

Code: [Select]
$ sudo apt -V install usrmerge
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dpkg-fsys-usrunmess : Conflicts: usrmerge
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

The bug description of apt doesn't really help me either.
« Last Edit: 2023/09/18, 11:42:51 by orinoco »

Offline Mister00X

  • User
  • Posts: 198
Re: apt & usrmerge
« Reply #1 on: 2023/09/18, 10:38:51 »
what does
Code: [Select]
apt list --installed dpkg-fsys-usrunmess
say?
Arguing that you don't care about the right to privacy because you have nothing to hide is no different than saying you don't care about free speech because you have nothing to say. – Edward Snowden

Offline edlin

  • User
  • Posts: 539
Re: apt & usrmerge
« Reply #2 on: 2023/09/18, 11:26:13 »
dpkg-fsys-usrunmess : Conflicts: usrmerge

Read: https://wiki.debian.org/UsrMerge
Do:
Code: [Select]
# dpkg --remove --force-all dpkg-fsys-usrunmess
edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline orinoco

  • User
  • Posts: 233
  • Bullshit artist
Re: apt & usrmerge
« Reply #3 on: 2023/09/18, 11:27:36 »
@Mister00X

Code: [Select]
$ sudo apt list --installed dpkg-fsys-usrunmess
Listing... Done
dpkg-fsys-usrunmess/now 1.21.3 all [installed,local]

Offline orinoco

  • User
  • Posts: 233
  • Bullshit artist
Re: apt & usrmerge
« Reply #4 on: 2023/09/18, 11:41:53 »
@edlin

Removing package dpkg-fsys-usrunmess followed by

Code: [Select]
$ sudo apt --fix-broken install
helped a lot to solve my problem.