Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] kicat 7.0.8 ohne libraries, Arduino sync Probleme  (Read 834 times)

Offline knorki

  • User
  • Posts: 67
[DE] kicat 7.0.8 ohne libraries, Arduino sync Probleme
« on: 2023/10/18, 08:40:29 »
Nach einer Neuinstalation wird kicad 7.0.8 ohne libraries installiert.
Die Version 7.0.7 hatte noch die libraries.
Ursache von meiner Seite unbekannt.

Arduino macht sync Probleme mit neueren Boards.
Das einzige Board was bei mir noch ohne sync Probleme beim upload läuft, ist das Arduino Uno R3.
Selbst ein Orginal Arduino Nano Every lässt kein update mehr zu, immer sync error.
Die Vorschläge  von Arduino die Fremd libraries zu löschen und nur die Arduino libraries zu aktualisieren nützt nichts.
Ebenso das Abschalten des cache in den Arduino /.arduino15/preferences.txt hilft auch nicht. 
Das scheint aber an Arduino selbst zu liegen. (Glaube ich, aber das mit dem Glauben ist so eine Sache für sich)

 
 

Offline edlin

  • User
  • Posts: 461
Re: kicat 7.0.8 ohne libraries, Arduino sync Probleme
« Reply #1 on: 2023/10/18, 10:22:52 »
KiCad:
Zur Version 7.0.8 gibt es auch die libraries; Vorschlag: kicad-libraries installieren.
Code: [Select]
edlin@Devil:/$ apt search kicad-libraries
Sortierung… Fertig
Volltextsuche… Fertig
kicad-libraries/testing,unstable,testing,testing,testing,testing,now 7.0.8+dfsg-1 all  [Installiert,automatisch]
  Virtual package providing common used libraries by kicad
Code: [Select]
edlin@Devil:/$ apt depends kicad-libraries
kicad-libraries
  Hängt ab von: kicad-footprints (>= 7.0.0~)
  Hängt ab von: kicad-symbols (>= 7.0.0~)
  Hängt ab von: kicad-templates (>= 7.0.0~)
  Schlägt vor: kicad-packages3d (>= 7.0.1~)
Nach der Installation:
Code: [Select]
edlin@Devil:/$ apt policy kicad-libraries
kicad-libraries:
  Installiert:           7.0.8+dfsg-1
  Installationskandidat: 7.0.8+dfsg-1
  Versionstabelle:
 *** 7.0.8+dfsg-1 500
        500 https://deb.debian.org/debian testing/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        500 http://debian.intergenia.de/debian trixie/main amd64 Packages
        500 https://mirror.ipb.de/debian trixie/main amd64 Packages
        500 https://de.mirrors.clouvider.net/debian trixie/main amd64 Packages
        500 http://ftp.hosteurope.de/mirror/ftp.debian.org/debian trixie/main amd64 Packages
        100 /var/lib/dpkg/status
KiCad installiert die libraries nicht automatisch, da sie in den Abhängigkeiten  nur als Empfehlung aufgeführt sind.

edlin

kicat? Schwappt der ganze Katzen-Content jetzt auch hier rüber?  ::)
« Last Edit: 2023/10/18, 10:44:27 by edlin »
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline edlin

  • User
  • Posts: 461
Re: Arduino sync Probleme
« Reply #2 on: 2023/10/18, 11:20:27 »
Arduino:
Bitte zukünftig die Themen trennen.
Hier gibt es sicher eine Menge Fehlerquellen.
- Alles auf den neuesten Stand bringen, einschließlich der Boards.
- Port überprüfen.
- Anderes USB-Kabel benutzen, auch wenn es bisher immer funktioniert hat.
- Anderen USB-Port testen (mögl. an anderem Controller angebunden).
- Teste alternativ das AppImage von https://www.arduino.cc/en/software (Arduino IDE 2.2.1).

Dann bleibt noch der „harte“ Weg über AVRDUDE (https://www.mikrocontroller.net/articles/AVRDUDE) oder einer anderen AVR-Programmiersoftware das compilierte Programm auf den Arduino zu schaufeln.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline knorki

  • User
  • Posts: 67
Re: kicat 7.0.8 ohne libraries, Arduino sync Probleme
« Reply #3 on: 2023/10/19, 08:29:19 »
OK, zukünftig werde ich Themen trennen.

zu KiCad Problem
Bei mir:

apt search kicad-libraries
Sortierung… Fertig
Volltextsuche… Fertig
kicad-libraries/unstable,now 7.0.8+dfsg-1 all  [installiert]
  Virtual package providing common used libraries by kicad

apt policy kicad-libraries
kicad-libraries:
  Installiert:           7.0.8+dfsg-1
  Installationskandidat: 7.0.8+dfsg-1
  Versionstabelle:
 *** 7.0.8+dfsg-1 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Ich vermute das meine installationsquellen nicht vollständig sind

debian.list
deb      https://deb.debian.org/debian/ unstable main contrib non-free-firmware

extra.list
deb      https://ftp.gwdg.de/pub/linux/siduction/extra unstable main

fixes.list
deb      https://ftp.gwdg.de/pub/linux/siduction/fixes unstable main

Fehlt da was?


Zum Arduino:
update heute morgen:
neuer      arduino builder 1.3.25-4+b6

noch nicht getestet

Offline edlin

  • User
  • Posts: 461
Re: kicat 7.0.8 ohne libraries, Arduino sync Probleme
« Reply #4 on: 2023/10/19, 09:47:40 »
Jetzt verstehe ich allerdings dein Problem nicht mehr. Die kicad-libraries sind doch in der neuesten Version bei dir installiert.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline knorki

  • User
  • Posts: 67
Re: kicat 7.0.8 ohne libraries, Arduino sync Probleme
« Reply #5 on: 2023/10/19, 15:17:54 »
Genau das ist das Problem was ich auch sehe, nur die Ursache ist mir nicht klar.

Ich verwende XFCE.

Im Verzeichnis ~/.config/kicad/7.0 ist kein Verzeichnis symbols
Im Verzeichnis ~/.local/share/kicad/7.0 ist ein Verzeichnis symbols aber leer
In den KiCad Einstellungen Symbolbibliotheken "Globale Bibliotheken" sind keine  Bibliotheken sichbar
In den "Einstellungen Pfade konfigurieren"  steht KICAD7_FOOTPRINT_DIR /usr/share/kicad/footprints/   
Im Verzeichins /usr/share/kicad/7.0/symbols/ sind die ..._sym Dateien, aber KiCad greift da nicht drauf zu.

Nun mal die Frage nach den Installationsquellen, sehen die bei Dir auch so aus oder gibt es da Unterschiede?

Verwendest Du KiCad als Schaltplan Programm? Wenn nein, was verwendest Du? Ich will einfach nur die Schaltpläne zeichnen, jedoch keine Leiterplatten erstellen.



Offline edlin

  • User
  • Posts: 461
Re: kicat 7.0.8 ohne libraries
« Reply #6 on: 2023/10/19, 18:13:59 »
Das Problem ist wohl, dass du kein Problem hast. Hat auch nix mit Xfce zu tun, warum auch.
Ein Blick in die Debian-Pakete offenbart, dass zum Beispiel die Symbole bei der Installation in /usr/share/kicad/symbols/ abgelegt werden.
Schau dir mal in KiCad unter Einstellungen -> Pfade konfigurieren zum Beispiel den Pfad für die Symbole an; der sollte auf /usr/share/kicad/symbols/ verweisen. Dann werden diese in KiCad auch ordentlich unter Einstellungen -> Symbolbibliotheken verwalten ... angezeigt. Dto. für Footprints. Also so, wie du es geschrieben hast.
Habs gerade probiert: Ich kann im Schaltplaneditor problemlos auf die Symbole zugreifen.

Die Einträge in den Sourcen sind auf den ersten Blick Ok.

Ich selbst verwende immer noch Eagle, das hat aber einen einfachen Grund: Ich besitze noch eine Professional-Lizenz aus der Zeit, wo es noch keinen Online- bzw. Abo-Zwang gab. Heute würde ich Niemandem mehr Eagle empfehlen. Da ist KiCad meine Emfehlung (im professionellen Bereich gibts Altium und Co.). Da mir meine 6.5er Lizenz genügt, ich den Workflow bei Eagle kenne, meine Bibliotheken hab etc., habe ich keinen Druck für einen Umstieg. Und ein Import in KiCad ist ja jederzeit möglich.
Kurz: Nimm KiCad. Da hast du auch eine Community dahinter, die bei Problemen helfen kann.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline knorki

  • User
  • Posts: 67
Arduino sync Probleme
« Reply #7 on: 2023/10/21, 09:16:43 »
Die Arduino IDE 1.8.19 funktioniert nur noch für die Orginal Arduino Controler.
Controller Nachbauten mit dem seriellen Schnittstellen controlern CH340 funktioniren nicht mehr.

Die Installation der Arduino IDE 2.2.1 (zip-Paket) funktioniert.
Nachteil: man muss immer online sein, ohne Internet ist keine Nutzung möglich.
Ich habe daher die Arduino IDE 2.2.1 auf einem extra Rechner installiert, auf dem keine privaten Daten liegen.

Offline edlin

  • User
  • Posts: 461
Re: kicat 7.0.8 ohne libraries, Arduino sync Probleme
« Reply #8 on: 2023/10/21, 18:42:50 »
Also ich hab gerade mal ein wenig mit der Arduino IDE rumgespielt. Hab auch einen Arduino Nano mit dem CH340 in meinem Lager gefunden.
1. Arduino IDE 1.8.19 funktioniert tadellos mit Board Arduino Nano und Prozessor ATmega328P (Old Bootloader). Kann Sketch problemlos hochladen und starten.

2. Arduino IDE 2.2.1 als AppImage. Nachdem ich Bibliotheken inkl. Boards aktualisiert hatte, habe ich die Onlineverbindung gekappt. Sketch geladen, compiliert und auf den Nano geladen, ganz ohne „Onlinezwang“. Auch kein Problem.

Ich gehe mal davon aus, dass du auch in der Vergangenheit die Aktualisierungen Online vorgenommen hast; per Post gehts wohl noch nicht ... Ich denke, hier ist Paranoia unbegründet.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates