Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] (solved) plasma-nm etc will be removed  (Read 1971 times)

Offline pit

  • User
  • Posts: 238
[EN] (solved) plasma-nm etc will be removed
« on: 2024/01/23, 07:17:19 »
Code: [Select]
===================================================================
 Entfernen                                                         
===================================================================
  Paket:                            Version:               Größe: 
  libopenconnect5                   9.12-1                 558 KB 
  libtss2-mu0                       4.0.1-3                371 KB 
  network-manager-openconnect       1.2.10-2               3.2 MB 
  openconnect                       9.12-1                 3.6 MB 
  plasma-nm                         4:5.27.10-1           10.3 MB 
                                                                   
===================================================================
« Last Edit: 2024/01/24, 08:28:53 by pit »

Offline seasons

  • User
  • Posts: 269
Re: plasma-nm etc will be removed
« Reply #1 on: 2024/01/23, 12:35:43 »
It looks like we need to wait for updated version of openconnect and maybe some other packages if installed: https://release.debian.org/transitions/html/auto-tpm2-tss.html

Offline Teriarch

  • User
  • Posts: 49
Re: plasma-nm etc will be removed
« Reply #2 on: 2024/01/23, 13:16:33 »
The front-ends depend on libopenconnect5, which in turn depends on libtss2-mu0.
The latter one got replaced by libtss2-mu-4.0.1-0 during the last upgrade and therefore
breaks libopenconnect5's dependency:

libtss2-mu-4.0.1-0:
Replaces: libtss2-esys0 (<< 3.0.1-2), libtss2-mu0 (<< 4.0.1-4)
Breaks: libtss2-esys0 (<< 3.0.1-2), libtss2-mu0 (<< 4.0.1-4)

As a provisional solution one can replace the offending dependency of libopenconnect5
by the new libtss2-mu-4.0.1-0 dependency and rebuild the package. But this method
is not for the faint of heart.

Offline eriefisher

  • User
  • Posts: 268
Re: plasma-nm etc will be removed
« Reply #3 on: 2024/01/23, 14:18:36 »
For me and my Xfce4 setup three packages to remove but a long list of autoremovable packages. Mostly gnome stuff that I can let go as it was installed after the fact but I think I'll wait and remove it myself with some control.

Offline ro_sid

  • User
  • Posts: 227
Re: plasma-nm etc will be removed
« Reply #4 on: 2024/01/23, 14:23:15 »
I would suggest the usual "apt(-get) upgrade" until this phase is over an then return to 'dist-upgrade', again. For me, this works fine :).

Offline Fellfrosch

  • User
  • Posts: 43
Re: plasma-nm etc will be removed
« Reply #5 on: 2024/01/23, 16:09:23 »
I for myself have decided, I will stop updating as long as it is needed. I don't think such phases usually last very long. Or am I wrong?

Offline pit

  • User
  • Posts: 238
Re: plasma-nm etc will be removed
« Reply #6 on: 2024/01/23, 16:52:19 »
And I have decided that I will never again carry out upgrades before my first coffee. 😵

Offline Fellfrosch

  • User
  • Posts: 43
Re: plasma-nm etc will be removed
« Reply #7 on: 2024/01/23, 16:59:59 »
That's a decision i would never make. I don't drink coffee, so my system would be very outdated quite soon.  8)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
Re: plasma-nm etc will be removed
« Reply #8 on: 2024/01/23, 19:14:28 »
I would suggest the usual "apt(-get) upgrade" until this phase is over an then return to 'dist-upgrade', again. For me, this works fine :).

+1
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline ro_sid

  • User
  • Posts: 227
Re: plasma-nm etc will be removed
« Reply #9 on: 2024/01/23, 23:24:32 »
It is over now. Just "libtss2-mu0" still gets removed, but is replaced by a newer version with explicit versioning.

Offline pit

  • User
  • Posts: 238
Re: (solved) plasma-nm etc will be removed
« Reply #10 on: 2024/01/24, 08:30:24 »
I can confirm that (solved):

Code: [Select]
sudo nala install libopenconnect5 network-manager-openconnect openconnect plasma-nm
========================================================
 Installieren                                           
========================================================
  Paket:                       Version:         Größe: 
  libopenconnect5              9.12-1+b1        220 KB 
  libpskc0                     2.6.11-1          41 KB 
  libstoken1                   0.92-1            28 KB 
  libtomcrypt1                 1.18.2+dfsg-7    404 KB 
  libtommath1                  1.2.1-2           63 KB 
  libtss2-tcti-libtpms0        4.0.1-6           37 KB 
  libtss2-tcti-spi-helper0     4.0.1-6           37 KB 
  libtss2-tctildr0             4.0.1-6           37 KB 
  libxmlsec1-openssl           1.2.38-1          87 KB 
  network-manager-openconnect  1.2.10-3         508 KB 
  openconnect                  9.12-1+b1        650 KB 
  plasma-nm                    4:5.27.10-1      1.3 MB 
  python3-asn1crypto           1.5.1-3           86 KB 
  python3-mechanize            1:0.4.9+ds-2     103 KB 
  python3-netifaces            0.11.0-2+b2       19 KB