Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] mcomix broken by python3-pil 10.0.0  (Read 3516 times)

Offline dpanter

  • User
  • Posts: 61
[EN] mcomix broken by python3-pil 10.0.0
« on: 2023/07/31, 14:18:44 »
Code: [Select]
14:15:52 [MainThread] ERROR: You don't have the required version of the Python Imaging Library Fork (Pillow) installed.
14:15:52 [MainThread] ERROR: Installed Pillow version is: 10.0.0
14:15:52 [MainThread] ERROR: Required Pillow version is: 6.0.0 or higher

Cause of the breakage is python3-pil (pillow 10.0.0-1) uploaded to Debian Wed, 05 Jul 2023

Reported to SourceForge July 3rd, already fixed: https://sourceforge.net/p/mcomix/bugs/138/
Reported to Debian July 10th, no reponse yet: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1040801

You can downgrade to 9.5.0-1 from testing if you're ok with the side effects.
<< insert signature here >>

Offline dpanter

  • User
  • Posts: 61
Re: mcomix broken by python3-pil 10.0.0
« Reply #1 on: 2023/08/28, 16:30:20 »
Updating to mention the bug isn't fixed in Debian yet, however there's a quick fix noted in the Debian bug report if you don't want to downgrade any packages and you're ok with a tiny manual edit in a Python script. Confirmed working on my machine.
<< insert signature here >>

Offline dpanter

  • User
  • Posts: 61
Re: mcomix broken by python3-pil 10.0.0
« Reply #2 on: 2024/02/06, 18:49:18 »
This was fixed with 3.0.0-1 in October 2023, forgot to update thread.
<< insert signature here >>