Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Broadcom wireless  (Read 4317 times)

eggdog

  • Guest
[EN] Broadcom wireless
« on: 2012/07/21, 16:54:47 »
I have installed siduction on a couple of different computers. I'm writing this from Desperado Reloaded, KDE version.

I'm unable to get wireless working on my laptop. Here is what inxi told me this morning:

Code: [Select]
System:    Host: siductionbox Kernel: 3.4-5.towo-siduction-686 i686 (32 bit, gcc: 4.7.1)
Desktop: KDE 4.8.4 (Qt 4.8.2) Distro: siduction 12.1.1 Desperado Reloaded - kde - (201206241910)
Machine: System: Hewlett-Packard product: Presario C500 (GF572UA#ABA) version: F.24 serial: CND72822L4
Mobo: Hewlett-Packard model: 30C6 version: 78.10 serial: CND72822L4
Bios: Hewlett-Packard version: F.24 date: 04/25/2007
CPU: Dual core Intel CPU T2080 (-MCP-) cache: 1024 KB flags: (nx sse sse2 sse3) bmips: 6916.16
Clock Speeds: 1: 1733.00 MHz 2: 800.00 MHz
Graphics:  Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller bus-ID: 00:02.0
X.org: 1.12.3 drivers: intel (unloaded: fbdev,vesa) tty size: 143x37 Advanced Data: N/A for root
Network:   Card-1: Broadcom BCM4311 802.11b/g WLAN driver: b43-pci-bridge bus-ID: 06:00.0
           IF: wlan0 state: down mac: 00:1a:73:79:5b:a8
           Card-2: Realtek RTL-8139/8139C/8139C+ driver: 8139too ver: 0.9.28 port: 2000 bus-ID: 08:08.0
           IF: eth0 state: unknown speed: 100 Mbps duplex: full mac: 00:1b:38:34:53:f0
Drives:    HDD Total Size: 80.0GB (47.6% used) 1: model: Hitachi_HTS54168
Info: Processes: 161 Uptime: 31 min Memory: 369.3/1000.6MB Runlevel: 5 Gcc sys: 4.7.1 Client: Shell inxi: 1.8.13


From the repository, I installed the firmware installer and the b43-fwcutter. I got an error message. The installer attempted to reach a Web site that was unavailable. (I'm sorry, I forget the name of the Web site.)

I then ran the following commands, which have worked for me on other distributions.

Code: [Select]
wget http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
tar xf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
b43-fwcutter -w /lib/firmware wl_apsta_mimo.o
modprobe b43


But no success.

I enjoy everything else about this excellent distro, both the KDE and the LXDE versions, and I'd really dig getting the wireless to work. Any suggestions will be appreciated.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.361
    • Land of the Buckeye
RE: Broadcom wireless
« Reply #1 on: 2012/07/22, 00:52:45 »
Maybe this helps.
« Last Edit: 2013/11/10, 11:20:26 by melmarker »
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

eggdog

  • Guest
RE: Broadcom wireless
« Reply #2 on: 2012/07/28, 15:36:26 »
Thanks for the suggestion. I apologize for not replying before now; it couldn't be helped.

Sadly, nothing has worked. I retraced my steps as well as I could, and I found that whatever I tried to install did install. I'm out of ideas, and I welcome more.

Offline michaa7

  • User
  • Posts: 2.302
RE: Broadcom wireless
« Reply #3 on: 2012/07/28, 16:33:13 »
Without any description of what *exactly* you did and without any knowledge of the corrisponding error messages or infos what happend noone can and will help
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline der_bud

  • User
  • Posts: 1.072
  • member
RE: Broadcom wireless
« Reply #4 on: 2012/07/29, 18:10:51 »
As from your inxi output card-1 state seems down and card-2 state unknown, first try (as root)
Code: [Select]
ifdown eth0
ifup wlan0
(what I expect not to work, though, if the firmware is really not installed).

What is the output of
Code: [Select]
fw-detect
Have you activated contrib non-free in your /etc/apt/sources.list.d/debian.list ?
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.