Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Quickaccess Widget kompilieren hakt  (Read 3941 times)

Offline spacepenguin

  • User
  • Posts: 862
    • spacepenguin.de
[DE] Quickaccess Widget kompilieren hakt
« on: 2011/05/07, 13:36:19 »
Ich benutze seit "Jahr und Tag" das Quickaccess Widget*), um mir eigene Menüs ins Panel zu legen. Das letzte Mal habe ich das Widget unter KDE 4.5 kompiliert, nachdem ich es an die KDE 4.5 Gegebeneheiten angepaßt hatte. Es läuft auch anstandslos in der kompilierten Version unter KDE 4.6.2.

Nun wollte ich aber etwas aus dem Code des Widgets entfernen, was unter KDE 4.6.2 beim Kompilieren Probleme macht (nicht jeder hat ja noch ein KDE 4.5, auf dem er das kompilieren kann). Und ich bekomme es auf einmal nicht mehr kompiliert, weil mir offenbar irgendetwas fehlt.

Mag sein, daß ich bei einem d-u irgendein dev-Paket habe entfernen lassen, weil ich dachte, das brauchst du eh so schnell nicht wieder. Dummerweise hakts da bei mir mit der Erinnerung.

Langer Rede kurzer Sinn: Hilfe, kann mir jemand sagen, welches Paket ich nachinstallieren muß, damit diese make install/checkinstall-Fehlermeldung entfällt?

Code: [Select]

Installing with make install...

====================== Installations-Ergebnisse ==========================
[  0%] Built target plasma_applet_quickaccess_automoc
make[2]: *** Keine Regel vorhanden, um das Target »../itemview.h«,
  benötigt von »CMakeFiles/plasma_applet_quickaccess.dir/plasma_applet_quickaccess_automoc.o«, zu erstellen.  Schluss.
make[1]: *** [CMakeFiles/plasma_applet_quickaccess.dir/all] Fehler 2
make: *** [all] Fehler 2

**** Installation fehlgeschlagen. Breche Paket-Erzeugung ab.


Die itemview.h sieht so aus:
http://pastebin.com/UL9t0Mnt

*) http://kde-look.org/content/show.php/QuickAccess+for+KDE+SC+4.5?content=134442
Susan | Hardware: SysProfile
Music-Profile: http://www.last.fm/de/user/spacepengu