Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: No sound (solved)  (Read 1990 times)

Offline turborat

  • User
  • Posts: 31
No sound (solved)
« on: 2019/12/12, 00:13:26 »
   5.3.14-towo.1-siduction-amd64 KDE

 
No sound.
No audio at all. Can’t be anything wrong with hardware; audio on Windows 7 partition (on same computer) works normally.
Can someone please help me with this?
« Last Edit: 2019/12/12, 22:38:30 by turborat »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.171
    • Land of the Buckeye
Re: No sound
« Reply #1 on: 2019/12/12, 12:32:47 »
Step 1:

Code: [Select]
inxi -A
and post the output.

Self-help available here.
« Last Edit: 2019/12/12, 12:42:53 by dibl »
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline turborat

  • User
  • Posts: 31
Re: No sound
« Reply #2 on: 2019/12/12, 13:46:04 »
Thanks dibl.
   $ inxi -A
 
Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel
Device-2: NVIDIA GK104 HDMI Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.3.14-towo.1-siduction-amd64

 
I forgot to mention, I had replaced the monitor (DVI) to a HDMI monitor.
I have tried to disable HDMI audio in settings but have not been successful.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.171
    • Land of the Buckeye
Re: No sound
« Reply #3 on: 2019/12/12, 16:25:26 »
OK good we know the hardware and driver.

Here's another way to show the available playback devices:

Code: [Select]
aplay -l
What is your desktop environment and audio packages?  Pulseaudio, alsamixer, alsamixer-gui, etc.? If pulseaudio, look for a muted "line out" built-in analog device.  Or use alsamixer/alsamixer-gui to check for an accidentally muted device.

System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline turborat

  • User
  • Posts: 31
Re: No sound
« Reply #4 on: 2019/12/12, 19:06:31 »
   $ aplay -l
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


 
What is your desktop environment and audio packages?”
desktop environment: KDE
audio packages: default, I guess

 
I putzed around in the alsamixer gui for a while, but unable to get anything to work.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.171
    • Land of the Buckeye
Re: No sound
« Reply #5 on: 2019/12/12, 21:06:12 »
On your KDE/Plasma desktop, click the Application Launcher in the lower left corner, click System Settings, and then scroll down the list to Multimedia.  On the Multimedia window, first click the second item, Audio Volume, then on the Devices tab, make sure the Outputs item is Audio Analog Stereo, and that it is not muted, and the port is Speakers.

Then, still under Multimedia, click the third item, Audio and Video.  On the Device Preference tab, click Music, and look in the right-hand window.  There you should see at least two items, Dummy Output and Built-In Audio Analog Stereo.  You want to highlight Built-In Audio Analog Stereo, and if it is not at the top of the list, move it up by clicking the Prefer arrow button at the lower right. When it is highlighted, click the "Test" button on the lower right, and it should play the chimes. If you changed anything to make it work, click the green "Apply" button.  The same Built-In Audio Analog Stereo device should be shown under Audio Recording in each item.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline turborat

  • User
  • Posts: 31
Re: No sound
« Reply #6 on: 2019/12/12, 22:37:58 »
thanks dibi.
this worked

Offline Colonel Panic

  • User
  • Posts: 12
Re: No sound (solved)
« Reply #7 on: 2021/09/30, 16:26:49 »
Thanks from me too, I've just had the same problem and this solved it.

Offline Colonel Panic

  • User
  • Posts: 12
Re: No sound (solved)
« Reply #8 on: 2021/10/06, 18:27:30 »
Spoke too soon - it's broken again. I'm in a Slack-based distro (Slackel) at the moment but may come back later and have another look at it.