Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Upgrade Warning -- kernel 5.13.3-1 may break networking  (Read 4141 times)

Offline unklarer

  • User
  • Posts: 618
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #90 on: 2021/07/21, 15:44:58 »
@towo

Code: [Select]
ls -ld /boot/initrd.img*
-rw-r--r-- 1 root root 31424936  8. Jul 09:12 /boot/initrd.img-5.12.15-1-siduction-amd64
-rw-r--r-- 1 root root 31429269 16. Jul 10:10 /boot/initrd.img-5.12.17-1-siduction-amd64
-rw-r--r-- 1 root root 31721377 20. Jul 08:57 /boot/initrd.img-5.13.3-2-siduction-amd64
-rw-r--r-- 1 root root 31721223 20. Jul 14:20 /boot/initrd.img-5.13.3-3-siduction-amd64
-rw-r--r-- 1 root root 31721640 21. Jul 12:08 /boot/initrd.img-5.13.4-1-siduction-amd64

Code: [Select]
cat /etc/initramfs-tools/modules
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod

Code: [Select]
cat /etc/initramfs-tools/initramfs.conf
#
# initramfs.conf
# Configuration file for mkinitramfs(8). See initramfs.conf(5).
#
# Note that configuration options from this file can be overridden
# by config files in the /etc/initramfs-tools/conf.d directory.

#
# MODULES: [ most | netboot | dep | list ]
#
# most - Add most filesystem and all harddrive drivers.
#
# dep - Try and guess which modules to load.
#
# netboot - Add the base modules, network modules, but skip block devices.
#
# list - Only include modules from the 'additional modules' list
#

MODULES=most

#
# BUSYBOX: [ y | n | auto ]
#
# Use busybox shell and utilities.  If set to n, klibc utilities will be used.
# If set to auto (or unset), busybox will be used if installed and klibc will
# be used otherwise.
#

BUSYBOX=auto

#
# KEYMAP: [ y | n ]
#
# Load a keymap during the initramfs stage.
#

KEYMAP=n

#
# COMPRESS: [ gzip | bzip2 | lz4 | lzma | lzop | xz | zstd ]
#

COMPRESS=gzip

#
# DEVICE: ...
#
# Specify a specific network interface, like eth0
# Overridden by optional ip= or BOOTIF= bootarg
#

DEVICE=

#
# NFSROOT: [ auto | HOST:MOUNT ]
#

NFSROOT=auto

#
# RUNSIZE: ...
#
# The size of the /run tmpfs mount point, like 256M or 10%
# Overridden by optional initramfs.runsize= bootarg
#

RUNSIZE=10%

#
# FSTYPE: ...
#
# The filesystem type(s) to support, or "auto" to use the current root
# filesystem type
#

FSTYPE=auto

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.537
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #91 on: 2021/07/21, 15:55:56 »
As i written earlyer, it's even not a problem with generating initrd.
At the moment i'm out of ideas, why old systems have those problems with kernel 5.13.

I have no system anymore, which was installed with an old iso und upgraded permanently.
All my systems are working fine after switch from 5.12 to 5.13.

Also i do not own hardware with an Renesas USB3 chipset, so i can't see, what's going wrong here.
But it seems, the Renesas problem is an upstream regression, since kernel 5.12.17 hast the same problems.

Maybe it could help, if anyone can test with the recent aptosid kernel

http://aptosid.com/debian/pool/main/l/linux-aptosid/linux-image-5.13.0-3.slh.1-aptosid-amd64_5.13-7_amd64.deb
http://aptosid.com/debian/pool/main/l/linux-aptosid/linux-headers-5.13.0-3.slh.1-aptosid-amd64_5.13-7_amd64.deb

Maybe i can find the diff, which is the cause of the problem.
« Last Edit: 2021/07/21, 16:00:34 by towo »
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Carnophage

  • User
  • Posts: 36
    • http://carnophage.wordpress.com
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #92 on: 2021/07/21, 16:16:30 »
Code: [Select]
Linux hal9001 5.13.0-3.slh.1-aptosid-amd64 #1 SMP PREEMPT aptosid 5.13-7 (2021-07-20) x86_64 GNU/LinuxSeems to work just fine  ???

Offline unklarer

  • User
  • Posts: 618
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #93 on: 2021/07/21, 16:32:59 »
^Here too.

Code: [Select]
inxi -Sxxx
System:    Host: sidukde Kernel: 5.13.0-3.slh.1-aptosid-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: LightDM 1.26.0
           Distro: siduction 16.1.0 Patience - kde - (201702251051) base: Debian GNU/Linux 11 (bullseye)

Offline michaa7

  • User
  • Posts: 2.150
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #94 on: 2021/07/21, 16:34:48 »
aptosidkernel fully working. All three soundcards available, USB-TV-Card working.

Quote
~$ dmesg | egrep -i "failed"
~$

Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline cs

  • User
  • Posts: 86
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #95 on: 2021/07/21, 16:42:09 »
No luck and no sound with external sound card for me with the aptosid kernel:

Quote
uname -a
Linux x13-cord 5.13.0-3.slh.1-aptosid-amd64 #1 SMP PREEMPT aptosid 5.13-7 (2021-07-20) x86_64 GNU/Linux

Quote
dmesg | egrep -i "failed"
[    1.335881] xhci_hcd 0000:05:00.0: Direct firmware load for renesas_usb_fw.mem failed with error -2
[   62.505248] xhci_hcd 0000:05:00.0: request_firmware failed: -11
[   62.505530] xhci_hcd: probe of 0000:05:00.0 failed with error -11
[   83.638308] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-cc-a0-63.ucode failed with error -2
[   83.924289] acp_pdm_mach acp_pdm_mach.0: snd_soc_register_card(acp) failed: -517
[   84.040599] thermal thermal_zone0: failed to read out thermal zone (-61)

Quote
dmesg | egrep -i "error"
[    1.222539] RAS: Correctable Errors collector initialized.
[    1.335881] xhci_hcd 0000:05:00.0: Direct firmware load for renesas_usb_fw.mem failed with error -2
[   62.505530] xhci_hcd: probe of 0000:05:00.0 failed with error -11
[   83.448051] EXT4-fs (nvme0n1p2): re-mounted. Opts: errors=remount-ro. Quota mode: none.
[   83.638308] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-cc-a0-63.ucode failed with error -2
[   86.770000] pipewire-media-[2451]: segfault at 1cc ip 00007f975758fcba sp 00007ffd03feca20 error 4 in libasound.so.2.0.0[7f975756a000+8d000]
[   86.948482] #PF: error_code(0x0010) - not-present page
[   86.997810] pulseaudio[2383]: segfault at 50 ip 0000000000000050 sp 00007ffde36ffe68 error 14 in pulseaudio[5643f8639000+5000]
[   87.012113] #PF: error_code(0x0010) - not-present page
[   87.405392] pulseaudio[5254]: segfault at 50 ip 0000000000000050 sp 00007fff565e96b8 error 14 in pulseaudio[56251f5a3000+5000]
[   87.634304] pulseaudio[6253]: segfault at 50 ip 0000000000000050 sp 00007ffedd685c88 error 14 in pulseaudio[558193f04000+5000]
[   87.879583] pulseaudio[7307]: segfault at 50 ip 0000000000000050 sp 00007ffc604c8268 error 14 in pulseaudio[55a472529000+5000]
[   88.136293] pulseaudio[7504]: segfault at 1cc ip 00007ff8c41b9cba sp 00007ffe5760b160 error 4 in libasound.so.2.0.0[7ff8c4194000+8d000]
[   96.718460] pipewire-media-[8089]: segfault at 50 ip 0000000000000050 sp 00007ffc9acedee8 error 14 in pipewire-media-session[5561757b6000+1a000]

Regards

cs

Offline michaa7

  • User
  • Posts: 2.150
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #96 on: 2021/07/21, 16:52:32 »

@ cs


Maybe this is a different problem. This error is currently discussed on lkml:

https://lkml.org/lkml/2021/7/19/83
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline cs

  • User
  • Posts: 86
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #97 on: 2021/07/21, 17:03:23 »
@michaa7 and towo

Quote
Maybe this is a different problem. This error is currently discussed on lkml:

https://lkml.org/lkml/2021/7/19/83

Yes, that sounds familiar to me, thanks for the hint!

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.150
    • Land of the Buckeye
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #98 on: 2021/07/21, 19:13:39 »
Yes.

Code: [Select]
don@Hibiscus:~$ inxi -Sn
System:    Host: Hibiscus Kernel: 5.13.0-3.slh.1-aptosid-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.20.5
           Distro: siduction 13.2.1 December - kde - (201401272125)
Network:   Device-1: Intel I210 Gigabit Network driver: igb
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: xxxxxxx
           Device-2: Intel I210 Gigabit Network driver: igb
           IF: enp9s0 state: down mac: e0:3f:49:e6:85:c4
           IF-ID-1: br0 state: up speed: 1000 Mbps duplex: unknown mac: xxxxxxx

Networking works as expected, USB thumb drive mounts as expected.

THANKS @towo!
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.537
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #99 on: 2021/07/21, 22:09:50 »
@all with problems

You all ave old siduction basis, have you done the usrmerge?
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Carnophage

  • User
  • Posts: 36
    • http://carnophage.wordpress.com
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #100 on: 2021/07/21, 22:19:24 »
That would be a no from my side. I somehow missed the existence of https://wiki.debian.org/UsrMerge

Offline jure

  • User
  • Posts: 615
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #101 on: 2021/07/21, 22:23:08 »
no

Code: [Select]
apt policy usrmerge
usrmerge:
  Installiert:           (keine)
  Installationskandidat: 25
  Versionstabelle:
     25 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://httpredir.debian.org/debian unstable/main i386 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main i386 Packages

Some info about usrmerge written by devil https://www.linux-community.de/ausgaben/linuxuser/2019/08/zusammengefasst/
Gruss Juergen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.150
    • Land of the Buckeye
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #102 on: 2021/07/21, 22:34:34 »
No, all mine are original siduction installations.  Here's another one that works correctly with the slh kernel.

Code: [Select]
System:    Kernel: 5.13.0-3.slh.1-aptosid-amd64 x86_64 bits: 64 Desktop: LXQt 0.16.1
           Distro: siduction 17.1.0 Patience - lxqt - (201703051830)
Machine:   Type: Portable System: Dell product: Inspiron N5110 v: N/A serial: <filter>
           Mobo: Dell model: 034W60 v: A11 serial: <filter> BIOS: Dell v: A11 date: 08/03/2012
Battery:   ID-1: BAT0 charge: 66.6 Wh condition: 82.2/73.3 Wh (112%)
CPU:       Info: Dual Core model: Intel Core i3-2330M bits: 64 type: MT MCP L2 cache: 3 MiB
           Speed: 1022 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 1022 2: 1089 3: 1538 4: 1265
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel
           Device-2: Microdia Laptop_Integrated_Webcam_HD type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa
           resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 21.1.5
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.13.0-3.slh.1-aptosid-amd64
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
           IF: enp5s0 state: down mac: <filter>
           Device-2: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi
           IF: wlp9s0 state: up mac: <filter>
Bluetooth: Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB driver: btusb
           Report: ID: hci0 state: down address: <filter>
Drives:    Local Storage: total: 74.53 GiB used: 20.86 GiB (28.0%)
           ID-1: /dev/sda vendor: Intel model: SSDSA2CW080G3 size: 74.53 GiB
Partition: ID-1: / size: 16.61 GiB used: 15.62 GiB (94.1%) fs: ext4 dev: /dev/sda1
Swap:      ID-1: swap-1 type: partition size: 1024 MiB used: 0 KiB (0.0%) dev: /dev/sda2
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 246 Uptime: 49m Memory: 3.76 GiB used: 2.47 GiB (65.7%) Shell: Bash inxi: 3.3.01
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline michaa7

  • User
  • Posts: 2.150
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #103 on: 2021/07/21, 22:40:55 »
@all with problems

You all ave old siduction basis, have you done the usrmerge?

If (A) this was mandatory and if (B) this was to be done manually then the answer is NO.

But if A and B are true I would have expected some strong hint in the update section.

If this is the root cause for all the problems with siduction + kernel 5.13, why don't we have problems with the aptosid kernel?


Anyway, should we now insztall usrmerge?

Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.537
Re: Upgrade Warning -- kernel 5.13.3-1 may break networking
« Reply #104 on: 2021/07/21, 23:13:06 »
In the kernel config the path to modprobe is only valid on systems with usrmerge installed.
In the slh kernel modprobe path is set ti /sbin/modprobe, which is valid on all systems.
And yes. usrmerge is recommend, because it's default in debian bullseye, on buster i'm not sure.

The new kernel, which is building at the moment, should work on all systems, usrmerged or not.
« Last Edit: 2021/07/21, 23:16:37 by towo »
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.