seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/05/12, 11:02:50


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Nvidia-legacy-390xx-driver und Kernelupdate  (Read 1975 times)

0 Members and 1 Guest are viewing this topic.

Offline charlyheinz

  • User
  • Posts: 13
Nvidia-legacy-390xx-driver und Kernelupdate
« on: 2021/04/12, 18:42:24 »
Hallo allerseits- ich stehe mit einer Nvidia-legacy-390xx-driver Installation und einem Kernelupdate auf dem Schlauch. Mit einem Kernel 5.10.20-towo.1-0 läuft eine 560er Grafikkarte problemlos. Aktuellere Kernel, bzw.  Nvidia-legacy-390xx-driver lassen sich nicht kombinieren. Ich erhalte folgende Meldungen:
Quote
Building initial module for 5.11.13-1-siduction-amd64Error! Bad return status for module build on kernel: 5.11.13-1-siduction-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-legacy-390xx/390.141/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-kernel-dkms (--configure):
 »installiertes nvidia-legacy-390xx-kernel-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nvidia-legacy-390xx-driver:
 nvidia-legacy-390xx-driver hängt ab von nvidia-legacy-390xx-kernel-dkms (= 390.141-3) | nvidia-legacy-390xx-kernel-390.141; aber:
  Paket nvidia-legacy-390xx-kernel-dkms ist noch nicht konfiguriert.
  Paket nvidia-legacy-390xx-kernel-390.141 ist nicht installiert.
  Paket nvidia-legacy-390xx-kernel-dkms, das nvidia-legacy-390xx-kernel-390.141 bereitstellt, ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes nvidia-legacy-390xx-driver (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 nvidia-legacy-390xx-kernel-dkms
 nvidia-legacy-390xx-driver
Kann mir jemand einen Tip geben was ich hier nicht gebacken kriege.Es handelt sich aktuell um den installierten Nvidia-legacy-390xx-driver 3.90.141-3. Das fehlende Paket nvidia-legacy-390xx-kernel-390.141 wird mir leider in den Repos nicht angeboten, oder verstehe ich hier etwas falsch
Ein DU wird nicht komplett durchgeführt. :(
Danke im voraus...

Offline jure

  • User
  • Posts: 571
Re: Nvidia-legacy-390xx-driver und Kernelupdate
« Reply #1 on: 2021/04/12, 20:57:43 »
ggf ist das hier gemeint

Code: [Select]
apol nvidia-legacy-390xx-kernel-support
nvidia-legacy-390xx-kernel-support:
  Installiert:           (keine)
  Installationskandidat: 390.141-3
  Versionstabelle:
     390.141-3 500
        500 http://ftp.de.debian.org/debian unstable/non-free amd64 Packages
Gruss Juergen

Offline charlyheinz

  • User
  • Posts: 13
Re: Nvidia-legacy-390xx-driver und Kernelupdate
« Reply #2 on: 2021/04/21, 18:53:17 »
Habe gerade ein DU durch geführt. Dabei wurde der nvidia-legacy-390 Treiber auf Version 390.143-1 aktualisiert. Eine update auf den Kernel linux-image-5.11.15-1-siduction-amd64 lief einwandfrei durch. Ein Neustart funktionierte problemlos. :D Zwischenzeitlich habe ich im Netz eine Anleitung zum patchen des Nvidia-legacy-390 Treibers zur Unterstützung von Kernel 5.11 gefunden. Während der Installation des aktuellen Kernels wird dieser patch wohl eingespielt.

Denke das Problem hat sich erledigt.

Danke nochmal an Alle die hier wirken!!