Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  Kernel 4.4 now available for testing / Kernel 4.4 verfügbar zum testen  (Read 16680 times)

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.948
Since today kernel 4.4-rc5 is available for install from our extra/experimental repo.
If you are an advanced user, please test this kernel to find possible problems for faster fixing them.

One known issue, fglrx 15.9 does not build against 4.4.

Seite heute ist Kernel 4.4-rc5 in unserem extra/experimental Repo verfügbar.
Wenn ihr nicht gerade Neulinge seid, bitte testet diesen Kernel, um
mögliche Probleme frühzeitig zu erkennen und zu beheben.

Ein bekanntes Problem, fglrx 15.9 baut nicht gegen 4.4.
« Last Edit: 2015/12/14, 19:59:00 by towo »
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx

arbeiten gut so weit

Thank You

working good so far

Code: [Select]
root /home/piper # apt-get install linux-image-4.4.0-rc5-siduction-amd64 linux-headers-4.4.0-rc5-siduction-amd64
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Suggested packages:
The following NEW packages will be installed:
  linux-headers-4.4.0-rc5-siduction-amd64 linux-image-4.4.0-rc5-siduction-amd64
0 upgraded, 2 newly installed, 0 to remove and 35 not upgraded.
Need to get 37.6 MB of archives.
After this operation, 181 MB of additional disk space will be used.
Get:1 http://packages.siduction.org/extra experimental/main amd64 linux-image-4.4.0-rc5-siduction-amd64 amd64 4.4~rc5-1 [30.9 MB]
Get:2 http://packages.siduction.org/extra experimental/main amd64 linux-headers-4.4.0-rc5-siduction-amd64 amd64 4.4~rc5-1 [6,689 kB]        
Fetched 37.6 MB in 39s (961 kB/s)                                                                                                           
Preconfiguring packages ...
Selecting previously unselected package linux-image-4.4.0-rc5-siduction-amd64.
(Reading database ... 222648 files and directories currently installed.)
Preparing to unpack .../linux-image-4.4.0-rc5-siduction-amd64_4.4~rc5-1_amd64.deb ...
Unpacking linux-image-4.4.0-rc5-siduction-amd64 (4.4~rc5-1) ...
Selecting previously unselected package linux-headers-4.4.0-rc5-siduction-amd64.
Preparing to unpack .../linux-headers-4.4.0-rc5-siduction-amd64_4.4~rc5-1_amd64.deb ...
Unpacking linux-headers-4.4.0-rc5-siduction-amd64 (4.4~rc5-1) ...
Setting up linux-image-4.4.0-rc5-siduction-amd64 (4.4~rc5-1) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-rc5-siduction-amd64
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/thunderstruck/theme.txt
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-4.4.0-rc5-siduction-amd64
Found initrd image: /boot/initrd.img-4.4.0-rc5-siduction-amd64
Found linux image: /boot/vmlinuz-4.3.2-towo.1-siduction-amd64
Found initrd image: /boot/initrd.img-4.3.2-towo.1-siduction-amd64
Setting up linux-headers-4.4.0-rc5-siduction-amd64 (4.4~rc5-1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.4.0-rc5-siduction-amd64
root /home/piper #

Code: [Select]
piper@x1:~$ inxi -F
System:    Host: x1 Kernel: 4.4.0-rc5-siduction-amd64 x86_64 (64 bit) Desktop: KDE Plasma 5.4.3
           Distro: siduction 15.1.0 Thunderstruck - kde - (201510232355)
Machine:   Mobo: Gigabyte model: GA-970A-UD3 v: x.x Bios: Award v: F7 date: 10/22/2012
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB
           clock speeds: max: 3500 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz 5: 3000 MHz 6: 1400 MHz
Graphics:  Card: NVIDIA GM204 [GeForce GTX 970]
           Display Server: X.Org 1.17.3 driver: nvidia Resolution: 1920x1200@59.95hz
           GLX Renderer: GeForce GTX 970/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 352.63
Audio:     Card-1 NVIDIA GM204 High Definition Audio Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-rc5-siduction-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: 90:2b:34:a5:99:2d
Drives:    HDD Total Size: 8001.6GB (24.0% used) ID-1: /dev/sda model: Hitachi_HDS72202 size: 2000.4GB
           ID-2: /dev/sdc model: ST3000DM001 size: 3000.6GB ID-3: /dev/sdb model: ST3000DM001 size: 3000.6GB
Partition: ID-1: / size: 199G used: 64G (34%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda1
Sensors:   System Temperatures: cpu: 22.5C mobo: N/A gpu: 52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 225 Uptime: 14 min Memory: 1362.0/16035.5MB Client: Shell (bash) inxi: 2.2.31
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck


  • Guest

is it sufficient to

  • uncomment the exp repo in the sources list
  • apt-get update then
  • install like piper showed above
  • comment the repo again and
  • reboot then?
Can i do like this and further d-u as usual, awaiting that kernel via unstable?

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.373
    • Land of the Buckeye

Geht gut.

10 minutes playing around and I can't find anything that doesn't work as expected. Here is the system:

Code: [Select]
System:    Host: Hibiscus Kernel: 4.4.0-rc5-siduction-amd64 x86_64 (64 bit gcc: 5.3.1)
           Desktop: KDE Plasma 5.4.3 (Qt 5.5.1) Distro: siduction 14.1.0 Indian Summer - kde - (201411230337)
Machine:   System: ASUS product: All Series
           Mobo: ASUSTeK model: Z87-WS v: Rev 1.xx Bios: American Megatrends v: 2004 date: 06/05/2014
CPU:       Quad core Intel Core i7-4770 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28020
           clock speeds: max: 3900 MHz 1: 3400 MHz 2: 3400 MHz 3: 3400 MHz 4: 3400 MHz 5: 3403 MHz 6: 3400 MHz
           7: 3449 MHz 8: 3403 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti] bus-ID: 05:00.0
           Display Server: X.Org 1.17.3 driver: nvidia Resolution: 1920x1200@59.88hz
           GLX Renderer: GeForce GTX 750 Ti/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 352.55 Direct Rendering: Yes
Network:   Card-1: Intel I210 Gigabit Network Connection driver: igb v: 5.3.0-k port: d000 bus-ID: 07:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: xxxxxxxx
           Card-2: Intel I210 Gigabit Network Connection driver: igb v: 5.3.0-k port: a000 bus-ID: 0a:00.0
           IF: eth1 state: down mac: xxxxxxxx
Drives:    HDD Total Size: 3120.7GB (26.9% used) ID-1: model: OCZ
           ID-2: model: WDC_WD1001FALS ID-3: model: OCZ
           ID-4: model: WDC_WD1000DHTZ ID-5: model: WDC_WD1000DHTZ
Info:      Processes: 305 Uptime: 11 min Memory: 4325.8/7927.6MB Init: systemd runlevel: 5 Gcc sys: 5.3.1
           Client: Shell (bash 4.3.421) inxi: 2.2.31

Thanks, towo!
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline axt

  • User
  • Posts: 494
    • axebase.net
siduction/32-VM, 4.4.0-rc5/686, e17
VBox 5.0.10-104061
EP 5.0.11-104675
GA 5.0.11-104662

All is working fine...and that's saying something! ;-)

Offline sedonix

  • User
  • Posts: 36

Offline seasons

  • User
  • Posts: 270
I am receiving this message that does not occur with the previous 4.3.x kernel

Code: [Select]
modprobe: module microcode not found in modules.dep
I tried running 'depmod -a' and rebooting.

Code: [Select]
$ cat amd64-microcode-blacklist.conf
# The microcode module attempts to apply a microcode update when
# it autoloads.  This is not always safe, so we block it by default.
blacklist microcode

$ dpkg-query -S /etc/modprobe.d/amd64-microcode-blacklist.conf
amd64-microcode: /etc/modprobe.d/amd64-microcode-blacklist.conf

EDIT: Maybe amd64-microcode package does not need to have this configuration file in kernel 4.4?
« Last Edit: 2015/12/18, 22:00:29 by seasons »

Offline seasons

  • User
  • Posts: 270
I have determined that the amd64-microcode-blacklist.conf file will no longer be needed:

I will report a bug against amd64-microcode package. I'm not sure what prompted the maintainer to blacklist the module in the first place, but they will need to find a new workaround.

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.948
No sense in repeating all from 4.3:


Identical problem now with 4.4
Should be solved with the new 4.4-rc6 kernel.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.948
Kernel is now 4.4-rc6.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline sedonix

  • User
  • Posts: 36
Code: [Select]
System:    Host: otsdawa Kernel: 4.4.0-rc6-siduction-amd64 x86_64 (64 bit) Desktop: KDE Plasma 5.4.3
           Distro: siduction 14.1.0 Indian Summer - kde - (201411230337)
Machine:   System: Compaq-Presario product: KQ514AA-ABA SR5550F
           Mobo: ASUSTek model: NARRA3 v: 3.02 Bios: Phoenix v: 5.13 date: 05/02/2008
CPU:       Dual core AMD Athlon 64 X2 5400+ (-MCP-) cache: 1024 KB
           clock speeds: max: 2800 MHz 1: 1000 MHz 2: 1000 MHz
Graphics:  Card: NVIDIA C61 [GeForce 6150SE nForce 430]
           Display Server: X.Org 1.17.3 driver: nvidia Resolution: 1920x1200@59.95hz
           GLX Renderer: GeForce 6150SE nForce 430/integrated/SSE2 GLX Version: 2.1.2 NVIDIA 304.131
Audio:     Card NVIDIA MCP61 High Definition Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-rc6-siduction-amd64
Network:   Card: NVIDIA MCP61 Ethernet driver: forcedeth
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1f:c6:6f:50:a9
Drives:    HDD Total Size: 3000.6GB (88.6% used) ID-1: /dev/sdb model: WDC_WD1001FALS size: 1000.2GB
           ID-2: /dev/sda model: ST3500620AS size: 500.1GB ID-3: USB /dev/sdc model: Ext_HDD_1021 size: 1500.3GB
Partition: ID-1: / size: 24G used: 9.7G (43%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 14.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 182 Uptime: 4 min Memory: 830.6/2887.3MB Client: Shell (bash) inxi: 2.2.31

Thanks towo! All looks good.