Welcome, Guest. Please login or register.
Did you miss your activation email?

Recent Posts

Pages: 1 ... 3 4 [5] 6 7 ... 10
41
Software - Support / Re: Nouveau ----> Nvidia, trouble changing driver
« Last post by ro_sid on 2024/04/04, 23:53:10 »
[...]
Code: [Select]
modprobe: FATAL: Module nvidia-driver_error.txt not found in directory /lib/modules/6.8.3-1-siduction-amd64
I'm way over my head on this, but does this mean something is missing from the driver package?
I do not think so. This is the contents of my directory "/lib/modules/6.8.3-1-siduction-amd64/updates/dkms":
Code: [Select]
-rw-r--r-- 1 root root    24720 Apr  4 00:06 bbswitch.ko
-rw-r--r-- 1 root root   203864 Apr  4 00:07 nvidia-current-drm.ko
-rw-r--r-- 1 root root  1758288 Apr  4 00:07 nvidia-current-modeset.ko
-rw-r--r-- 1 root root     6776 Apr  4 00:07 nvidia-current-peermem.ko
-rw-r--r-- 1 root root  2839576 Apr  4 00:07 nvidia-current-uvm.ko
-rw-r--r-- 1 root root 62502600 Apr  4 00:07 nvidia-current.ko
where bbswitch.ko is from another, although related, package.
42
Software - Support / Re: Errors install siduction kernel
« Last post by sotnik on 2024/04/04, 23:52:24 »
To be honest I am not sure what do you mean but any way I provide the full output below

Quote
apt install linux-image-siduction-amd64   linux-headers-siduction-amd64
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
linux-image-siduction-amd64 is already the newest version (6.8-3).
linux-headers-siduction-amd64 is already the newest version (6.8-3).
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up linux-headers-6.8.3-1-siduction-amd64 (6.8-3) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 6.8.3-1-siduction-amd64.
The kernel is built without module signing facility, modules won't be signed
applying patch cc_version_check-gcc5.patch...patching file conftest.sh

applying patch bashisms.patch...patching file conftest.sh

applying patch 0001-some-power-management-features-were-not-yet-in-Linux.patch...patching file conftest.sh

applying patch 0026-add-missing-includes-to-fix-module-build-for-ppc64el.patch...patching file nvidia/nvlink_common.h

applying patch 0033-refuse-to-load-legacy-module-if-IBT-is-enabled.patch...patching file nvidia-modeset/nvidia-modeset-linux.c
patching file nvidia/nv.c

applying patch 0034-fix-typos.patch...patching file nvidia-uvm/uvm.h
patching file nvidia-uvm/uvm_perf_thrashing.c

applying patch fragile-ARCH.patch...patching file Makefile

applying patch use-kbuild-compiler.patch...patching file Makefile
patching file Kbuild

applying patch use-kbuild-flags.patch...patching file Kbuild
patching file nvidia/nvidia.Kbuild
patching file Makefile
patching file nvidia-modeset/nvidia-modeset.Kbuild

applying patch conftest-verbose.patch...patching file Kbuild

applying patch conftest-prefer-arch-headers.patch...patching file conftest.sh


Building module:
Cleaning build area...
Building module(s).......(bad exit status: 2)
Failed command:
env NV_VERBOSE=1 make -j16 modules KERNEL_UNAME=6.8.3-1-siduction-amd64
Error! Bad return status for module build on kernel: 6.8.3-1-siduction-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-tesla-470/470.239.06/build/make.log for more information.
dkms autoinstall on 6.8.3-1-siduction-amd64/x86_64 failed for nvidia-tesla-470(10)
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.8.3-1-siduction-amd64 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 11
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-6.8.3-1-siduction-amd64.postinst line 11.
dpkg: error processing package linux-headers-6.8.3-1-siduction-amd64 (--configure):
 installed linux-headers-6.8.3-1-siduction-amd64 package post-installation script subprocess returned error exit status 11
Setting up linux-image-6.8.3-1-siduction-amd64 (6.8-3) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.8.3-1-siduction-amd64.
The kernel is built without module signing facility, modules won't be signed
applying patch cc_version_check-gcc5.patch...patching file conftest.sh

applying patch bashisms.patch...patching file conftest.sh

applying patch 0001-some-power-management-features-were-not-yet-in-Linux.patch...patching file conftest.sh

applying patch 0026-add-missing-includes-to-fix-module-build-for-ppc64el.patch...patching file nvidia/nvlink_common.h

applying patch 0033-refuse-to-load-legacy-module-if-IBT-is-enabled.patch...patching file nvidia-modeset/nvidia-modeset-linux.c
patching file nvidia/nv.c

applying patch 0034-fix-typos.patch...patching file nvidia-uvm/uvm.h
patching file nvidia-uvm/uvm_perf_thrashing.c

applying patch fragile-ARCH.patch...patching file Makefile

applying patch use-kbuild-compiler.patch...patching file Makefile
patching file Kbuild

applying patch use-kbuild-flags.patch...patching file Kbuild
patching file nvidia/nvidia.Kbuild
patching file Makefile
patching file nvidia-modeset/nvidia-modeset.Kbuild

applying patch conftest-verbose.patch...patching file Kbuild

applying patch conftest-prefer-arch-headers.patch...patching file conftest.sh


Building module:
Cleaning build area...
Building module(s).......(bad exit status: 2)
Failed command:
env NV_VERBOSE=1 make -j16 modules KERNEL_UNAME=6.8.3-1-siduction-amd64
Error! Bad return status for module build on kernel: 6.8.3-1-siduction-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-tesla-470/470.239.06/build/make.log for more information.
dkms autoinstall on 6.8.3-1-siduction-amd64/x86_64 failed for nvidia-tesla-470(10)
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.8.3-1-siduction-amd64 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 11
dpkg: error processing package linux-image-6.8.3-1-siduction-amd64 (--configure):
 installed linux-image-6.8.3-1-siduction-amd64 package post-installation script subprocess returned error exit status 11
dpkg: dependency problems prevent configuration of linux-headers-siduction-amd64:
 linux-headers-siduction-amd64 depends on linux-headers-6.8.3-1-siduction-amd64 (= 6.8-3); however:
  Package linux-headers-6.8.3-1-siduction-amd64 is not configured yet.

dpkg: error processing package linux-headers-siduction-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-siduction-amd64:
 linux-image-siduction-amd64 depends on linux-image-6.8.3-1-siduction-amd64 (= 6.8-3); however:
  Package linux-image-6.8.3-1-siduction-amd64 is not configured yet.

dpkg: error processing package linux-image-siduction-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-headers-6.8.3-1-siduction-amd64
 linux-image-6.8.3-1-siduction-amd64
 linux-headers-siduction-amd64
 linux-image-siduction-amd64
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please not I have the nvidia driver but actually I use nouveau
43
Software - Support / Re: XCompose file
« Last post by lanig on 2024/04/04, 22:51:41 »
I have received very useful help on the fcitx forum. I post a solution in case it may help somebody.
Code: [Select]
  7 include "%L"                                                                             
  6 <ae> : "ą"                                                                               
  5 <AE> : "Ą"                                                                               
  4 <copyright> : "ć"                                                                       
  3 <registered> : "Ć"                                                                       
  2 <acircumflex> : "ź"                                                                     
  1 <Acircumflex> : "Ź"                                                                     
  0 <U0140> : "ł"                                                                           
  1 <U013F> : "Ł"                                                                           
  2 <notsign> : "ń"                                                                         
  3 <rightarrow> : "Ń"                                                                       
  4 <ocircumflex> : "ó"#P mappé sur P car                                                   
  5 <Ocircumflex> : "Ó" # alt-gr O = œ                                                       
  6 <ssharp> : "ś"                                                                           
  7 <doublelowquotemark> : "Ś"                                                               
  8 <ecircumflex> : "ę" #R mappé sur la touche voisine                                       
  9 <Ecircumflex> : "Ę"# de e car alt-gr e = €                                               
 10 <thorn> : "ż" # T car Z déjà pris                                                       
 11 <THORN> : "Ż"   
44
Upgrade Warnings / Re: Attention! Malicious Software in testing and sid
« Last post by michaa7 on 2024/04/04, 22:39:45 »
Ich war vermutlich der 11. Klicker ...  >:(

Hier kann man es auch 10+ mal anklicken ....
45
Software - Support / Re: Errors install siduction kernel
« Last post by towo on 2024/04/04, 21:54:34 »
Your output is not the real error! You have a secret dkms-package installesd, which is not compatible with that kernel version.

Quote
run-parts: /etc/kernel/postinst.d/dkms exited with return code 11

So post the releavant error, then we maybe could help.
46
Software - Support / Re: Nouveau ----> Nvidia, trouble changing driver
« Last post by dibl on 2024/04/04, 21:52:55 »
Thanks, @ro_sid, for your efforts.  Today, we can be slightly less clueless.

I carefully stepped through the kubuki dance of edits to the grub command options and the /etc/modprobe.d/blacklist.nouveau, and rebuilt the nvidia modules and modprobed, and saw the same result.  Frustrated, I issued
Code: [Select]
modprobe nvidia*.  I was surprised to see this error output, which did not come out of
Code: [Select]
modprobe nvidia-current:

Code: [Select]
modprobe: FATAL: Module nvidia-driver_error.txt not found in directory /lib/modules/6.8.3-1-siduction-amd64
I'm way over my head on this, but does this mean something is missing from the driver package?
47
Software - Support / Errors install siduction kernel
« Last post by sotnik on 2024/04/04, 21:46:48 »
I tried to install siduction kernel (I used debian kernel for a while)
apt install linux-image-siduction-amd64   linux-headers-siduction-amd64
I got the following errors:

Quote
run-parts: /etc/kernel/postinst.d/dkms exited with return code 11
dpkg: error processing package linux-image-6.8.3-1-siduction-amd64 (--configure):
 installed linux-image-6.8.3-1-siduction-amd64 package post-installation script subprocess returned error exit status 11
dpkg: dependency problems prevent configuration of linux-headers-siduction-amd64:
 linux-headers-siduction-amd64 depends on linux-headers-6.8.3-1-siduction-amd64 (= 6.8-3); however:
  Package linux-headers-6.8.3-1-siduction-amd64 is not configured yet.

dpkg: error processing package linux-headers-siduction-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-siduction-amd64:
 linux-image-siduction-amd64 depends on linux-image-6.8.3-1-siduction-amd64 (= 6.8-3); however:
  Package linux-image-6.8.3-1-siduction-amd64 is not configured yet.

dpkg: error processing package linux-image-siduction-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-headers-6.8.3-1-siduction-amd64
 linux-image-6.8.3-1-siduction-amd64
 linux-headers-siduction-amd64
 linux-image-siduction-amd64
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

After that I tried the apt install -f and I got the previous error again.
Is something that I can do?
48
Software - Support / Re: Nouveau ----> Nvidia, trouble changing driver
« Last post by ro_sid on 2024/04/04, 17:42:51 »
Thanks for reporting. I am really mystified! Your system must be something special :).
I have looked it up in "my" configuration: the package "nvidia-kernel-support" should make it impossible for the nouveau driver/module to load by blacklisting it. That package is normally installed by the nvidia driver metapackage.

At this time, I am clueless, sorry.
50
Upgrade Warnings / Re: Attention! Malicious Software in testing and sid
« Last post by sotnik on 2024/04/04, 11:04:15 »
I do not know the consequences of the problem. But I would like to say that in recent days I have noticed for a very short period of time the CPU going to 100% for no apparent reason. Also, the illuminated keyboard flashes (again for no apparent reason.
I don't know if it is related to the problem but I am reporting it.
Pages: 1 ... 3 4 [5] 6 7 ... 10