Welcome, Guest. Please login or register.
Did you miss your activation email?

Recent Posts

Pages: 1 ... 7 8 [9] 10
81
Wenn das Vertrauen fehlt, zu einen OS wechseln was nach Stand der Dinge nicht betroffen ist?

Wohin willst Du denn wechseln? Die Alternativen sind ja endlich. Winows und Mac sind für mich per se nicht wirklich als vertrauenswürdig zu bezeichnen. Was bleibt denn da noch, wenn man das Vertrauen in Linux verloren hat? FreeBSD? Unix? FreeDOS?

Einfach ein Systemd-freies Linux zu nutzen ist ja auch keine Alternative, wenn ich generell das Vertrauen in das System verloren habe. Schadcode kann ja letztendlich überall untergebracht werden, es spielt keine Rolle ob closed oder open source, völlig egal, welches init System.

Die einzige wirklich sichere Alternative ist in meinen Augen, den Stecker zu ziehen.   
Nein, ein Systemwechsel kommt für mich aktuell nicht in Frage. Es bleibt zu hoffen, dass man sich sicherheitsrelevante Projekte nochmals genau anschaut und man, falls in der Vergangenheit schonmal was eingebaut wurde, das dann auch findet. 
82
Upgrade Warnings / Re: Attention! Malicious Software in testing and sid
« Last post by Balou on 2024/04/01, 13:22:21 »
Kann man darauf vertrauen, dass die Pakete clean sind?

Im Moment neige ich dazu dass was aktuell angeboten für clean zu halten. Okay mit dem Stand der Informationen die man jetzt hat.
Ein Problem ist bekannt und bevor man jetzt eine Aktualisierung freigibt kann man auf die Schwachstelle prüfen.
Aber war das jetzt alles oder nur die Spitze des Eisbergs? Das ist nicht eine Sicherlücke weil schlecht programmiert wurde, hier wurde mit krimineller Energie eine Backdoor eingebaut. Da schleicht sich mir ein Gedanke ein ob wir nicht alle schon ein "Ostergeschenk" uns eingefangen haben, nur noch nicht entdeckt.

Wenn das Vertrauen fehlt, zu einen OS wechseln was nach Stand der Dinge nicht betroffen ist?

Balou


83
Upgrade Warnings / Re: Attention! Malicious Software in testing and sid
« Last post by edlin on 2024/04/01, 11:29:56 »
In dem Zusammenhang stellt sich mir auch die Frage, wie man im Moment mit Aktualisierungen umgehen sollte. Momentan biedern sich bei mir gerade 117 Pakete an. Kann man darauf vertrauen, dass die Pakete clean sind?

edlin
84
Upgrade Warnings / Re: Attention! Malicious Software in testing and sid
« Last post by devil on 2024/04/01, 07:00:30 »
Debian 12.6 ist zunächst mal auf unbestimmte Zeit verschoben. Eine Tiefenanalyse der Debian Repositories soll klären, inwieweit die xz Backdoor an anderer Stelle Spuren hinterlassen hat.
85
I was able to solve it based on the make error, I had to reinstall the linux-headers:

Code: [Select]
sudo apt install --reinstall linux-headers-$(uname -r)
Thx a lot for your help!

Edit:
Before I installed the generic Linux headers:
Code: [Select]
sudo apt install linux-headers-generic
86
Vielen Dank! Thx a lot!

I changed the repo and get a better error:
Ich habe das Repo geändert und bekomme einen besseren Fehler:
Code: [Select]
Setting up nvidia-kernel-dkms (550.67-0siduction2) ...
Removing old nvidia-current-550.67 DKMS files...
Deleting module nvidia-current-550.67 completely from the DKMS tree.
Loading new nvidia-current-550.67 DKMS files...
Building for 6.8.2-1-siduction-amd64
Building initial module for 6.8.2-1-siduction-amd64
Error! Bad return status for module build on kernel: 6.8.2-1-siduction-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/550.67/build/make.log for more information.
dpkg: error processing package nvidia-kernel-dkms (--configure):
 installed nvidia-kernel-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of nvidia-driver:
 nvidia-driver depends on nvidia-kernel-dkms (= 550.67-0siduction2) | nvidia-kernel-550.67 | nvidia-open-kernel-550.67; however:
  Package nvidia-kernel-dkms is not configured yet.
  Package nvidia-kernel-550.67 is not installed.
  Package nvidia-kernel-dkms which provides nvidia-kernel-550.67 is not configured yet.
  Package nvidia-open-kernel-550.67 is not installed.

dpkg: error processing package nvidia-driver (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nvidia-kernel-dkms
 nvidia-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)

Log in /var/lib/dkms/nvidia-current/550.67/build/make.log contains/enthält:

Code: [Select]
DKMS make.log for nvidia-current-550.67 for kernel 6.8.2-1-siduction-amd64 (x86_64)
Mo 1. Apr 00:26:05 CEST 2024
make V=1 -C /lib/modules/6.8.2-1-siduction-amd64/build M=/var/lib/dkms/nvidia-current/550.67/build ARCH=x86_64 NV_KERNEL_SOURCES=/lib/modules/6.8.2-1-siduction-amd64/build NV_KERNEL_OUTPUT=/lib/modules/6.8.2-1-siduction-amd64/build NV_KERNEL_MODULES="nvidia nvidia-uvm nvidia-modeset nvidia-drm nvidia-peermem" INSTALL_MOD_DIR="kernel/drivers/video" NV_SPECTRE_V2=0 modules
make[1]: Entering directory '/usr/src/linux-headers-6.8.2-1-siduction-amd64'
make --no-print-directory -C /usr/src/linux-headers-6.8.2-1-siduction-amd64 \
-f /usr/src/linux-headers-6.8.2-1-siduction-amd64/Makefile modules

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.

make[2]: *** [/usr/src/linux-headers-6.8.2-1-siduction-amd64/Makefile:809: include/config/auto.conf] Error 1
make[1]: *** [Makefile:252: __sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-6.8.2-1-siduction-amd64'
make: *** [Makefile:85: modules] Error 2
87
Quote
driver: nouveau v: kernel

seems odd
88
Upgrade Warnings / Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Last post by dibl on 2024/03/31, 23:12:07 »

Nvidia hat wohl vor kurzem die 550-Treiber https://www.nvidia.com/download/driverResults.aspx/223432/en-us/ ausgerollt.

The 550.x driver is available in the siduction fixes repo:

deb  https://liquorix.net/siduction/fixes unstable main contrib non-free non-free-firmware

(use your mirror)


One one machine, it installed correctly and is working well:

Code: [Select]
don@Hibiscus:~$ inxi -SG
System:
  Host: Hibiscus Kernel: 6.7.6-1-siduction-amd64 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 5.27.10 Distro: siduction 22.1.2 Masters_of_War -
    kde - (202303151559)
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] driver: nvidia v: 550.67
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4 driver: X:
    loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia
    resolution: 1366x768~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67
    renderer: NVIDIA GeForce GTX 750 Ti/PCIe/SSE2
   
   
However, on another machine, it appeared to install correctly, but it broke the transition to graphical.target, so booting to the desktop hangs there and the desktop does not come up.

Code: [Select]
don@dibl-MOW:~$ inxi -SG
System:
  Host: dibl-MOW Kernel: 6.7.6-1-siduction-amd64 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 5.27.10 Distro: siduction 22.1.2 Masters_of_War -
    kde - (202303151559)
Graphics:
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nouveau v: kernel
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: nouveau gpu: nouveau
    resolution: 1: 1920x1200~60Hz 2: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: nouveau,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 24.0.4-1 renderer: NV136

So this one is now using the nouveau driver (which actually looks pretty good ...).

Tomorrow if time permits, I will try again with the new driver and see if I can find out what is going wrong.


Entschuldigung sie, bitte, für englisch.



89
Super, danke, einen Schritt weiter:

Code: [Select]
The following packages have unmet dependencies:
 nvidia-driver : Depends: nvidia-kernel-dkms (= 550.67-0siduction2) but 535.161.08-1 is installed or
                          nvidia-kernel-550.67 or
                          nvidia-open-kernel-550.67 but it is not installable
                 Recommends: nvidia-settings (>= 550) but 535.171.04-1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Nvidia hat wohl vor kurzem die 550-Treiber https://www.nvidia.com/download/driverResults.aspx/223432/en-us/ ausgerollt.
90
Upgrade Warnings / Re: Nvidia-Treiber Modulbau schlägt mit Kernel 6.8 fehl
« Last post by towo on 2024/03/31, 20:00:30 »
Code: [Select]
deb https://packages.siduction.org/extra unstable non-free contrib non-free-firmware
Dann klappts auch mit dem Treiber.
Pages: 1 ... 7 8 [9] 10