seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2017/09/21, 03:35:08


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: erledigt - Fehler beim du am 12.09.17  (Read 70 times)

0 Members and 1 Guest are viewing this topic.

Offline jure

  • User
  • Posts: 329
erledigt - Fehler beim du am 12.09.17
« on: 2017/09/13, 17:39:53 »
Hallo zusammen

beim gestrigen apt dist-upgrade hatte ich seit langem mal einen Fehler, den ich bisher nicht lösen konnte.
Weder ein "apt --fix-broken install" oder "apt install -f" oder "dpkg -i --force-overwrite /var/cache/apt/archives/libgnuradio-xx" hat das Problem gelöst. Würde eine Löschen der Liste per "rm -rf /var/lib/apt/list/* && apt-get update" helfen oder was sonst muss/kann ich machen  um die Abhängigkeitsprobleme zu lösen :-[

Code: [Select]
Host: siductionbox Kernel: 4.13.0-towo.2-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.8.7
           Distro: Debian GNU/Linux buster/sid

Code: [Select]
apt dist-upgrade (gestern)
........
Vorbereitung zum Entpacken von .../30-libgnuradio-fcdproplus3.7.11_3.7.25.4b6464b-3_amd64.deb ...
Entpacken von libgnuradio-fcdproplus3.7.11 (3.7.25.4b6464b-3) ...
dpkg: Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-XF9r5L/30-libgnuradio-fcdproplus3.7.11_3.7.25.4b6464b-3_amd64.deb (--unpack):
 Versuch, »/usr/lib/x86_64-linux-gnu/pkgconfig/gnuradio-fcdproplus.pc« zu überschreiben, welches auch in Paket libgnuradio-fcdproplus3.7.10 3.7.25.4b6464b-2+b2 ist
Vormals nicht ausgewähltes Paket libgnuradio-iqbalance3.7.11 wird gewählt.
Vorbereitung zum Entpacken von .../31-libgnuradio-iqbalance3.7.11_0.37.2-8_amd64.deb ...
Entpacken von libgnuradio-iqbalance3.7.11 (0.37.2-8) ...
dpkg: Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-XF9r5L/31-libgnuradio-iqbalance3.7.11_0.37.2-8_amd64.deb (--unpack):
 Versuch, »/usr/lib/x86_64-linux-gnu/pkgconfig/gnuradio-iqbalance.pc« zu überschreiben, welches auch in Paket libgnuradio-iqbalance3.7.10 0.37.2-7+b2 ist
.......
Fehler traten auf beim Bearbeiten von:
 /tmp/apt-dpkg-install-XF9r5L/30-libgnuradio-fcdproplus3.7.11_3.7.25.4b6464b-3_amd64.deb
 /tmp/apt-dpkg-install-XF9r5L/31-libgnuradio-iqbalance3.7.11_0.37.2-8_amd64.deb
Log ended: 2017-09-12  13:41:49

Start-Date: 2017-09-12  13:51:02
Commandline: apt --fix-broken install
Install: libgnuradio-fcdproplus3.7.11:amd64 (3.7.25.4b6464b-3, automatic), libgnuradio-iqbalance3.7.11:amd64 (0.37.2-8, automatic)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2017-09-12  13:51:03

Start-Date: 2017-09-12  13:51:20
Commandline: apt install -f
Install: libgnuradio-fcdproplus3.7.11:amd64 (3.7.25.4b6464b-3, automatic), libgnuradio-iqbalance3.7.11:amd64 (0.37.2-8, automatic)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2017-09-12  13:51:20

dpkg -i --force-overwrite /var/cache/apt/archives/libgnuradio-fcdproplus3.7.11_3.7.25.4b6464b-3_amd64.deb
(Lese Datenbank ... 344110 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libgnuradio-fcdproplus3.7.11_3.7.25.4b6464b-3_amd64.deb ...
Entpacken von libgnuradio-fcdproplus3.7.11 (3.7.25.4b6464b-3) über (3.7.25.4b6464b-3) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgnuradio-fcdproplus3.7.11:
 libgnuradio-fcdproplus3.7.11 hängt ab von libgnuradio-audio3.7.11; aber:
  Paket libgnuradio-audio3.7.11:amd64 ist noch nicht konfiguriert.
 libgnuradio-fcdproplus3.7.11 hängt ab von libgnuradio-blocks3.7.11; aber:
  Paket libgnuradio-blocks3.7.11:amd64 ist noch nicht konfiguriert.
 libgnuradio-fcdproplus3.7.11 hängt ab von libgnuradio-pmt3.7.11; aber:
  Paket libgnuradio-pmt3.7.11:amd64 ist noch nicht konfiguriert.
 libgnuradio-fcdproplus3.7.11 hängt ab von libgnuradio-runtime3.7.11; aber:
  Paket libgnuradio-runtime3.7.11:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libgnuradio-fcdproplus3.7.11 (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für libc-bin (2.24-17) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 libgnuradio-fcdproplus3.7.11

« Last Edit: 2017/09/13, 18:05:25 by jure »
Gruss Juergen

Offline jure

  • User
  • Posts: 329
Re: Fehler beim du am 12.09.17
« Reply #1 on: 2017/09/13, 18:04:56 »
ich beantworte das mal selber  :)

ja ein "rm -rf /var/lib/apt/list/* && apt-get update" hat geholfen, im Anschluss ein "apt install -f" und das du lief durch.
Ebenso das heutige auf Plasma 5.10 - bisher fehlen da noch ein paar icons in der Kontrollleiste fehlen noch...z.B. FF &TB

Gruss Juergen