Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Warning: util-linux/2.40-6 has serious error  (Read 1581 times)

Offline Pip

  • User
  • Posts: 164
[EN] Warning: util-linux/2.40-6 has serious error
« on: 2024/04/18, 18:25:44 »
In case you're updating, make sure you're not updating this just yet (though putting it on hold caused even more worry with fdisk and others to be removed). It's being looked into now. I suggest waiting a while.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1069064

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 944
Re: Warning: util-linux/2.40-6 has serious error
« Reply #1 on: 2024/04/19, 07:45:11 »
Quote
from the bugreport
[...]
util-linux-extra gained the utils ctrlaltdel, fsck.cramfs, fsck.minix,
mkfs.bfs, mkfs.cramfs, and mkfs.minix. In util-linux-extra, these now
reside below /usr/sbin while they used to reside in /sbin in util-linux
in bookworm and earlier. Hence upgrading from bookworm to sid can cause
these files to be lost.
[...]

So we are already on sid not bookworm and before!
I do not think, that will affect us.

Code: [Select]
~$ LANG=C apt policy util-linux
util-linux:
  Installed: 2.40-6
  Candidate: 2.40-6
  Version table:
 *** 2.40-6 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        500 https://ftp.uni-hannover.de/debian/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
hhl@hhl-2:~$ LANG=C apt policy util-linux
util-linux          util-linux-extra    util-linux-locales
hhl@hhl-2:~$ LANG=C apt policy util-linux-extra
util-linux-extra:
  Installed: 2.40-6
  Candidate: 2.40-6
  Version table:
 *** 2.40-6 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        500 https://ftp.uni-hannover.de/debian/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status

Code: [Select]
:~$ ls -l /sbin/mkfs.m*
-rwxr-xr-x 1 root root 129432 15. Apr 09:51 /sbin/mkfs.minix
lrwxrwxrwx 1 root root      8 18. Feb 2021  /sbin/mkfs.msdos -> mkfs.fat
hhl@hhl-2:~$ ls -l /usr/sbin/mkfs.m*
-rwxr-xr-x 1 root root 129432 15. Apr 09:51 /usr/sbin/mkfs.minix
lrwxrwxrwx 1 root root      8 18. Feb 2021  /usr/sbin/mkfs.msdos -> mkfs.fat

I updated my system from bookworm to sid/trixie long ago, and so all others should done too!

Code: [Select]
:~$ inxi -S
System:
  Host: hhl-2 Kernel: 6.8.6-1-siduction-amd64 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 5.27.10 Distro: siduction 22.1.2 Masters_of_War -
    kde - (202303151559)

:~$ cat /etc/debian_version
trixie/sid
« Last Edit: 2024/04/19, 15:18:57 by hendrikL »

Offline lanig

  • User
  • Posts: 54
Re: Warning: util-linux/2.40-6 has serious error
« Reply #2 on: 2024/04/19, 09:35:25 »
I don't know whether it is related or not, but
Code: [Select]
apt dist-upgrade                                                                             
Installing dependencies:                                                                                       
  libcares2 libmpg123-0t64 libquazip5-1t64                                                                     
                                                                                                               
Paquets suggérés :                                                                                             
  libquazip-doc                                                                                                     
                                                                                                                     
Upgrading:                                                                                                           
  audacity gstreamer1.0-plugins-good libnode-dev libnode109 libopenmpt0t64 libsndfile1 nodejs nomacs                 
                                                                                                                     
Not upgrading:                                                                                                       
  bsdextrautils libblkid-dev libfdisk1    libmount1     libuuid1 rfkill     util-linux-extra                         
  eject         libblkid1    libmount-dev libsmartcols1 mount    util-linux uuid-dev                                 
                                                                                                                     
REMOVING:                                                                                                           
  fdisk libc-ares2 libkpmcore12 libmpg123-0 libquazip5-1 partimage partitionmanager uuid-runtime           
         

I am surprised to see fdisk and partitionmanager being removed. Is it safe to dist-upgrade?

Best regards,
                                                                                                                     
       

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 944
Re: Warning: util-linux/2.40-6 has serious error
« Reply #3 on: 2024/04/19, 10:02:38 »
hi lanig,

What is the outcome of 'apt full-upgrade fdisk+ partitionmanager+'?
You can also use apt dist-upgrade <foo>+'.

Both are installed here™.

Code: [Select]
:~$ LANG=C apt policy partitionmanager fdisk
partitionmanager:
  Installed: 22.12.3-1+b1
  Candidate: 22.12.3-1+b1

fdisk:
  Installed: 2.40-6
  Candidate: 2.40-6

Offline lanig

  • User
  • Posts: 54
Re: Warning: util-linux/2.40-6 has serious error
« Reply #4 on: 2024/04/19, 14:19:39 »
OK, thanks.

My problem came from the fact that I have put on hold  util-linux-extra because of the bug report :
Code: [Select]
b1 - #1069064 - util-linux-extra: insufficient Replaces for util-linux due to /usr-move
I was confused because I haven't understood the discussion about "upgrading from bookworm". It is clear now.
« Last Edit: 2024/04/19, 14:28:33 by lanig »

Offline Pip

  • User
  • Posts: 164
Re: Warning: util-linux/2.40-6 has serious error
« Reply #5 on: 2024/04/19, 16:43:54 »
Glad it's clear. I did mention that issue with holding util-linux-extra in the original post, but not clearly enough.

As has been said, this is probably not relevant to us (actually, since hendrikL said it, it's a definite), but there's a fix being developed and it just seemed more prudent for me to wait a little while. But then, I am a coward.

Offline edlin

  • User
  • Posts: 547
Re: Warning: util-linux/2.40-6 has serious error
« Reply #6 on: 2024/04/19, 18:17:59 »
I had checked after the initial posting to see if it was already „too late“ for me. util-linux was already installed in the latest version. I then installed util-linux-extra additionally and without any problems. No package had to be removed etc.

I am therefore also of the opinion that we are not affected.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates