Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: GELÖST: *ERROR* CPU pipe A FIFO underrun (Bildschirm flackert ...)  (Read 263 times)

Offline pit

  • User
  • Posts: 208
Ich habe vor ein paar Tagen auf meinem Notebook Lenovo Thinkpad T480 Siduction neu installiert => siduction-21.2.0-farewell-kde-amd64-202109171658.iso
Das System ist auf tagesaktuellem Stand, weicht aber insofern vom Standard ab, als ich das Preining Repository eingebunden habe.
Code: [Select]
CPU: quad core Intel Core i7-8550U (-MT MCP-)
speed/min/max: 1012/400/4000 MHz Kernel: 5.15.10-2-siduction-amd64 x86_64
Intel UHD Graphics 620 driver: i915 v: kernel
Manchmal vergeht eine komplette Usersession, ohne dass das Phänomen auftritt, manchmal tritt es schon nach wenigen Minuten Betrieb auf:

Das Display zeigt während Plasma/KDE aktiv ist horizontale Störungen (eine Art farbige Schlieren, die von unten nach oben durch das Bild laufen), der Effekt verstärkt sich binnen Sekunden und dann wird das Display schwarz und zeigt auch dann nichts mehr, wenn ich via STRG + Alt + F2 auf die Konsole schalte. Bleibt mir nur noch, im Blindflug zu rebooten. Das erste Mal passiert ist das übrigens schon während der Installation, die ich aber dennoch zu Ende bringen konnte. Das Ganze tritt z.B. während der Laufzeit von Windows 10 nicht auf, ich denke nicht, dass es sich um defekte Hardware handelt.

Die relevante Meldung im Logfile (s. Zeile 29 im Anhang) sollte diese sein:

Code: [Select]
i915 0000:00:02.0: [drm] *ERROR* CPU pipe A FIFO underrun
Ich habe nach intensivem Googeln diese Grub Commandline Parameter getestet (natürlich immer gefolgt von update-grub & reboot), alle ohne Erfolg, der Fehler trat jeweils erneut auf:

Code: [Select]
#/etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet systemd.show_status=1 mitigations=off"
                                                         ^^^^^^^^^^^^
Code: [Select]
intel_idle.max_cstate=4
Code: [Select]
intel_idle.max_cstate=0
Jetzt bin ich mit meinem Latein am Ende u. frage in die Runde, ob es hier jmd. ähnlich ergangen ist (die integrierte Intel UHD Graphics 620 ist ja so exotisch nicht, CPU ist übrigens Intel Core i7-8550U) bzw. ob vielleicht sogar jmd. die Lösung kennt. Vielleicht hat sich ja auch in jüngeren Kernels was geändert und @towo fällt was ein?
« Last Edit: 2021/12/23, 20:41:57 by pit »

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.577
Code: [Select]
intel_iommu=igfx_off
als Kernel Parameter versuchen.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline pit

  • User
  • Posts: 208
@towo

Code: [Select]
intel_iommu=igfx_off
Das hatte mir heute auch schon @devil im irc empfohlen. Ich habe das gleich umgesetzt u. mittlerweile läuft das Notebook seit Stunden, ohne dass der Fehler erneut aufgetreten ist. Danke euch beiden!

Grüße,
pit