Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [gelöst] Probleme bei Einbindung einer mit LUKS verschlüsselten Partition  (Read 364 times)

Offline cs

  • User
  • Posts: 90
Hallo zusammen,

hat sich erledigt: Beim Lesen meines Posts weiter unten ist mir aufgefallen, dass ich eine veraltete UUID für die Datenpartition verwendet habe.

Jetzt klappt es mit

Code: [Select]
Daten UUID=57e2ce8c-2a30-41cf-a433-a838038d3832 none luks
in der /etc/crypttab

Lesen hilft ...

:-)

==========================

Hallo zusammen,

ich habe die neue Ausgabe "Wintersky" auf meinem Notebook installiert (übrigens herzlichen Dank dafür - auch fürs wunderschöne "Artwork"!), aber leider ein Problem bei der nachträglichen automatischen Einbindung eine luks-verschlüsselten Datenpartition in den Boot-Vorgang.

Ich kann die Daten-Partition über KDE per Passworteingabe einbinden, hätte das aber gern in den Bootvorgang integriert.

Dazu habe ich die Datenpartition in crypttab und fstab eingetragen.

Leider wird zwar das Passwort der Installationspartition korrekt beim Bootvorgang von GRUB abgefragt, aber nicht das Passwort der verschlüsselten Daten-Partition. Stattdessen kommt nach 1 min. 30 sec. ein Timeout und der Bootvorgang wird ohne erfolgreiche Einbindung der verschlüsselten Partition fortgesetzt.

Ich habe Siduction verschlüsselt auf

/dev/nvme0n1p5

installiert.

Die Datenpartition ist auf

/dev/nvme0n1p3

Die Ausgabe von blkid ist

Code: [Select]
/dev/nvme0n1p5: UUID="ed276bf8-4f48-4cb3-9df1-3ef61482f446" TYPE="crypto_LUKS" PARTLABEL="root" PARTUUID="b5eb8b3d-3a07-d942-bc75-01b6a2502589"
/dev/nvme0n1p3: UUID="57e2ce8c-2a30-41cf-a433-a838038d3832" TYPE="crypto_LUKS" PARTUUID="f4244afe-3f60-a84f-9868-2d04427eae2d"
/dev/nvme0n1p1: UUID="1820-F81A" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="0baf3ac2-6785-4114-ad55-c9a73f8ca578"
/dev/nvme0n1p4: UUID="39fd3c79-74f9-4b7b-b38c-5653ef0d32b1" TYPE="swap" PARTUUID="ec3a6398-0c08-4300-8c01-95f4b4fd79eb"
/dev/nvme0n1p2: UUID="736c4067-2fc7-4cb8-afc2-3642917c49a5" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="3ec7dad9-90d0-8944-871a-7f10985fe82c"
/dev/mapper/luks-ed276bf8-4f48-4cb3-9df1-3ef61482f446: UUID="1c9e53bb-4c78-4e11-8f00-138c6c575a47" BLOCK_SIZE="4096" TYPE="ext4"
/dev/mapper/luks-57e2ce8c-2a30-41cf-a433-a838038d3832: UUID="bb18dc91-736a-4d31-9845-d0b5a99e0349" BLOCK_SIZE="4096" TYPE="ext4"

Meine crypttab-Einträge sind

Code: [Select]
luks-ed276bf8-4f48-4cb3-9df1-3ef61482f446 UUID=ed276bf8-4f48-4cb3-9df1-3ef61482f446     /crypto_keyfile.bin luks,keyscript=/bin/cat
Daten UUID=bb18dc91-736a-4d31-9845-d0b5a99e0349 none luks

Meine fstab ist

Code: [Select]
UUID=1820-F81A                            /boot/efi      vfat    umask=0077 0 2
/dev/mapper/luks-ed276bf8-4f48-4cb3-9df1-3ef61482f446 /              ext4    defaults,noatime 0 1
/dev/mapper/Daten /media/cord/Daten ext4 auto,defaults 0 0

Den Ordner /media/cord/Daten habe ich angelegt, damit die verschlüsselte Datenpartition dort gemountet werden kann.

Code: [Select]
update-grub2
und

Code: [Select]
update-initramfs -u
habe ich ausgeführt.

Ich kann die Datenpartition auch manuell mithilfe des Passworts und dem Befehl

Code: [Select]
cryptsetup luksOpen /dev/nvme0n1p3 Daten
entschlüsseln, nur klappt das leider nicht beim Bootvorgang.

Aus irgendeinem Grund werde ich beim Bootvorgang nur nach dem Passwort der Systempartition, nicht nach dem Passwort der Datenpartition gefragt.

Das Ganze ist nur ein Schönheitsfehler, weil ich die Datenpartition natürlich auch nach dem Booten über KDE einbinden kann, aber mich wurmt, dass es nicht beim Booten klappt.

Für einen Hinweis auf das, was ich womöglich falsch mache, wäre ich sehr dankbar!

Viele Grüße

cs





« Last Edit: 2022/01/19, 19:55:18 by cs »