Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] RADEON HD6470M , Asus K42J : fglrx installation  (Read 10026 times)

wayne128

  • Guest
[EN] RADEON HD6470M , Asus K42J : fglrx installation
« on: 2011/12/25, 09:40:38 »
PROBLEM:
A. When I boot from USB stick, the siduction-xfce RC iso would provide default, safe mode etc.

Using default setting, laptop will boot into a garbage screen.

B. When I choose to boot from Safe mode, it boots up laptop, with low resolution.

Upon installation, reboot will bring up a garbage screen.
ctrl/alt/f2 or alt/f2 did not get to terminal.


The issue is related to graphic , Radeon HD6470M

So I got stuck, and decided to try xchat.

Thanks to devil , agaida and others, who helped me out to get it working.  :D


Here I shall just record the key steps to get this RC installed onto the laptop.
This should help some other users? and would certainly help me in future when I need to refer to the steps.. :)

I might have some typo error.. when I have time again I shall do these steps again to confirm it works,
If anyone spot some mistake kindly let me know so that I could amend it.

1. Boot from USB stick,
By choosing safemode, I would get the low resolution graphic working.
Run live mode.

2. Activate wireless/wired
Use ceni, to get internet.

3. Change the repos to add debian contrib and non-free
open root terminal, Open editor, such as mcedit , nano, mousepad, etc

edit /etc/apt/sources.list.d/debian.list

at the end of first line, type in contrib non-free
on second line, remove the # so as to activate the source repos, this is needed during compilation of kernel?(i guess)

after that, save the changes
get out of editor and back to terminal

4. apt-get update

5. apt-get install firmware-linux-nonfree

6. apt-get install fglrx-driver

7.check that build-essential is installed, in this case the iso had it installed.

I use apt-cache policy build-essential to check.

8. check that linux-headers is installed, in this case headers was already installed.
Same as above I use apt-cache policy linux-headers* to check

9. Install build dependencies
apt-get build-dep fglrx-driver

10. do this step
apt-get install $(apt-cache search fglrx- | awk '{print $1}')

11. make a config in xorg
aticonfig --initial --force

12 start the installation, fill up all the details
wait for installer to complete.

13 reboot
and hope for the best..

after reboot, I had the installation works! no more garbage screen. :D :)

and the resolution was default to 1366x768


Some additional help, :D
from agaida,take care of the kernel line, radeon.modeset=0 must be in every kernel line that use fglrx.

to do this

14. modify /etc/default/grub
GRUB_CMDLINE_LINUX="radeon.modeset=0"
15. run update-grub
16. do a check on /boot/grub/grub.cfg to be sure radeon.modeset=0 is in the kernel line.



One more information:
This laptop runs cool! thanks to the RC iso, perhaps the kernel is doing it correctly...  :)

several other distros tested, temperature may be running around 60-65degc for some, and for others 55-58degC

this one: 47-50degc for hours! with power adaptor plugged in and LCD is bright all the time. Running nice and cool :D


Thanks again on this RC release and all those who help in xchat..

just one small issue, it cannot shutdown, last line on screen was something like
'shutting down....gdm3' and hang up.

I press alt/f1 and it pops up text asking for login,
I just hit any key and it will shutdown after a few seconds.

wayne128

  • Guest
another method to install ati driver
« Reply #1 on: 2011/12/28, 11:28:44 »
tried another way to install ati proprietory driver:

1. Install as per normal to hard disk.
2. Boot from hard disk, select safemode to get into low resolution graphic
3. run Ceni to get internet
4. go to this link, download this file
http://www2.ati.com/drivers/linux/ati-driver-installer-11-12-x86.x86_64.run
5. chmod 755 ati-driver-installer-11-12-x86.x86_64.run
6. ./ati-driver-installer-11-12-x86.x86_64.run
7. just use its default setting and install driver
8. reboot.. works.. with default 1366x768 resolution  :D

blackone

  • Guest
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #2 on: 2011/12/29, 15:39:23 »
Hi there

I am curently running radeon hd2400 on my desktop.  Ok its not quite the same as yours but I also had the garbled screen upon first boot.  I was able to fix it.

You need to able the non-free repository in /etc/apt/sources.list.d/debian.list.  My entry goes like this deb
Code: [Select]
http://ftp.uk.debian.org/debian unstable main non-free (if you already know how to edit and do this and I am sorry for the patranisation).

Do an apt-get update and apt-get install linux-firmware-nonfree.  Then make sure that /etc/X11/xorg.conf has the driver section pointing to radeon.

Hopefully that will fix it - did for me.

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
Re: another method to install ati driver
« Reply #3 on: 2011/12/30, 01:44:51 »
Quote from: "wayne128"
tried another way to install ati proprietory driver:

1. Install as per normal to hard disk.
2. Boot from hard disk, select safemode to get into low resolution graphic
3. run Ceni to get internet
4. go to this link, download this file
http://www2.ati.com/drivers/linux/ati-driver-installer-11-12-x86.x86_64.run
5. chmod 755 ati-driver-installer-11-12-x86.x86_64.run
6. ./ati-driver-installer-11-12-x86.x86_64.run
7. just use its default setting and install driver
8. reboot.. works.. with default 1366x768 resolution  :D


it isn't really a solution. The folks at debian doing a real great job with the fglrx in debian non-free. So its not recommendated to use the binary from ati. BTW: This is only my opinion, but using the ati*.run directly is imho not the best idea.
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: another method to install ati driver
« Reply #4 on: 2011/12/30, 01:56:31 »
Quote

Then make sure that /etc/X11/xorg.conf has the driver section pointing to radeon.

xorg.conf for the radeon driver is not needed at all, just the leftovers from fglrx.

greetz
devil

blackone

  • Guest
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #5 on: 2011/12/30, 11:34:38 »
Quote
xorg.conf for the radeon driver is not needed at all,


Yeah I know. But the installer placed xorg.conf there with a vesa driver.  And when vesa word was replaced with radeon all hell broke loose.

I also disabled KMS.  I have noticed that KMS hinders graphic performance, and is in part the cause of the garbled graphics.

Quote
    wayne128 wrote:
tried another way to install ati proprietory driver:

1. Install as per normal to hard disk.
2. Boot from hard disk, select safemode to get into low resolution graphic
3. run Ceni to get internet
4. go to this link, download this file
http://www2.ati.com/drivers/linux/ati-d ... x86_64.run
5. chmod 755 ati-driver-installer-11-12-x86.x86_64.run
6. ./ati-driver-installer-11-12-x86.x86_64.run
7. just use its default setting and install driver
8. reboot.. works.. with default 1366x768 resolution Very Happy


I also had debain running with the official ati driver. I will have to find the instructions for installing and post them

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #6 on: 2011/12/30, 11:42:43 »
Quote
I also disabled KMS. I have noticed that KMS hinders graphic performance, and is in part the cause of the garbled graphics.

That's completly wrong and sounds like, you have not installed firmware-linux-non-free.
Btw, the vesa entry comes from the live-start with safe settings, after installing firmware-linux-nonfree, a
Code: [Select]
rm -f /etc/X11/xorg.conf

is nessesary and your radeon-card should work well.
Quote
I also had debain running with the official ati driver. I will have to find the instructions for installing and post them

Installing fglrx in debian is quite easy:
Code: [Select]
apt-get install fglrx-driver
after that
Code: [Select]
mkdir /etc/X11/xorg.conf.d
and finaly
Code: [Select]
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

blackone

  • Guest
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #7 on: 2011/12/30, 13:54:39 »
hi towo

Quote
     Quote:
I also disabled KMS. I have noticed that KMS hinders graphic performance, and is in part the cause of the garbled graphics.

That's completly wrong and sounds like, you have not installed firmware-linux-non-free.
Btw, the vesa entry comes from the live-start with safe settings, after installing firmware-linux-nonfree


Again yes I know.  But then again the screen was garbled in the live-cd.  So I re-booted into safe graphics mode.  If I was to boot into normal graphics I needed to add radeon.modeset=0 just to get graphics in the live-cd .  The same was true once installed - radeon.modeset=0 when trying to use the radeon driver.  What can I say it works for me.

I will try deleting the xorg.conf file - see what happens.

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #8 on: 2011/12/30, 13:56:24 »
And again, install firmware-linux-nonfree!
As i told you before, disabling kms is not needed, if the firmware is installed!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

blackone

  • Guest
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #9 on: 2011/12/30, 14:30:24 »
Quote from: "towo"
And again, install firmware-linux-nonfree!
As i told you before, disabling kms is not needed, if the firmware is installed!
Actually, that is already done.  And yes you are right about kms not needing to be disabled, however I find the graphics are better - quicker - with kms disabled.  But then I am using the open-source driver and not fglrx.

Offline DeepDayze

  • User
  • Posts: 457
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #10 on: 2011/12/30, 16:37:52 »
Surely I do hope the performance with KMS enabled will improve to be on par with KMS disabled. I have a thinkpad with a radeon card and found disabling KMS improves the graphics performance

Offline tuxic

  • User
  • Posts: 117
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #11 on: 2012/01/14, 14:50:42 »
I had the same problem installing with an ATI Radeon HD 4850 and after choosing the Vesa after booting,  after the install there's a garbage screen.  I've tried to open a terminal (Ctrl+Alt+F1) but it doesn't accept my login parameters as if I've tried a wrong password.  It's my fourth try and I'm a little frustrated...
"Many people live and die..., and all they do is process groceries."
                  H. Peavey

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #12 on: 2012/01/14, 15:06:16 »
For propper work, you need to install firmware-linux-nonfree and deleting /etc/X11/xorg.conf.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline tuxic

  • User
  • Posts: 117
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #13 on: 2012/01/17, 19:46:41 »
If I can't open a terminal,  how???
"Many people live and die..., and all they do is process groceries."
                  H. Peavey

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.940
RADEON HD6470M , Asus K42J : fglrx installation
« Reply #14 on: 2012/01/17, 20:08:19 »
Boot your system with radeon.modeset=0 3 as bootcheat, then you have a terminal, where you can install the firmware.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.