Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Solved: Option for installing siduction on software raid device (md) is missing  (Read 2794 times)


  • Guest
Hello and many thanks for a great distro!

I was trying to install the december 2013 KDE release, but I saw some issues with the latest installer and I had to stop.

Fist allow me to explain my setup. I have 2 disks, each sliced into two partitions:
- sda1 and sdb1 constitute one software raid0 device, for the root partition,
- sda2 and sdb2 constitute another software raid0 partition for the /home partition.
This setup allows me to reinstall my laptop without loosing the user data from /home .

With the siduction installer from spring 2013, using the graphical installer, I could choose /dev/md*** for root and /home partitions. With the siduction installer from december 2013, the /dev/md*** devices are not listed as available devices. I only see: sda1, sda2, sdb1, sdb2.

Is this a bug or a feature?
Is there a workaround?

« Last Edit: 2014/03/02, 13:44:40 by vrommium »

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
You are right, the graphical installer sucks in that particular case. You may try the cli-installer with the precreated device. I think you will run into mounting problems at restart after the installation, but this should be easy to fix.

I filed a bug for this: http://chili.siduction.org/issues/1508

i would call it a regression - there is a possible and easy workaround. Easy, if you are familar with mdadm:

* given, that you have already a Raid,add this raid-info to /etc/mdadm.conf in the live system. the livesystem should always have assembled it on start.
* become root and start cli-installer
* make a real basic setup and choose custom if the installer ask for a installation target
* /dev/md???# should be the installation target
* if the installation is done, start the installed system, you will possible encounter, that X don't start. If so, remount / writable, then manually edit your /etc/fstab to a proper value
* restart your system, it should now work - i have tested these steps in a Virtualbox VM
« Last Edit: 2014/02/28, 23:37:01 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)


  • Guest
Thanks, melmarker, for your testing! I have played with the cli-installer and I saw you can give one custom partition as a target for installation. Yet I was not ready to test the scenario directly on my laptop, without a proof-of-concept.
After reboot I will need to edit the /etc/fstab file not only for the root, but also for /home partition (it is also on a software raid partition).

I guess one could mark this entry as solved. 


  • Guest

As an update, I installed the siduction december 2013 edition on md raid0 devices.

The steps on my system (pls be carefull on yours):
- started the live installer (I used the nox x64 version of the siduction ISO)
- mounted all /dev/md** devices, as seen by the siduction live installer, and checked which /dev/md*** contains the old root partition, in order not to overwrite my /home partition by mistake
- installed siduction, with the live cli-installer, with the root partition on /dev/md126 (in my case!), by selecting the custom option
- reboot -- I got the grub error: partition /dev/md126 not found (my case!)
- I suspected the UID for root partition, in fstab, is not correct. It is not the same in the live linux, as in the installed linux, so I booted again with the live ISO and edited the line for the root partition, in fstab, from "UID=.....................  /  ..." to "/dev/md2 / ..." (in my case!)
- reboot -- edited the grub line (with "E"): searched the line where it said /dev/md126 (in my case!) and changed /dev/md126 to /dev/md/2 (in my case!) -- booted ("F10")
- the boot worked; I logged in to linux and as root I run: update-grub2, which updates the grub configs with the md devices, as seen by the installed kernel
- rebooted -- boot worked, so I knew I got the root partition right. I finished by editing the /etc/fstab to include my other md*** partition, which mounts as /home
- reboot -- checked the end result: I got a new siduction install, none of my data from /home was lost.
Happy End!

The bottom line is that the siduction live installer sees the the md devices with other designation/paths as the installed system. This generates wrong configs in the grub parameters, and maybe also in fstab.

I've seen this also in other distributions, so for an experienced user it shouldn't be a problem.
« Last Edit: 2014/03/04, 23:29:36 by vrommium »