Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Tastaturlayout DE nach Start nicht eingestellt  (Read 10454 times)

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
[DE] Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #15 on: 2015/07/21, 23:31:27 »
klasse, so machen wir das
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline der_bud

  • User
  • Posts: 1.073
  • member
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #16 on: 2015/07/22, 10:12:53 »
Back to topic? :)  c.monty, hast Du mal probiert was passiert wenn Du ganz ohne xorg.conf startest, was erkennt er da?
Die update-rc.d Warnung sind relativ 'normal', das hat was damit zu tun das /etc/init.d/$foo eigentlich deprecated ist. Gibt es im journal weitere Hinweise?
Code: [Select]
journalctl -b -p err
systemctl status kbd.service
systemctl status keyboard-setup.service
systemctl status keymap.service


(@holgerw, die Frage nach dem Desktop kam weil es je nach DE durchaus möglich wäre das erst da was passiert. Von cinnamon weiß ich nichts, wenn man bei KDE den Tastaturlayout-Switcher installiert, mehrere Layouts hinterlegt und vor dem runterfahren auf CN stellen würde, hätte man nach Login chinesische Tastatur, egal was sonst systemweit hinterlegt ist ;) )
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

c.monty

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #17 on: 2015/07/23, 22:18:08 »
Hallo!

Ich habe eine nvidia-Grafikkarte und habe einen proprietären Treiber installiert.
Nach meinem Verständnis setzt dieser die Verwendung von xorg.conf voraus.

1. Frage in diesem Zusammenhang:
Warum soll ich xorg.conf deaktivieren, wenn dort nichts fehlerhaftes drinsteht?

Im journal steht nichts relevantes zum Keyboard drin:
Code: [Select]
-- Logs begin at So 2015-07-19 14:45:20 CEST, end at Do 2015-07-23 21:56:02 CEST. --
Jul 23 21:55:06 pc1-gigabyte kernel: Failed to find cpu0 device node
Jul 23 21:55:06 pc1-gigabyte kernel: blk_update_request: I/O error, dev fd0, sector 0
Jul 23 21:55:06 pc1-gigabyte kernel: blk_update_request: I/O error, dev fd0, sector 0
Jul 23 21:55:08 pc1-gigabyte kernel: blk_update_request: I/O error, dev fd0, sector 0
Jul 23 21:55:22 pc1-gigabyte ntpd_intres[800]: host name not found: 0.debian.pool.ntp.org
Jul 23 21:55:22 pc1-gigabyte ntpd_intres[800]: host name not found: 1.debian.pool.ntp.org
Jul 23 21:55:22 pc1-gigabyte ntpd_intres[800]: host name not found: 2.debian.pool.ntp.org
Jul 23 21:55:22 pc1-gigabyte ntpd_intres[800]: host name not found: 3.debian.pool.ntp.org
Jul 23 21:55:35 pc1-gigabyte colord-sane[904]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jul 23 21:55:59 pc1-gigabyte pulseaudio[1915]: [pulseaudio] bluez4-util.c: org.bluez.Manager.GetProperties() failed: $
Jul 23 21:55:59 pc1-gigabyte pulseaudio[1915]: [pulseaudio] bluez4-util.c: org.bluez.Manager.GetProperties() failed: $
Jul 23 21:55:59 pc1-gigabyte pulseaudio[2001]: [pulseaudio] pid.c: Daemon already running.

Und hier noch die Status-Übersicht:
Code: [Select]
user@pc1-gigabyte:~$ systemctl status kbd.service
● kbd.service - LSB: Prepare console
   Loaded: loaded (/etc/init.d/kbd)
   Active: active (exited) since Do 2015-07-23 21:55:17 CEST; 13min ago
  Process: 597 ExecStart=/etc/init.d/kbd start (code=exited, status=0/SUCCESS)

Jul 23 21:55:17 pc1-gigabyte kbd[597]: Setting console screen modes.
Jul 23 21:55:17 pc1-gigabyte kbd[597]: setterm: $TERM is not defined.
user@pc1-gigabyte:~$ systemctl status keyboard-setup.service
● keyboard-setup.service - LSB: Set preliminary keymap
   Loaded: loaded (/etc/init.d/keyboard-setup)
   Active: active (exited) since Do 2015-07-23 21:55:10 CEST; 14min ago
  Process: 241 ExecStart=/etc/init.d/keyboard-setup start (code=exited, status=0/SUCCESS)

Jul 23 21:55:10 pc1-gigabyte keyboard-setup[241]: Setting preliminary keymap...done.
user@pc1-gigabyte:~$ systemctl status keymap.service
● keymap.service - LSB: Set keymap
   Loaded: loaded (/etc/init.d/keymap.sh)
   Active: active (exited) since Do 2015-07-23 21:55:08 CEST; 14min ago
  Process: 239 ExecStart=/etc/init.d/keymap.sh start (code=exited, status=0/SUCCESS)

Inzwischen habe ich einen Workaround mit /etc/rc.local versucht, allerdings ohne den erhofften Erfolg.
Mehr dazu hier.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #18 on: 2015/07/23, 22:50:04 »
Quote
]Nach meinem Verständnis setzt dieser die Verwendung von xorg.conf voraus.
falsch, das manual hilft weiter

und bitte noch mal die die LiveIso nehmen und dann mal mit 'DE' starten - funktioniert das nicht, dann noch mal melden. erm - IRC könnte auch helfen, so wird da ein wenig ermüdend
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

c.monty

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #19 on: 2015/07/23, 23:11:49 »
Ich hatte bei der Live-CD genau dasselbe Problem mit dem Keyboard-Layout trotz DE Sprachauswahl im Bootmenü mit F2.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #20 on: 2015/07/24, 01:32:00 »
jetzt hab ich begriffen - sorry für die lange Leitung - wir reden über cinnamon ...
Sei's drum,  sollte theoretisch funktionieren, aber da sich da sowieso sehr viel geändert hat, müssen wir für das neue Release eh noch mal komplett über die Settings gehen - cinnamon war und ist manchmal ein wenig sensibel, was seine Umgebung angeht. Eventuell gibt es da was zu fixen, ich schau da auch noch mal genau drüber. Kann aber noch dauern, das Flavour ist bei der Überarbeitung noch nicht an der Reihe.

EDIT: Wenn wirklich nichts anderes mehr hilft: Desktopfile in ~/.config/autostart anlegen und damit den gewünschten setxkb ausführen lassen
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

c.monty

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #21 on: 2015/07/25, 09:40:52 »
EDIT: Wenn wirklich nichts anderes mehr hilft: Desktopfile in ~/.config/autostart anlegen und damit den gewünschten setxkb ausführen lassen

Was genau ist ein Desktopfile?
Wäre ein ausführbares bash-Script ausreichend, das in diesem Verzeichnis abgelegt ist, etwa mit diesem Inhalt?
Code: [Select]
#!/bin/sh -e
setxkbmap -model pc105 \
      -layout de \
      -variant nodeadkeys \
      -option lv3:ralt_switch,terminate:ctrl_alt_bksp
exit 0

Update:
Mit einem Bash-Script in  ~/.config/autostart funktioniert es nicht.
Es liegt aber nicht am Syntax, denn ich kann das Script über die Konsole ausführen und habe dann das gewünschte Tastaturlayout DE.
« Last Edit: 2015/07/25, 09:48:49 by c.monty »

Offline gerd

  • User
  • Posts: 147
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #22 on: 2015/07/25, 10:31:55 »
Das sollte dir weiterhelfen, wobei als Autostarter Dinge wie "Category" leer bleiben können
https://wiki.ubuntuusers.de/.desktop-dateie

c.monty

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #23 on: 2015/07/25, 10:41:23 »
Verstehe.

Wäre es dann nicht einfacher, den Befehl
Code: [Select]
setxkbmap -model pc105 -layout de -variant nodeadkeys -option lv3:ralt_switch,terminate:ctrl_alt_bkspals Startprogramm (= Autostart) einzubauen?

Offline gerd

  • User
  • Posts: 147
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #24 on: 2015/07/25, 10:45:01 »
Wenn du bereits weißt wie und wo und es funktioniert: ja.

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #25 on: 2015/07/25, 21:27:39 »
@Gerd: der Haken an der Sache ist, dass das dann nicht zwingend funktionieren muss. :P

@c.monty: Da ich grade bei einer frisch gebauten ISO in das selbe Problem gelaufen bin und es bei Gnome nicht auftritt, hab ich mal so ein kleines Desktopfile geschriieben - passt.

Code: [Select]
mkdir -p ~/.config/autostart

echo [Desktop Entry] > ~/.config/autostart/setxkb.desktop
echo Type=Application >> ~/.config/autostart/setxkb.desktop
echo Exec=setxkbmap de,pl,us >> ~/.config/autostart/setxkb.desktop
echo Name=fixfuckedxkb >> ~/.config/autostart/setxkb.desktop
ausloggen, einloggen, glücklich sein
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Maik

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #26 on: 2015/07/28, 13:52:00 »
Da hier ein sehr ähnlich gelagertes Problem vorliegt,Tastaurlayout wird einfach ignoriert und generell Standart US geladen.
Beide Wege funktionieren über Crontab
Entwerder über User (crontab -e)
Quote
@reboot Befehl
oder cron.d
Quote
@reboot Nutzer Befehl
Unüblich und Unschön  ;)

c.monty

  • Guest
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #27 on: 2015/07/29, 08:19:20 »
OK.
Ich denke man kann sich darauf verständigen, dass es mehrere Optionen gibt, dieses Problem zu beheben.
Bei mir funktioniert beispielsweise die Option mit Autostart-Befehl.
Aber das sind ja alles keine Lösungen, sondern nur Workarounds.

Sollte hierfür ein Bug geöffnet werden, damit dies final gefixed wird?

Offline melmarker

  • User
  • Posts: 2.799
    • g-com.eu
Re: Tastaturlayout DE nach Start nicht eingestellt
« Reply #28 on: 2015/07/29, 09:53:23 »
Nein
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)