Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] apt messages "User sessions running outdated binaries"  (Read 23650 times)

Offline vayu

  • User
  • Posts: 232
On my new install I'm getting new messages from apt. "User sessions running outdated binaries". It seems like it takes a long time for apt to tell me this.  How can I turn this off?

Also do I need "No services need to be restarted. No containers need to be restarted."? Can I set it to restart if needed?
« Last Edit: 2018/01/15, 16:25:58 by vayu »

Offline piper

  • User
  • Posts: 1.785
  • we are the priests ... of the temples of syrinx
Re: apt messages "User sessions running outdated binaries"
« Reply #1 on: 2018/01/15, 13:36:26 »
Can I see

Code: [Select]
needrestart -v
From my experience needrestart had quite a few false positives last time I used it, granted, that was late 2016 early 2017, I purged it and never looked back

I didn't list all (google it)

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=843778
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=828103 - suppose to be fixed



Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline vayu

  • User
  • Posts: 232
Re: apt messages "User sessions running outdated binaries"
« Reply #2 on: 2018/01/15, 16:25:29 »
Thanks so much. I deleted needrestart. It's much better now.

Offline DriverDevel

  • Newbie
  • Posts: 1
Potentially helpful issue details:
On my LMDE 5(?), behaviour of the needrestart package will cause annoying lockups / hangs on each apt activity.
I diagnosed this via
Code: [Select]
# needrestart -vwhich reported
[/etc/needrestart/notify.d/400-notify-send] notify user [USERNAME] on :0
The /etc/needrestart/notify.d/400-notify-send script
uses
NSEND='/usr/bin/notify-send'
Doing
Code: [Select]
/usr/bin/notify-send SomeTextas plain user does work (clickable notification popup successfully displayed), but as apt installation context (administrative user) does not work (long hang / almost-lockup).
Reason for notify-send failure? Unknown / more (Internet?) investigation needed.
Possibly a bug report about mal-functioning needrestart package should be filed.
Ah, a related bug:
"needrestart: notify-send timeout instead of notify"
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1024426 

HTH!