Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] graphical.target does not start  (Read 2367 times)

Offline EdSid

  • User
  • Posts: 8
[EN] graphical.target does not start
« on: 2023/07/09, 18:27:57 »
This problem appeard after upgrade and confirming the defaults - I think there was a new config file, that I should have taken.
Before that the (LUKS crypted) system starts up into the XFCE desktop, now it stops with login prompt. Username, password and startx then opens the desktop without further problems.

On startup there are the messages:

[OK] Reached target multi-user.target - Multi-User System.
[OK] Reached target graphical.target - Graphical Interface
         Starting systemd-update-utmp-runlevel.service - Record Runlevel Change ...
[OK] Finished systemd-update-utmp-runlevel.service - Record Runlevel Change ...

I wonder, how to get these messages without making a photo, dmesg and "journalctl -b" doesn't show this.

After that the prompt appears, so I tried to set the runlevel by systemd:

systemctl enable graphical.target --force
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled or disabled using systemctl.
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

Do I understand right "The graphical.target is not meant to be enabled by systemd"? But how to enable it, the former runlevel configuration is empty.

Offline EdSid

  • User
  • Posts: 8
Re: graphical.target does not start
« Reply #1 on: 2023/07/11, 10:00:32 »
I solved the problem by installation of Manjaro, this keeps working after upgrade.