Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Radeon RX 6300 -- Cannot start SDDM  (Read 4641 times)

Offline finotti

  • User
  • Posts: 273
[EN] Radeon RX 6300 -- Cannot start SDDM
« on: 2023/05/27, 21:15:15 »
I've just installed siduction on a new desktop with a Radeon RX 6300 card.

When starting the computer, I do not get to SDDM, and get the following errors:

Code: [Select]
[snip]
[font=monospace][color=#000000][     3.942] (II) Loading sub module "fbdevhw" [/color]
[     3.942] (II) LoadModule: "fbdevhw"
[     3.942] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[     3.942] (II) Module fbdevhw: vendor="X.Org Foundation"
[     3.942]    compiled for 1.21.1.7, module version = 0.0.2
[     3.942]    ABI class: X.Org Video Driver, version 25.2
[     3.942] (EE) Unable to find a valid framebuffer device
[     3.942] (WW) Falling back to old probe method for fbdev
[     3.942] (II) Loading sub module "fbdevhw"
[     3.942] (II) LoadModule: "fbdevhw"
[     3.942] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[     3.942] (II) Module fbdevhw: vendor="X.Org Foundation"
[     3.942]    compiled for 1.21.1.7, module version = 0.0.2
[     3.942]    ABI class: X.Org Video Driver, version 25.2
[     3.942] (EE) open /dev/fb0: No such file or directory
[     3.942] vesa: Ignoring device with a bound kernel driver
[     3.942] (II) modeset(G0): using drv /dev/dri/card0
[     3.943] (EE) Screen 0 deleted because of no matching config section.
[     3.943] (II) UnloadModule: "modesetting"
[     3.943] (EE) Screen 1 deleted because of no matching config section.
[     3.943] (II) UnloadModule: "fbdev"
[     3.943] (II) UnloadSubModule: "fbdevhw"
[     3.943] (EE) Screen 1 deleted because of no matching config section.
[     3.943] (II) UnloadModule: "vesa"
[     3.943] (EE)  
Fatal server error:
[     3.943] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[     3.943] (EE)  
[     3.943] (EE)  
Please consult the The X.Org Foundation support  
         at http://wiki.x.org
 for help.  
[     3.943] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     3.943] (EE)  
[     3.943] (EE) Server terminated with error (1). Closing log file.
 [/font]

On the other hand, I can start it with startplasma-wayland.  Any ideas of what could be wrong?

More info:

Code: [Select]
# inxi -G
Graphics:
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] driver: i915 v: kernel
  Device-2: AMD Navi 24 [Radeon RX 6300] driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 1.22.1.9 with: Xwayland v: 22.1.9
    compositor: kwin_wayland driver: X: loaded: radeon
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu
    resolution: 2560x1440~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon RX 6300 (navi24 LLVM
    15.0.6 DRM 3.52 6.3.4-1-siduction-amd64)


Code: [Select]
# inxi -v5
System:
  Host: dell7010 Kernel: 6.3.4-1-siduction-amd64 arch: x86_64 bits: 64
    compiler: gcc v: 12.2.0 Desktop: KDE Plasma v: 5.27.2 Distro: siduction
    22.1.2 Masters_of_War - kde - (202303220911) base: Debian GNU/Linux 12
    (bookworm)
Machine:
  Type: Desktop System: Dell product: OptiPlex SFF Plus 7010 v: N/A
    serial: 765VCX3
  Mobo: Dell model: 0YGWFV v: A00 serial: /765VCX3/CNFCW0032L00AJ/
    UEFI: Dell v: 1.1.2 date: 02/24/2023
Memory:
  System RAM: available: 125.5 GiB used: 4.39 GiB (3.5%)
  Array-1: capacity: 128 GiB slots: 4 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: DIMM1 type: DDR5 size: 32 GiB speed: spec: 4800 MT/s
    actual: 3600 MT/s
  Device-2: DIMM2 type: DDR5 size: 32 GiB speed: spec: 4800 MT/s
    actual: 3600 MT/s
  Device-3: DIMM3 type: DDR5 size: 32 GiB speed: spec: 4800 MT/s
    actual: 3600 MT/s
  Device-4: DIMM4 type: DDR5 size: 32 GiB speed: spec: 4800 MT/s
    actual: 3600 MT/s
CPU:
  Info: 24-core model: 13th Gen Intel Core i9-13900 bits: 64 type: MCP
    smt: disabled arch: Raptor Lake rev: 1 cache: L1: 2.1 MiB L2: 32 MiB
    L3: 36 MiB
  Speed (MHz): avg: 1896 high: 2009 min/max: 800/5300:5600:4200 cores:
    1: 2000 2: 2000 3: 2000 4: 2000 5: 2000 6: 983 7: 800 8: 2009 9: 2000
    10: 2000 11: 2000 12: 2000 13: 2000 14: 2000 15: 2000 16: 2000 17: 2000
    18: 2000 19: 2000 20: 2000 21: 2000 22: 1724 23: 2000 24: 2000
    bogomips: 95846
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Dell
    driver: i915 v: kernel arch: Gen-13 bus-ID: 00:02.0
  Device-2: AMD Navi 24 [Radeon RX 6300] vendor: Dell driver: amdgpu
    v: kernel arch: RDNA-2 bus-ID: 03:00.0
  Display: wayland server: X.Org v: 1.22.1.9 with: Xwayland v: 22.1.9
    compositor: kwin_wayland driver: X: loaded: radeon
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu
    resolution: 2560x1440~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon RX 6300 (navi24 LLVM
    15.0.6 DRM 3.52 6.3.4-1-siduction-amd64) direct-render: Yes
Audio:
  Device-1: Intel Alder Lake-S HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    bus-ID: 03:00.1
  API: ALSA v: k6.3.4-1-siduction-amd64 status: kernel-api
  Server-1: PipeWire v: 0.3.65 status: active
Network:
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full
    mac: cc:96:e5:1f:61:3b
Drives:
  Local Storage: total: 476.94 GiB used: 86.54 GiB (18.1%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC801 NVMe 512GB
    size: 476.94 GiB temp: 35.9 C
  Optical-1: /dev/sr0 vendor: PLDS model: DVD+-RW DU-8A5LH rev: 6D1M
    dev-links: cdrom
Partition:
  ID-1: / size: 459.43 GiB used: 86.54 GiB (18.8%) fs: ext4
    dev: /dev/nvme0n1p2 label: N/A uuid: d62d5ab4-1ceb-4b05-b9d3-7b9eb92feafd
  ID-2: /boot/efi size: 299.4 MiB used: 152 KiB (0.0%) fs: vfat
    dev: /dev/nvme0n1p1 label: -r uuid: 29D8-3B25
Swap:
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3 label: swap uuid: 3e0f2e0a-58a8-4cdf-9e79-f91873584668
Sensors:
  System Temperatures: cpu: 43.0 C mobo: 41.0 C sodimm: Mem C gpu: amdgpu
    temp: 42.0 C
  Fan Speeds (RPM): cpu: 867 gpu: amdgpu fan: 0
Info:
  Processes: 429 Uptime: 7m Init: systemd target: graphical (5) Compilers:
  gcc: 12.2.0 Packages: 3703 Shell: Bash v: 5.2.15 inxi: 3.3.27


Offline finotti

  • User
  • Posts: 273
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #1 on: 2023/05/27, 22:06:40 »
FWIW, I tried specifying the PCI:

Code: [Select]
$ lspci
00:00.0 Host bridge: Intel Corporation Device a700 (rev 01)
00:01.0 PCI bridge: Intel Corporation Device a70d (rev 01)
00:02.0 Display controller: Intel Corporation Raptor Lake-S GT1 [UHD Graphics 770] (rev 04)
00:04.0 Signal processing controller: Intel Corporation Device a71d (rev 01)
00:08.0 System peripheral: Intel Corporation GNA Scoring Accelerator module (rev 01)
00:14.0 USB controller: Intel Corporation Alder Lake-S PCH USB 3.2 Gen 2x2 XHCI Controller (rev 11)
00:14.2 RAM memory: Intel Corporation Alder Lake-S PCH Shared SRAM (rev 11)
00:15.0 Serial bus controller: Intel Corporation Alder Lake-S PCH Serial IO I2C Controller #0 (rev 11)
00:16.0 Communication controller: Intel Corporation Alder Lake-S PCH HECI Controller #1 (rev 11)
00:17.0 SATA controller: Intel Corporation Alder Lake-S PCH SATA Controller [AHCI Mode] (rev 11)
00:1b.0 PCI bridge: Intel Corporation Device 7ac4 (rev 11)
00:1f.0 ISA bridge: Intel Corporation Device 7a83 (rev 11)
00:1f.3 Audio device: Intel Corporation Alder Lake-S HD Audio Controller (rev 11)
00:1f.4 SMBus: Intel Corporation Alder Lake-S PCH SMBus Controller (rev 11)
00:1f.5 Serial bus controller: Intel Corporation Alder Lake-S PCH SPI Controller (rev 11)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (17) I219-LM (rev 11)
01:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Upstream Port of PCI Express Switch
02:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Downstream Port of PCI Express Switch
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 24 [Radeon RX 6300]
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Navi 21/23 HDMI/DP Audio Controller
04:00.0 Non-Volatile memory controller: SK hynix Platinum P41 NVMe Solid State Drive 2TB


Code: [Select]
$ cat /etc/X11/xorg.conf.d/52-active_gpu.conf
Section “Screen”
    Identifier  “Default Screen”
    Device      “Card0”
EndSection

Section "Device"
        Identifier  "Card0"
        BusID      "PCI:3:0:0"
EndSection


But it did not work...

Online eriefisher

  • User
  • Posts: 268
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #2 on: 2023/05/28, 12:56:38 »
This is a desktop yes? Not a laptop. Are you running multiple monitors? 

Offline finotti

  • User
  • Posts: 273
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #3 on: 2023/05/28, 13:07:11 »
This is a desktop yes? Not a laptop. Are you running multiple monitors?
Yes, a desktop.  I am not running multiple monitors yet, but I will add one, or maybe two more shortly.

Online eriefisher

  • User
  • Posts: 268
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #4 on: 2023/05/28, 14:17:13 »
Which chip is the monitor connected to? It appears to be the AMD but on boot it's looking for a monitor on the Intel and failing. Can you switch over or connect a second monitor?

Offline finotti

  • User
  • Posts: 273
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #5 on: 2023/05/28, 14:19:55 »
Which chip is the monitor connected to? It appears to be the AMD but on boot it's looking for a monitor on the Intel and failing. Can you switch over or connect a second monitor?
Yes, I forgot to mention it, but it does work when I connect the monitor to the motherboard (Intel card).  But I would like to use the AMD, since the intel should take resources from the CPU (if I understand it correctly).

Offline finotti

  • User
  • Posts: 273
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #6 on: 2023/05/28, 15:30:52 »
It seems I have solved the problem, by properly editing my config file.  Now I have:

Code: [Select]
Section "Monitor"
    Identifier "DisplayPort-1-4"
EndSection

Section "Screen"
    Identifier  "Dell2"
    Device      "Card1"
    Monitor    "DisplayPort-1-4"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "intel"
        BusID      "PCI:0:2:0"
EndSection

Section "Device"
        Identifier  "Card1"
        Driver      "amdgpu"
        BusID      "PCI:3:0:0"
EndSection


To get the monitor ID I did:

Code: [Select]
cat /var/log/Xorg.0.log | grep EDID

I will test it a little more before marking it solved.

Offline finotti

  • User
  • Posts: 273
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #7 on: 2023/05/28, 15:43:44 »
Spoke to soon...

After failing to start SDDM at boot, issuing "service sddm restart" works, but it still fails at boot.  Here is the failed log:

Code: [Select]
[    3.844] (--) Log file renamed from "/var/log/Xorg.pid-1378.log" to "/var/log/Xorg.0.log"
[    3.845]
X.Org X Server 1.21.1.7
X Protocol Version 11, Revision 0
[    3.845] Current Operating System: Linux dell7010 6.3.4-1-siduction-amd64 #1 SMP PREEMPT_DYNAMIC siduction 6.3-4 (2023-05-25) x86_64
[    3.845] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-6.3.4-1-siduction-amd64 root=UUID=d62d5ab4-1ceb-4b05-b9d3-7b9eb92feafd ro quiet resume=UUID=3e0f2e0a-58a8-4cdf-9e79-f91873584668 systemd.show_status=1
[    3.845] xorg-server 2:21.1.7-3 (https://www.debian.org/support)
[    3.845] Current version of pixman: 0.42.2
[    3.845]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    3.845] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    3.845] (==) Log file: "/var/log/Xorg.0.log", Time: Sun May 28 09:33:23 2023
[    3.846] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    3.846] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    3.847] (==) No Layout section.  Using the first Screen section.
[    3.847] (**) |-->Screen "Dell2" (0)
[    3.847] (**) |  |-->Monitor "DisplayPort-1-4"
[    3.847] (**) |  |-->Device "Card1"
[    3.847] (**) |  |-->GPUDevice "Card0"
[    3.847] (==) Automatically adding devices
[    3.847] (==) Automatically enabling devices
[    3.847] (==) Automatically adding GPU devices
[    3.847] (==) Automatically binding GPU devices
[    3.847] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    3.848] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    3.848]    Entry deleted from font path.
[    3.850] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        built-ins
[    3.850] (==) ModulePath set to "/usr/lib/xorg/modules"
[    3.850] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    3.850] (II) Loader magic: 0x55a847c6df00
[    3.850] (II) Module ABI versions:
[    3.850]    X.Org ANSI C Emulation: 0.4
[    3.850]    X.Org Video Driver: 25.2
[    3.850]    X.Org XInput driver : 24.4
[    3.850]    X.Org Server Extension : 10.0
[    3.850] (++) using VT number 7

[    3.850] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    3.850] (II) xfree86: Adding drm device (/dev/dri/card0)
[    3.850] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[    3.852] (--) PCI: (0@0:2:0) 8086:a780:1028:0bd0 rev 4, Mem @ 0x6011000000/16777216, 0x4000000000/268435456, I/O @ 0x00004000/64
[    3.852] (--) PCI:*(3@0:0:0) 1002:7424:1028:0040 rev 0, Mem @ 0x4100000000/2147483648, 0x4180000000/2097152, 0x70500000/1048576, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[    3.853] (II) LoadModule: "glx"
[    3.853] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    3.856] (II) Module glx: vendor="X.Org Foundation"
[    3.856]    compiled for 1.21.1.7, module version = 1.0.0
[    3.856]    ABI class: X.Org Server Extension, version 10.0
[    3.856] (II) LoadModule: "amdgpu"
[    3.856] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[    3.858] (II) Module amdgpu: vendor="X.Org Foundation"
[    3.858]    compiled for 1.21.1.7, module version = 23.0.0
[    3.858]    Module class: X.Org Video Driver
[    3.858]    ABI class: X.Org Video Driver, version 25.2
[    3.858] (II) LoadModule: "intel"
[    3.858] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    3.859] (II) Module intel: vendor="X.Org Foundation"
[    3.859]    compiled for 1.21.1.3, module version = 2.99.917
[    3.859]    Module class: X.Org Video Driver
[    3.859]    ABI class: X.Org Video Driver, version 25.2
[    3.859] (II) AMDGPU: Driver for AMD Radeon:
        All GPUs supported by the amdgpu kernel driver
[    3.859] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    3.859] (II) intel: Driver for Intel(R) HD Graphics
[    3.859] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    3.859] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    3.860] (II) AMDGPU(0): [KMS] Kernel modesetting enabled.
[    3.860] (EE) AMDGPU(0): [drm] Failed to open DRM device for pci:0000:03:00.0: Invalid argument
[    3.860] (II) intel(G0): Using Kernel Mode Setting driver: i915, version 1.6.0 20201103
[    3.860] (II) intel(G0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20210115-1 (Timo Aaltonen <tjaalton@debian.org>)
[    3.860] (II) intel(G0): SNA compiled for use with valgrind
[    3.861] (EE) Screen 0 deleted because of no matching config section.
[    3.861] (II) UnloadModule: "amdgpu"
[    3.861] (EE) Device(s) detected, but none match those in the config file.
[    3.861] (EE)
Fatal server error:
[    3.861] (EE) no screens found(EE)
[    3.861] (EE)
Please consult the The X.Org Foundation support
        at http://wiki.x.org
for help.
[    3.861] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    3.861] (EE)
[    3.861] (EE) Server terminated with error (1). Closing log file.


The main error seems to be
Code: [Select]
(EE) AMDGPU(0): [drm] Failed to open DRM device for pci:0000:03:00.0: Invalid argument

Here is the one after successfully restarting SDDM: https://paste.debian.net/1281313/
« Last Edit: 2023/05/28, 15:49:12 by finotti »

Offline finotti

  • User
  • Posts: 273
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #8 on: 2023/05/28, 16:03:53 »
Sorry for the sheer amount of posts, but just in case it can help anyone see what is wrong...

If I comment out the sections Monitor and Screen from the config, SDDM "starts" with no errors, but the screen is blank.

Here is the corresponding log: https://paste.debian.net/1281314/

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #9 on: 2023/05/28, 17:40:03 »
Code: [Select]
dpkg -l | grep -i firmware
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline finotti

  • User
  • Posts: 273
Re: Radeon RX 6300 -- Cannot start SDDM
« Reply #10 on: 2023/05/28, 17:55:10 »
Code: [Select]
dpkg -l | grep -i firmware
Code: [Select]
# dpkg -l | grep -i firmware
ii  amd64-microcode                                  3.20230414.1                        amd64        Processor microcode firmware for AMD CPUs
ii  b43-fwcutter                                    1:019-8                              amd64        utility for extracting Broadcom 43xx firmware
ii  firmware-amd-graphics                            20230210-5                          all          Binary firmware for AMD/ATI graphics chips
ii  firmware-atheros                                20230210-5                          all          Binary firmware for Qualcomm Atheros wireless cards
ii  firmware-b43-installer                          1:019-8                              all          firmware installer for the b43 driver
ii  firmware-b43legacy-installer                    1:019-8                              all          firmware installer for the b43legacy driver
ii  firmware-bnx2                                    20230210-5                          all          Binary firmware for Broadcom NetXtremeII
ii  firmware-bnx2x                                  20230210-5                          all          Binary firmware for Broadcom NetXtreme II 10Gb
ii  firmware-brcm80211                              20230210-5                          all          Binary firmware for Broadcom/Cypress 802.11 wireless cards
ii  firmware-iwlwifi                                20230210-5                          all          Binary firmware for Intel Wireless cards
ii  firmware-libertas                                20230210-5                          all          Binary firmware for Marvell wireless cards
ii  firmware-linux                                  20230210-5                          all          Binary firmware for various drivers in the Linux kernel (metapackage)
ii  firmware-linux-free                              20200122-1                          all          Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree                          20230210-5                          all          Binary firmware for various drivers in the Linux kernel (metapackage)
ii  firmware-misc-nonfree                            20230210-5                          all          Binary firmware for various drivers in the Linux kernel
ii  firmware-myricom                                20230210-5                          all          Binary firmware for Myri-10G Ethernet adapters
ii  firmware-netxen                                  20230210-5                          all          Binary firmware for QLogic Intelligent Ethernet (3000 and 3100 Series)
ii  firmware-qlogic                                  20230210-5                          all          Binary firmware for QLogic HBAs
ii  firmware-realtek                                20230210-5                          all          Binary firmware for Realtek wired/wifi/BT adapters
ii  firmware-ti-connectivity                        20230210-5                          all          Binary firmware for TI Connectivity wifi and BT/FM/GPS adapters
ii  firmware-zd1211                                  1:1.5-10                            all          binary firmware for the zd1211rw wireless driver
ii  fwupd                                            1.8.12-2                            amd64        Firmware update daemon
ii  fwupd-amd64-signed                              1:1.4+1                              amd64        Tools to manage UEFI firmware updates (signed)
ii  intel-microcode                                  3.20230512.1                        amd64        Processor microcode firmware for Intel CPUs
ii  libfwupd2:amd64                                  1.8.12-2                            amd64        Firmware update daemon library
ii  ovmf                                            2022.11-6                            all          UEFI firmware for 64-bit x86 virtual machines