Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] Probleme mit broadcom4312 seit upgrade auf aptosid  (Read 12583 times)

Offline reddark

  • User
  • Posts: 1.053
    • http://www.klangruinen.de/
[DE] Probleme mit broadcom4312 seit upgrade auf aptosid
« Reply #15 on: 2010/09/14, 19:54:21 »
Bei mir is weniger

dmesg | grep b43:
Code: [Select]
[33030.671461] b43-pci-bridge 0000:06:00.0: PCI INT A disabled
[33032.062638] b43-pci-bridge 0000:06:00.0: restoring config space at offset 0x1 (was 0x100002, writing 0x100006)
[33032.074275] b43-pci-bridge 0000:06:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[33033.741158] b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)

Offline sidlix

  • User
  • Posts: 115
Probleme mit broadcom4312 seit upgrade auf aptosid
« Reply #16 on: 2010/09/16, 01:38:56 »
Hallo Zusammen,

auch ich kämpfe hier mit dem BCM 4312 rev. 1 Chipsatz im Lenovo s10. Es ist recht merkwürdig: Ich starte das Netbook vom Live-USB-Stick, kopiere den firmware Ordner B43, den ich mittels apt-get install firmeware-b43-lppy-installer auf einem anderen Rechner erstellt habe, in lib firmware auf dem Stick. Ceni findet die Karte, findet mein Wlan-Netzwerk, meldet sich an, bekommt eine IP und meldet sich Sekunden später wieder ab. Unter dem XFCE Tool habe ich dann auch unter wlan0 kein Wlan-Device (unter ceni schon). iwconfig meldet mir aber immer noch IEEE 802.11bg ESSID:"XXX", die ESSID stimmt. Aber, ich bin laut Anzeige in der Fritz-Box längst nicht mehr verbunden.....

Verzichtet ich auf den Ordner lib/firmware/b43 in  wird der Device auch erkannt (wohl über die Firmware in lib/firmware/b43-open[ sollte dieser entfernt werden??]), aber unter ceni werden keine Wlannetze gefunden. Ich finde das sehr kryptisch.

Scheint leider immer noch nicht richtig zu laufen...
Dachte erst an ein DNS-Problem (das manuelle Eintragen eines DNS-Server brachte aber auch nichts), aber es ist wohl nur eine kurzzeitige Verbindung möglich, die dann abreist, leider habe ich keine Fehlermeldung. Ich meine auch, dass alle anderen Möglichkeiten aus dem wl-Wiki von debian mit wl.lo usw, seit dem update auf den 2.6.32-Kernel nicht mehr gehen.

@grefabu
Interessanter Weise liefert mir dmesg | grep b43 den gleichen Fehler:

Code: [Select]
[   63.441252] b43-phy0 ERROR: Fatal DMA error: 0x00000800, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
[   63.441263] b43-phy0 ERROR: This device does not support DMA on your system. Please use PIO instead.
[   63.441268] b43-phy0: Controller RESET (DMA error) ...


@all
Weiß jemand, was er bedeutet??

Ich erinnere mich aber, dass der Chipsatz in 64bit-Maschinen verbaut problemlos läuft. Never ending Story...

Nach Diktat in seinem Quartier im Bett...

Grüße
Neelix
s i d l i x
... .. -.. .-.. .. -..-
debian s i d +  nee l i x

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.842
Probleme mit broadcom4312 seit upgrade auf aptosid
« Reply #17 on: 2010/09/16, 02:07:20 »
Quote

(wohl über die Firmware in lib/firmware/b43-open[ sollte dieser entfernt werden??]),

nein, muss er nicht.
sobald proprietäre firmware vorhanden ist, wird die immer bevorzugt. broabcom halt

greetz
devil

grefabu

  • Guest
Probleme mit broadcom4312 seit upgrade auf aptosid
« Reply #18 on: 2010/09/16, 07:22:47 »
@Neelix
Schön, dann binn ich wenigstens nicht allein,...

Wegen des DMA Fehlers: den bekommt man mit 'options b43 pio=1' in einer datei unter /etc/modprobe.d/ (z.B. b43.conf) weg.
Der Scan bleibt aber leer.

mich wundert es halt nur, das der Wechsel auf einen älteren Kernel auch nichts bringt. Das Problem war aber definitiv erst nach dem Upgrede auf den neuen Kernel da,...

Grefabu

grefabu

  • Guest
Probleme mit broadcom4312 seit upgrade auf aptosid
« Reply #19 on: 2010/09/16, 18:11:49 »
Sachen gibt's.

Ich setze mich heute noch mal an den Rechner.

Mit einem beherztem 'rm -rf /usr/src/broadcom-sta-modules-2.6.3*' lösche ich mal die schon mal gebauten module. Setze b43 und ssb auf blacklist. Und es funktioniert wieder!

So long, and thank you for the fisch!

Grefabu

@neelix
Falls Du Hilfe brauchst mit dem wl Treiber, schau einfach in den Link den ich in meinem ersten Beitrag eingefügt habe.

gs

  • Guest
Probleme mit broadcom4312 seit upgrade auf aptosid
« Reply #20 on: 2010/09/16, 20:38:35 »
Ich habe den wl-treiber nach dem readme bei http://www.broadcom.com/support/802.11/linux_sta.php gebaut. Auf der Seite sind auch patches für kernels über 2.6.33 etc.
Nach diesem Vorgehen funktioniert der BCM4312 einwandfrei, auch nach einem Kernel-update....