seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2017/11/21, 23:52:14


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Virtualbox doesn't start, xcb error  (Read 437 times)

0 Members and 1 Guest are viewing this topic.

Offline ajavibp

  • User
  • Posts: 79
    • The website of the association where I collaborate.
Virtualbox doesn't start, xcb error
« on: 2017/05/19, 11:59:21 »
Hello,
I'm crazy because of a VirtualBox error that I can not solve.
Quote
Qt FATAL: This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.
Reinstalling the application may fix this problem.
Of course, reinstallation does not help at all, I even got to have a full purge and it keeps the error when reinstalling.
ldd -r /usr/lib/virtualbox/VBoxRT.so shows no problems (pastebin).
ldd /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so shows no problems (pastebin).
Going manually to version 5.1.18 serves as a workaround, but I would not like to keep it that way.
Thank you very much in advance for your help.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.160
Re: Virtualbox doesn't start, xcb error
« Reply #1 on: 2017/05/19, 15:21:45 »
How did you install vbox  ? Straight from debian or downloaded from oracle ?

I have no problems (debian version)  and use it daily to test siduction and my builds

You could try as root after purge

Code: [Select]
updatedb

then reinstall


Code: [Select]
piper@x1:~$ apt policy virtualbox
virtualbox:
  Installed: 5.1.22-dfsg-1
  Candidate: 5.1.22-dfsg-1
  Version table:
 *** 5.1.22-dfsg-1 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/contrib amd64 Packages
        100 /var/lib/dpkg/status



https://www.google.com/search?q=Virtualbox+doesn%27t+start%2C+xcb+error

https://www.google.com/search?q=Qt+FATAL%3A+This+application+failed+to+start+because+it+could+not+find+or+load+the+Qt+platform+plugin+%22xcb%22+in+%22%22.
« Last Edit: 2017/05/19, 15:44:25 by piper »
debian sid  |  apt-get into it

Offline ajavibp

  • User
  • Posts: 79
    • The website of the association where I collaborate.
Re: Virtualbox doesn't start, xcb error
« Reply #2 on: 2017/05/19, 18:03:11 »
Thanks piper for your support.
I usually install it directly from debian, but I have also tried it from Oracle. Any version after 5.1.18 causes me the same error.

Of course, I already tried also with the advice of the links that you send me. That's why I said I'm crazy about this error. I use other programs that use Qt, like Kile, without any problems.

Offline Lanzi

  • User
  • Posts: 1.548
    • Preiswerter Urlaub (Zimmer und Ferienwohnungen) im Harz?
Re: Virtualbox doesn't start, xcb error
« Reply #3 on: 2017/05/20, 18:58:02 »
just a guess, biut check you ~/.virtuelbox folder if you have 0byte files.

Offline ajavibp

  • User
  • Posts: 79
    • The website of the association where I collaborate.
Re: Virtualbox doesn't start, xcb error
« Reply #4 on: 2017/05/21, 12:11:35 »
After the purge and reinstall I have no .virtualbox folder (neither similar names)  :o

Offline ajavibp

  • User
  • Posts: 79
    • The website of the association where I collaborate.
Re: Virtualbox doesn't start, xcb error
« Reply #5 on: 2017/08/30, 21:14:34 »
I still can not get the virtualbox of the repositories to work. At the moment it only works for me if I install virtualbox-5.1_5.1.26-117224-Debian-wheezy_amd64 directly.
Any ideas?

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.110
Re: Virtualbox doesn't start, xcb error
« Reply #6 on: 2017/08/30, 21:51:02 »
virtualbox-5.1_5.1.26-117224-Debian-wheezy_amd64 is absolute wrong!

You need the stretch package as minimum!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline ajavibp

  • User
  • Posts: 79
    • The website of the association where I collaborate.
Re: Virtualbox doesn't start, xcb error
« Reply #7 on: 2017/08/30, 22:31:14 »
If curious, but wheezy is the only works for me. I tried stretch, ubuntu and, of course, repository versions. 5.0 version has module compilation problems, and 5.1 doesn't start because rhe 'xcb' error. I tried all the solutions that I saw in Google too