Siduction Forum

BUGS => Bugs 2021.2 (DE/EN) => Topic started by: RedCarpet on 2021/08/04, 10:42:36

Title: [Critical] outdated (wrong) firefox package out of the box
Post by: RedCarpet on 2021/08/04, 10:42:36
Hello,

i just installed siduction and ended up with the normal "firefox" package installed.
In Debian there are two packages for firefox, the (normal) firefox package, which should be the normal firefox but which doesn't seem to have gotten an update over the past two months and the firefox-esr package.
The normal debian firefox package for debian unstable is out of date. (https://packages.debian.org/sid/firefox (https://packages.debian.org/sid/firefox))
The latest version of this "firefox" package is 88.0.1-1 and not 90.0.2 (https://en.wikipedia.org/wiki/Firefox (https://en.wikipedia.org/wiki/Firefox)).
And no, this "firefox" package is not firefox-esr its (the normal) firefox. firefox-esr is currently at 78.12.0esr-1.

Please stop installing your users outdated firefox versions which will not be updated to the current version because of the old version in the repositorys. I would suggest you to install your users the firefox-esr package, which seems to be the current firefox-esr version.
Most users will not even notice that they are using an out of date browser. I wouldn't have noticed it, if firefox wouldn't have worsened their gui in the last few versions.
Please fix this as soon as possible. Also, if you using siduction to read this, please check your firefox version, if it is up to date.

The current version according to Wikipedia: 90.0.2
The installer installed this version:
(https://i.ibb.co/b2TNg5R/yourfirefox.png)
The current version of firefox-esr:
(https://i.ibb.co/8XvCBdb/firefox-esr.png)
Title: Re: [Critical] outdated (wrong) firefox package out of the box
Post by: Carnophage on 2021/08/04, 11:39:57
Firefox package will be automatically updated right after Debian leaves the freeze period before next stable release (https://release.debian.org/bullseye/freeze_policy.html) as it is already waiting in experimental repository.

Code: [Select]
# apt policy firefox
firefox:
  Installed: 90.0-2
  Candidate: 90.0-2
  Version table:
 *** 90.0-2 100
          1 http://deb.debian.org/debian experimental/main amd64 Packages
        100 /var/lib/dpkg/status
     88.0.1-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages

Same thing goes for many more non-stable-release-critical changes. That's how thing roll when one uses Debian Unstable as base.
Title: Re: [Critical] outdated (wrong) firefox package out of the box
Post by: unklarer on 2021/08/04, 11:44:42
Quote from: RedCarpet
Please stop installing your users outdated firefox versions which will not be updated to the current version because of the old version in the repositorys. I would suggest you to install your users the firefox-esr package, which seems to be the current firefox-esr version.

Welcome to the forum!

Siduction is a rollinrelease distribution based on Debian.

Debian packages (FF88.0.1 and ESR78.12) are "frozen" until the release of Debian11, "frozen". This means that no one can change anything in the packages unless the Debian security team does it themselves.

Debian11 will be released on 08/14/2021. Then you will also find the new FF packages.
If that takes too long, you can also get/install version 90.0.2 directly from Mozilla.

Basically this has nothing to do with [Critical], it is a normal process.   :D
Title: Re: [Critical] outdated (wrong) firefox package out of the box
Post by: hendrikL on 2021/08/04, 12:57:56

[...] The released images are a snapshot of Debian unstable, that also goes by the name of Sid, from 2021-07-28.[...]ยน

1) https://siduction.org/2021/07/release-notes-for-siduction-2021-2-0/